_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


python-easy-ansi 2.1
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://gitlab.com/joeysbytes/easy-ansi
Licenses: Expat
Build system: pyproject
Synopsis: Terminal framework API
Description:

Easy ANSI is a terminal framework API to give you an easy way to use colors, cursor control movements, and line/box drawing. It is not meant as a replacement to more full-featured frameworks (such as curses or urwid), but as a tool to quickly create nice-looking screens in your terminal window. You can even create animations with the cursor controls.

python-pylru 1.2.0
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/jlhutch/pylru
Licenses: GPL 2+
Build system: pyproject
Synopsis: Least recently used (LRU) cache implementation
Description:

Pylru implements a true LRU cache along with several support classes. Pylru provides a cache class with a simple dict interface. It also provides classes to wrap any object that has a dict interface with a cache. Both write-through and write-back semantics are supported. Pylru also provides classes to wrap functions in a similar way, including a function decorator.

python-attrs 26.1.0
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/python-attrs/attrs/
Licenses: Expat
Build system: pyproject
Synopsis: Attributes without boilerplate
Description:

attrs is a Python package with class decorators that ease the chores of implementing the most common attribute-related object protocols.

python-dbfread 2.0.7-0.dce5446
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://dbfread.readthedocs.io
Licenses: Expat
Build system: pyproject
Synopsis: Read DBF Files with Python
Description:

This library reads DBF files and returns the data as native Python data types for further processing. It is primarily intended for batch jobs and one-off scripts.

python-repoze-lru 0.7
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://www.repoze.org
Licenses: Original BSD
Build system: pyproject
Synopsis: Tiny LRU cache implementation and decorator
Description:

This package provides a tiny LRU cache implementation and decorator.

python-isoduration 20.11.0
Propagated dependencies: python-arrow@1.3.0
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/bolsote/isoduration
Licenses: ISC
Build system: pyproject
Synopsis: Operations with ISO 8601 durations
Description:

ISO 8601 is most commonly known as a way to exchange datetimes in textual format. A lesser known aspect of the standard is the representation of durations. The state of the art of ISO 8601 duration handling in Python is more or less limited to what's offered by isodate. This package attempts to address the shortcomings of isodate.

python-pkgconfig 1.6.0
Dependencies: pkg-config@0.29.2
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/matze/pkgconfig
Licenses: Expat
Build system: pyproject
Synopsis: Python interface for pkg-config
Description:

This module provides a Python interface to pkg-config. It can be used to find all pkg-config packages, check if a package exists, check if a package meets certain version requirements, query CFLAGS and LDFLAGS and parse the output to build extensions with setup.py.

python-vncdotool 1.2.0
Propagated dependencies: python-pillow@12.2.0 python-pycryptodomex@3.23.0 python-twisted@25.5.0
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: http://github.com/sibson/vncdotool
Licenses: Expat
Build system: pyproject
Synopsis: Command line VNC client
Description:

This package provides a Python command line VNC client. It can be useful to automating interactions with virtual machines or hardware devices that are otherwise difficult to control.

python-click-aliases 1.0.6
Propagated dependencies: python-click@8.4.1
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/click-contrib/click-aliases
Licenses: Expat
Build system: pyproject
Synopsis: Enable aliases for Click
Description:

This package helps to add (mutiple) aliases to a click group or command.

python-logbook 1.8.2
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/getlogbook/logbook
Licenses: Modified BSD
Build system: pyproject
Synopsis: Logbook is a logging replacement for Python
Description:

Logbook is a logging system for Python that replaces the standard library’s logging module. It was designed with both complex and simple applications in mind and the idea to make logging fun.

python-icalendar 6.3.2
Propagated dependencies: python-dateutil@2.9.0 python-tzdata@2025.1
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/collective/icalendar
Licenses: FreeBSD
Build system: pyproject
Synopsis: Python library for parsing and generating iCalendar files
Description:

icalendar is a Python library for parsing and generating iCalendar files.

python-lief 1.0.0
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/lief-project/LIEF
Licenses: ASL 2.0
Build system: pyproject
Synopsis: Library to instrument executable formats
Description:

python-lief is a cross platform library which can parse, modify and abstract ELF, PE and MachO formats.

python-easy-ansi 0.3
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://gitlab.com/joeysbytes/easy-ansi
Licenses: Expat
Build system: pyproject
Synopsis: Terminal framework API
Description:

Easy ANSI is a terminal framework API to give you an easy way to use colors, cursor control movements, and line/box drawing. It is not meant as a replacement to more full-featured frameworks (such as curses or urwid), but as a tool to quickly create nice-looking screens in your terminal window. You can even create animations with the cursor controls.

python-flufl-bounce 4.0-0.e7d37db
Propagated dependencies: python-atpublic@3.1.1 python-zope-interface@7.2
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://fluflbounce.readthedocs.io/en/latest/
Licenses: ASL 2.0 LGPL 3
Build system: pyproject
Synopsis: Email bounce detectors
Description:

The flufl.bounce library provides a set of heuristics and an API for detecting the original bouncing email addresses from a bounce message. Many formats found in the wild are supported, as are VERP and RFC 3464.

python-pyan3 1.2.0
Propagated dependencies: python-jinja2@3.1.6
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/Technologicat/pyan
Licenses: GPL 2
Build system: pyproject
Synopsis: Offline call graph generator for Python 3
Description:

Pyan takes one or more Python source files, performs a (rather superficial) static analysis, and constructs a directed graph of the objects in the combined source, and how they define or use each other. The graph can be output for rendering by GraphViz or yEd.

python-hatch-argparse-manpage 1.0.0
Propagated dependencies: python-argparse-manpage@4.7 python-rich@15.0.0
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/damonlynch/hatch-argparse-manpage
Licenses: GPL 3+
Build system: pyproject
Synopsis: Hatch build hook plugin to generate manual pages
Description:

This package provides a build hook plugin for Hatch to automatically bs generate a manual page from an ArgumentParser object, using argparse-manpage by Pavel Raiskup.

python-pathable 0.4.3
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/p1c2u/pathable
Licenses: ASL 2.0
Build system: pyproject
Synopsis: Object-oriented paths
Description:

With this package you can traverse resources like paths and access resources on demand with separate accessor layer.

python-cfgv 3.4.0
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/asottile/cfgv
Licenses: Expat
Build system: pyproject
Synopsis: Configuration validation library
Description:

This library helps to validate configuration files and produce human readable error messages.

python-kombu 5.6.2
Propagated dependencies: python-amqp@5.1.1 python-packaging@26.2 python-tzdata@2025.1 python-vine@5.1.0
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://kombu.readthedocs.io
Licenses: Modified BSD
Build system: pyproject
Synopsis: Message passing library for Python
Description:

The aim of Kombu is to make messaging in Python as easy as possible by providing an idiomatic high-level interface for the AMQ protocol, and also provide proven and tested solutions to common messaging problems. AMQP is the Advanced Message Queuing Protocol, an open standard protocol for message orientation, queuing, routing, reliability and security, for which the RabbitMQ messaging server is the most popular implementation.

python-beautifultable 1.1.0
Propagated dependencies: python-wcwidth@0.2.13
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/pri22296/beautifultable
Licenses: Expat
Build system: pyproject
Synopsis: Print ASCII tables for terminals
Description:

python-beautifultable provides a class for easily printing tabular data in a visually appealing ASCII format to a terminal.

Features include, but are not limited to:

  • Full customization of the look and feel of the table

  • Row and column accessors.

  • Full support for colors using ANSI sequences or any library.

  • Plenty of predefined styles and option to create custom ones.

  • Support for Unicode characters.

  • Supports streaming table when data is slow to retrieve.

python-seaborn 0.13.2-0.32088bb
Propagated dependencies: python-matplotlib@3.10.9 python-numpy@2.4.6 python-pandas@3.0.3 python-scipy@1.17.1 python-statsmodels@0.14.6
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://seaborn.pydata.org/
Licenses: Modified BSD
Build system: pyproject
Synopsis: Statistical data visualization
Description:

Seaborn is a library for making attractive and informative statistical graphics in Python. It is built on top of matplotlib and tightly integrated with the PyData stack, including support for numpy and pandas data structures and statistical routines from scipy and statsmodels.

python-jsonrpclib-pelix 0.3.2
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/tcalmant/jsonrpclib
Licenses: ASL 2.0
Build system: pyproject
Synopsis: JSON-RPC 2.0 client library for Python
Description:

This library implements the JSON-RPC v2.0 specification (backwards-compatible) as a client library for Python. This version is a fork of jsonrpclib by Josh Marshall, usable with Pelix remote services.

python-precis-i18n 1.1.1
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/byllyfish/precis_i18n
Licenses: Expat
Build system: pyproject
Synopsis: Implementation of the PRECIS framework
Description:

This module implements the PRECIS Framework as described in RFC 8264, RFC 8265 and RFC 8266.

python-dparse 0.6.4
Propagated dependencies: python-packaging@26.2 python-toml@0.10.2
Channel: guix
Location: gnu/packages/python-xyz.scm (gnu packages python-xyz)
Home page: https://github.com/pyupio/dparse
Licenses: Expat
Build system: pyproject
Synopsis: Parser for Python dependency files
Description:

This package provides a parser for Python dependency files.

Total packages: 32836