Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides the Minitest::Retry class, which extends Minitest to allow retrying tests when they fail.
Net::SSH is a pure-Ruby implementation of the SSH2 client protocol. It allows you to write programs that invoke and interact with processes on remote servers, via SSH2.
WEBrick is an HTTP server toolkit that can be configured as an HTTPS server, a proxy server, and a virtual-host server.
This unmaintained package provides a Prawn extension that allows including other Portable Document Format (PDF) documents as background or combining several PDF documents into one. This functionality used to be part of Prawn itself, but was extracted from Prawn 0.15.0 because of its many longstanding issues.
CI::Reporter is an add-on to Ruby testing frameworks that allows you to generate XML reports of your test runs. The resulting files can be read by a continuous integration system that understands Ant's JUnit report format.
The Stud Ruby library adds a few things missing from the standard Ruby library such as:
Stud::TryRetry on failure, with back-off, where failure is any exception.
Stud::PoolGeneric resource pools.
Stud::TaskTasks (threads that can return values, exceptions, etc.)
Stud.intervalInterval execution (do X every N seconds).
Stud::BufferBatch and flush behavior.
This gem is a library that provides trigonometric and transcendental functions for complex numbers. The functions in this module accept integers, floating-point numbers or complex numbers as arguments.
This RubyGem implements topological sorting using Tarjan's algorithm for strongly connected components. It is designed to be able to be used with any object which can be interpreted as a directed graph.
Addressable is a replacement for the URI implementation that is part of Ruby's standard library. It more closely conforms to RFC 3986, RFC 3987, and RFC 6570 (level 4), providing support for IRIs and URI templates.
Colorator is a Ruby gem that helps you colorize your text for the terminal.
Module Stream defines an interface for external iterators.
RR is a test double framework that features a rich selection of double techniques and a terse syntax.
Tilt is a thin interface over a number of different Ruby template engines in an attempt to make their usage as generic as possible.
This library contains the Ruby extension that implements Protocol Buffers functionality in Ruby.
The Ruby extension makes use of generated Ruby code that defines message and enum types in a Ruby DSL. You may write definitions in this DSL directly, but we recommend using protoc's Ruby generation support with .proto files. The build process in this directory only installs the extension; you need to install protoc (in package ruby-grpc-tools) as well to have Ruby code generation functionality.
Middleware is a generalized implementation of a middleware abstraction for Ruby.
EmailReplyTrimmer is a Ruby small library to trim replies from plain text email.
Parallel allows you to run any code in parallel Processes (to use all CPUs) or Threads(to speedup blocking operations). It is best suited for map-reduce or e.g. parallel downloads/uploads.
MSpec is a specialized framework that is syntax-compatible with RSpec 2 for basic features. MSpec contains additional features that assist in writing specs for Ruby implementations in ruby/spec.
Lemon is a unit testing framework that enforces highly formal case-to-class and unit-to-method test construction. This enforcement can help focus concern on individual units of behavior.
GRPC is a high performance, open-source universal RPC framework. This package provides a ruby interface for it.
ruby_engine provides an RubyEngine class that can be used to check which implementation of Ruby is in use. It can provide the interpreter name and provides query methods such as RubyEngine.mri?.
Psych is a YAML parser and emitter. Psych leverages libyaml for its YAML parsing and emitting capabilities. In addition to wrapping libyaml, Psych also knows how to serialize and de-serialize most Ruby objects to and from the YAML format.
Deep Merge is a set of utility functions for Hash. It permits you to merge elements inside a hash together recursively.
This library provides methods to encode and decode Ascii85 binary-to-text encoding. The main modern use of Ascii85 is in PostScript and Portable Document Format (PDF) file formats.