Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
LibCSS is a CSS (Cascading Style Sheet) parser and selection engine, written in C. It is developed as part of the NetSurf project.
gmid is a fast Gemini server written with security in mind. It has features such as:
reload the running configuration without interruption
automatic redirect/error pages
IRI support (RFC3987)
reverse proxying
CGI and FastCGI support
virtual hosts
location rules
event-based asynchronous I/O model
low memory footprint.
HTML::Lint is a pure-Perl HTML parser and checker for syntactic legitmacy.
Woof (Web Offer One File) is a small simple web server that can easily be invoked on a single file. Your partner can access the file with tools they trust (e.g. wget).
This package provides a rofi frontend for the buku bookmark manager.
This module (HTTP::CookieJar::LWP) implements a minimalist HTTP user agent cookie jar in conformance with RFC 6265.
The Apache HTTP Server Project is a collaborative software development effort aimed at creating a robust, commercial-grade, featureful, and freely-available source code implementation of an HTTP (Web) server. The project is jointly managed by a group of volunteers located around the world, using the Internet and the Web to communicate, plan, and develop the server and its related documentation.
Pytest-httpbin creates a pytest fixture that is dependency-injected into your tests. It automatically starts up a HTTP server in a separate thread running httpbin and provides your test with the URL in the fixture.
libRocket is a C++ user interface package based on the HTML and CSS standards. libRocket uses the open standards XHTML1.0 and CSS2.0 (while borrowing features from HTML5 and CSS3), and extends them with features suited towards real-time applications. It is designed as a complete solution for any project's interface needs:
Dynamic layout system.
Efficient application-wide styling, with a custom-built templating engine.
Fully featured control set: buttons, sliders, drop-downs, etc.
Runtime visual debugging suite.
Easily integrated and extensible with Python or Lua scripting.
The Kiwix library provides the Kiwix software suite core. It contains the code shared by all Kiwix ports.
The File::Listing module exports a single function called parse_dir(), which can be used to parse directory listings.
This plugin links the two pieces required for session management in web applications together: the state, and the store.
nsgenbind is a tool to generate JavaScript to DOM bindings from w3c webidl files and a binding configuration file.
Tidy is a console application which corrects and cleans up HTML and XML documents by fixing markup errors and upgrading legacy code to modern standards.
Tidy also provides libtidy, a C static and dynamic library that developers can integrate into their applications to make use of the functions of Tidy.
LibParserUtils is a library for building efficient parsers, written in C. It is developed as part of the NetSurf project.
The Jetty Web Server provides an HTTP server and Servlet container capable of serving static and dynamic content either from a standalone or embedded instantiation. This package provides the core jetty servlet container.
Tinyproxy is a light-weight HTTP/HTTPS proxy daemon. Designed from the ground up to be fast and yet small, it is an ideal solution for use cases such as embedded deployments where a full featured HTTP proxy is required, but the system resources for a larger proxy are unavailable.
Monolith bundles any web page into a single HTML file.
Unlike conventional ``Save page as…'', Monolith not only saves the target document, it embeds CSS, image, and JavaScript assets all at once, producing a single HTML5 document.
If compared to saving websites with wget -mpk, Monolith embeds all assets as data URLs and therefore displays the saved page exactly the same, being completely separated from the Internet.
JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C, output them as JSON-formatted strings and parse JSON-formatted strings back into the C representation of JSON objects. It aims to conform to RFC 7159.
A "public suffix" is a domain name under which Internet users can directly register own names.
Browsers and other web clients can use it to avoid privacy-leaking "supercookies", avoid privacy-leaking "super domain" certificates, domain highlighting parts of the domain in a user interface, and sorting domain lists by site.
Libpsl has built-in PSL data for fast access, allowing to load PSL data from files, checks if a given domain is a public suffix, provides immediate cookie domain verification, finds the longest public part of a given domain, finds the shortest private part of a given domain, works with international domains (UTF-8 and IDNA2008 Punycode), is thread-safe, and handles IDNA2008 UTS#46.
HTTP::Body parses chunks of HTTP POST data and supports application/octet-stream, application/json, application/x-www-form-urlencoded, and multipart/form-data.
Dispatch type managing path-matching behaviour using regexes. Regex dispatch types have been deprecated and removed from Catalyst core. It is recommend that you use Chained methods or other techniques instead. As part of the refactoring, the dispatch priority of Regex vs Regexp vs LocalRegex vs LocalRegexp may have changed. Priority is now influenced by when the dispatch type is first seen in your application.
The Guix Data Service stores data about GNU Guix, and provides this through a web interface. It supports listening to the guix-commits mailing list to find out about new revisions, then loads the data from these in to a PostgreSQL database.
libquvi is a library with a C API for parsing media stream URLs and extracting their actual media files.