Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This is only useful if you want to start a Swank server in a Lisp processes that doesn't run under Emacs. Lisp processes created by M-x slime automatically start the server.
This Common Lisp library provides string encoding and decoding routines for IDNA, the International Domain Names in Applications.
This library provides modern file handling for Common Lisp, which avoids many of the pitfalls of pathnames.
This library implements efficient algorithms that calculate various string metrics in Common Lisp:
Damerau-Levenshtein distance
Hamming distance
Jaccard similarity coefficient
Jaro distance
Jaro-Winkler distance
Levenshtein distance
Normalized Damerau-Levenshtein distance
Normalized Levenshtein distance
Overlap coefficient
Implementation of a set-like data structure with constant time addition, removal, and random selection.
Utility library for handling bit vectors, bit vector arithmetic, and universal integer type conversions between bit-vectors, byte-vectors, octals, decimals, and hexadecimal notation.
This an implementation of CDR 2: generic hash tables for Common Lisp
cl-strings is a small, portable, dependency-free set of utilities that make it even easier to manipulate text in Common Lisp. It has 100% test coverage and works at least on sbcl, ecl, ccl, abcl and clisp.
cl-morse is a Morse code translation library for Common Lisp.
THE-COST-OF-NOTHING is a library for measuring the run time of Common Lisp code. It provides macros and functions for accurate benchmarking and lightweight monitoring. Furthermore, it provides predefined benchmarks to determine the cost of certain actions on a given platform and implementation.
This package provides a utility library intended at providing configurable reader macros for common tasks such as accessors, hash-tables, sets, uiop:run-program, arrays and a few others.
ASDF-FLV provides support for file-local variables through ASDF. A file-local variable behaves like *PACKAGE* and *READTABLE* with respect to LOAD and COMPILE-FILE: a new dynamic binding is created before processing the file, so that any modification to the variable becomes essentially file-local.
In order to make one or several variables file-local, use the macros SET-FILE-LOCAL-VARIABLE(S).
CLX is an X11 client library for Common Lisp. The code was originally taken from a CMUCL distribution, was modified somewhat in order to make it compile and run under SBCL, then a selection of patches were added from other CLXes around the net.
Screamer is an extension of Common Lisp that adds support for nondeterministic programming. Screamer consists of two levels. The basic nondeterministic level adds support for backtracking and undoable side effects. On top of this nondeterministic substrate, Screamer provides a comprehensive constraint programming language in which one can formulate and solve mixed systems of numeric and symbolic constraints. Together, these two levels augment Common Lisp with practically all of the functionality of both Prolog and constraint logic programming languages such as CHiP and CLP(R). Furthermore, Screamer is fully integrated with Common Lisp. Screamer programs can coexist and interoperate with other extensions to as CLIM and Iterate.
This Common Lisp library provides functions for lzip (LZMA) compression/decompression using bindings to the lzlib C library.
This library is an implementation of Deflate (RFC 1951) decompression, with optional support for ZLIB-style (RFC 1950) and gzip-style (RFC 1952) wrappers of deflate streams. It currently does not handle compression.
NDebug provides a small set of utilities to make graphical (or, rather non-REPL-resident) Common Lisp applications easier to integrate with the standard Lisp debugger (*debugger-hook*, namely) and implementation-specific debugger hooks (via trivial-custom-debugger), especially in a multi-threaded context.
This is a system presenting a protocol for "file systems": things that present a collection of "files," which are things that have several attributes, and a central data payload. Most notably this includes the OS filesystem, but can also be used to address other filesystem-like things like archives, object stores, etc. in the same manner.
This library is a collection of functions and macros for manipulating Common Lisp arrays and performing numerical calculations with them.
This package provides an example implementation of the Common Lisp condition system and library, based on the original condition system implementation by Kent M. Pitman.
This library retrieves locale information configured on the system. This is helpful if you want to write applications and libraries that display messages in the user's native language.
CAMBL is a Common Lisp library providing a convenient facility for working with commoditized values. It does not allow compound units (and so is not suited for scientific operations) but does work rather nicely for the purpose of financial calculations.
This package provides a way of extracting and replicating the compile-time side-effects of forms.
The LOCAL-TIME library is a Common Lisp library for the manipulation of dates and times. It is based almost entirely upon Erik Naggum's paper "The Long Painful History of Time".