Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This Common Lisp library provides optimized byte-swapping primitives. The library can change endianness of unsigned integers of length 1/2/4/8. Very useful in implementing various network protocols and file formats.
Framework for representing and manipulating documents.
This is a small library to help you with managing the Common Lisp docstrings for your library.
This is a small Common Lisp library that finds an open port within a range.
EASY-ROUTES is yet another routes handling system on top of Hunchentoot. It's just glue code for Restas routing subsystem (CL-ROUTES).
It supports:
dispatch based on HTTP method
arguments extraction from the url path
decorators
URL generation from route names
This package provides EASY-ROUTES, EASY-ROUTES+DJULA and EASY-ROUTES+ERRORS systems.
Just wrap your Common Lisp function in this macro call and it will be optimized for tail recursion. You will be warned if the function is not tail recursive.
wild-package-inferred-system is an extension of ASDF package-inferred-system that interprets star * and globstar ** in package or system names.
This library provides purely functional dictionaries and sets in Common Lisp based on the hash array-mapped trie data structure.
Cluster is an assembler (initially for x86 and x86-64) with a difference. To avoid the issue of defining a syntax, the input to Cluster is a list of standard objects (i.e., instances of the class STANDARD-OBJECT), as opposed to a character file or S-expressions.
This is a coroutine library for Common Lisp implemented using the continuations of the cl-cont library.
This library features a rectangle packer for sprite and texture atlases.
Bobbin is a simple word-wrapping library for strings in Common Lisp. It aims to be simple, work nicely for the majority of cases, and degrade gracefully for edge cases. It is not particularly concerned with speed — if you need very high-performance word wrapping, Bobbin is not for you.
Loop has a consistent interface unlike other looping abstractions and ANSI list operations. You can define your own efters and gatherers that integrate tightly into other operations. All operations are non-consing when possible.
cl-annot is an general annotation library for Common Lisp.
Nodgui (No Drama GUI) is a Common Lisp binding for the Tk GUI toolkit. It also provides a few additional widgets more than the standard Tk ones.
CLML (Common Lisp Machine Learning) is a high performance and large scale statistical machine learning package
MARRAY is a library which provides access to memory-mapped files through Common Lisp arrays.
CL-PPCRE is a portable regular expression library for Common Lisp, which is compatible with perl. It is pretty fast, thread-safe, and compatible with ANSI-compliant Common Lisp implementations.
This is a backend for the linear-programming Common Lisp library using the GNU Linear Programming Kit (GLPK) library.
F2cl is a Common Lisp library that can convert Fortran 77 code into Common Lisp code.
cl-sbcl-cl-ipfs-api2 is a pretty simple set of IPFS bindings for Common Lisp, using the HTTP API for (almost) everything, except for pubsub (which uses the locally installed go-ipfs program).
DEFLATE data, defined in RFC1951, forms the core of popular compression formats such as zlib (RFC 1950) and gzip (RFC 1952). As such, Chipz also provides for decompressing data in those formats as well. BZIP2 is the format used by the popular compression tool bzip2.
This package provides a Common Lisp web framework for building GUI applications. CLOG can take the place, or work along side, most cross platform GUI frameworks and website frameworks. The CLOG package starts up the connectivity to the browser or other websocket client (often a browser embedded in a native template application).
When dealing with network protocols and file formats, it's common to have to read or write 16-, 32-, or 64-bit datatypes in signed or unsigned flavors. Common Lisp sort of supports this by specifying :element-type for streams, but that facility is underspecified and there's nothing similar for read/write from octet vectors. What most people wind up doing is rolling their own small facility for their particular needs and calling it a day.
This library attempts to be comprehensive and centralize such facilities. Functions to read 16-, 32-, and 64-bit quantities from octet vectors in signed or unsigned flavors are provided; these functions are also SETFable. Since it's sometimes desirable to read/write directly from streams, functions for doing so are also provided. On some implementations, reading/writing IEEE singles/doubles (i.e. single-float and double-float) will also be supported.