Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
CL-STRFTIME is a Common Lisp compiler for the strftime “language.”
This system implements binding threading macros -- a kind of threading macros with different semantics than classical, Clojure core threading macros or their extension, swiss-arrows. Two Common Lisp implementations of those are arrows and arrow-macros.
This system is a fork of arrows with changes in semantics that make it impossible to merge back upstream.
BKNR.DATASTORE is an in-memory CLOS based database with transactions for Common Lisp.
ORG-SAMPLER allows using Lisp docstrings and reflection to make org-mode text for inclusion into a larger document.
For is a library for an extensible iteration macro. It allows you to write concise looping constructs similar to loop and iterate. Unlike loop however it is extensible and sensible, and unlike iterate it does not require code-walking and is easier to extend.
This is an implementation of the Unicode Standards Annex #14 (http://www.unicode.org/reports/tr14/) line breaking algorithm. It provides a fast and convenient way to determine line breaking opportunities in text.
Note that this algorithm does not support break opportunities that require morphological analysis. In order to handle such cases, please consult a system that provides this kind of capability, such as a hyphenation algorithm.
Also note that this system is completely unaware of layouting decisions. Any kind of layouting decisions, such as which breaks to pick, how to space between words, how to handle bidirectionality, and what to do in emergency situations when there are no breaks on an overfull line are left up to the user.
This is a pure Common Lisp library to create, transform and render anti-aliased vectorial paths.
This library contains an implementation of interfaces and implementations. They're sometimes called protocols in other languages. Broadly speaking, an interface is some collection of function prototypes that a valid implementation must implement.
This package provides easy access to the defining class and its options during initialization or reinitialization of its subcomponents.
cl-gopher is a Common Lisp library for interacting with the Gopher protocol.
It is suitable for building both clients and servers, and provides a sample client.
deeds allows for efficient event delivery to multiple handlers with a complex event filtering system.
Chunga implements streams capable of chunked encoding on demand as defined in RFC 2616.
This package provides an implementation of the Matrix API for Common Lisp.
This package provides a robust CSV parser and printer that tries to follow the fine print of de facto standards. It can be configured to choose which standard exactly.
This library simplifies functional programming in Common Lisp by making it easier to make new data structures with specified changes in place.
Salza2 is a Common Lisp library for creating compressed data in the zlib, deflate, or gzip data formats, described in RFC 1950, RFC 1951, and RFC 1952, respectively.
Framework for representing and manipulating documents.
This is a small library to display a native GUI message box. This can be useful to show error messages and other informational pieces should the application fail and be unable to do so using its standard UI.
Ningle is a lightweight web application framework for Common Lisp.
This package provides a Common Lisp library to create magic squares of any size.
This package provides a configuration library that adds the ability for Lem to manage packages within the user configuration directory.
This package provides a Common Lisp library for dice rolling and working with dice-roll statistics.
This library provides a macroexpand-all function that calls the implementation specific equivalent.
This library provides a simple multithreading worker mechanism.