Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This library provides an OS and implementation independent access to timeouts.
cl-gserver is a 'message passing' library / framework with actors similar to Erlang or Akka. It supports creating reactive systems for parallel computing and event based message handling.
Osicat is a lightweight operating system interface for Common Lisp on Unix-platforms. It is not a POSIX-style API, but rather a simple lispy accompaniment to the standard ANSI facilities.
This implements encoding and decoding of Punycode strings, specified in RFC 3492 and used for unicode characters in domain names.
This package provides a hierarchy of major functions and auxiliary functions related to the structured analysis and processing of open text.
The Plump-SEXP library is a backend for Plump which can convert between S-expressions and the Plump DOM.
FARE-MOP is a small collection of utilities using the MetaObject Protocol. It notably contains a SIMPLE-PRINT-OBJECT method, and a SIMPLE-PRINT-OBJECT-MIXIN mixin that allow you to trivially define PRINT-OBJECT methods that print the interesting slots in your objects, which is great for REPL interaction and debugging.
Utility for creating, accessing, and managing custom namespaces in Common Lisp. Originally started as a fork of LISP-NAMESPACE, it became its own piece of software that is somewhat backwards compatible with it.
With lispy syntax, shortcuts, and improvements, LASS aims to help you out in writing CSS quick and easy. LASS was largely inspired by SASS. LASS supports two modes, one being directly in your lisp code, the other in pure LASS files.
cl-cron is a simple tool that provides cron like facilities directly inside of Common Lisp.
Germinal is a server for the Gemini protocol, written in Common Lisp.
The Bordeaux-FFT library provides a reasonably efficient implementation of the Fast Fourier Transform and its inverse for complex-valued inputs, in portable Common Lisp.
Lack is a Common Lisp library which allows web applications to be constructed of modular components. It was originally a part of Clack, however it's going to be rewritten as an individual project since Clack v2 with performance and simplicity in mind.
Charje.documentation can used to parse Common Lisp docstrings the charje way, or it can be used to create custom docstring parsers. Docstring parsers are composed using mixin classes and initialization methods.
Common Lisp port of Universal Tween Engine.
Caveman is intended to be a collection of common parts for web applications. Caveman2 has three design goals:
Be extensible.
Be practical.
Don't force anything.
This package provides supports for unicode normalization, RFC8264 and RFC7564.
This library contains generic hacks meant to be used in any project. It was originally developed for the Cells library.
NClasses provides helper macros to help write classes, conditions, generic functions, and CLOS code in general with less boilerplate.
It's a fork of hu.dwim.defclass-star. It includes some bug fixes and extra features like type inference.
CL-SXML implements Oleg Kiselyov’s SXML, an S-expression-based rendering of the XML Infoset.
cl-css-lite is a library for generating CSS from an s-exp based syntax. When compiled with Parenscript loaded in the Lisp image, it also provides the same CSS generation facilities in Parenscript-generated JavaScript code.
Osicat is a lightweight operating system interface for Common Lisp on Unix-platforms. It is not a POSIX-style API, but rather a simple lispy accompaniment to the standard ANSI facilities.
CL-DOT is a Common Lisp library for generating Graphviz dot output from arbitrary Lisp data.
cl-sbcl-cl-ipfs-api2 is a pretty simple set of IPFS bindings for Common Lisp, using the HTTP API for (almost) everything, except for pubsub (which uses the locally installed go-ipfs program).