Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides a portability layer for the extensible sequences standard extension to Common Lisp. Extensible sequences allow you to create your own sequence types that integrate with the rest of the functions and operations that interact with sequences.
A heap-based priority queue whose first and foremost priority is speed.
Calispel is a Common Lisp library for thread-safe message-passing channels, in the style of the occam programming language, also known as communicating sequential processes (CSP). See https://en.wikipedia.org/wiki/Communicating_sequential_processes.
Calispel channels let one thread communicate with another, facilitating unidirectional communication of any Lisp object. Channels may be unbuffered, where a sender waits for a receiver (or vice versa) before either operation can continue, or channels may be buffered with flexible policy options.
Because sending and receiving on a channel may block, either operation can time out after a specified amount of time.
A syntax for alternation is provided (like ALT in occam, or Unix select()): given a sequence of operations, any or all of which may block, alternation selects the first operation that doesn't block and executes associated code. Alternation can also time out, executing an "otherwise" clause if no operation becomes available within a set amount of time.
Calispel is a message-passing library, and as such leaves the role of threading abstractions and utilities left to be filled by complementary libraries such as Bordeaux-Threads and Eager Future.
This is a reverse proxy server written in and configurable in Common Lisp. It supports WebSocket, HTTP, HTTPS, HTTP to HTTPS redirecting, port and host forwarding configuration using a real programming language, HTTP header and body manipulation (also using a real programming language).
CL(x) xembed protocol implementation
This Common Lisp library provides bindings for the ZeroMQ lightweight messaging kernel.
This library is intended to solve the problem of source tracking for Common Lisp code.
By "source tracking", it is meant that code elements that have a known origin in the form of a position in a file or in an editor buffer are associated with some kind of information about this origin.
Since the exact nature of such origin information depends on the Common Lisp implementation and the purpose of wanting to track that origin, the library does not impose a particular structure of this information. Instead, it provides utilities for manipulating source code in the form of what is called concrete syntax trees (CSTs for short) that preserve this information about the origin.
FLOW is a flowchart graph library. Unlike other graphing libraries, this one focuses on nodes in a graph having distinct ports through which connections to other nodes are formed. This helps in many concrete scenarios where it is important to distinguish not only which nodes are connected, but also how they are connected to each other.
Particularly, a lot of data flow and exchange problems can be reduced to such a flowchart. For example, an audio processing library may present its pipeline as a flowchart of segments that communicate with each other through audio sample buffers. Flow gives a convenient view onto this kind of problem, and even allows the generic visualisation of graphs in this format.
This package provides the getopt function to parse command-line options. The options are organized in valid options, other arguments and unknown arguments. Optional Lisp conditions for error situations are also defined.
Provides a simple way of directing output to a stream according to the concise and intuitive semantics of FORMAT's stream argument.
This library defines a way of treating Common Lisp packages as conduits which can sit between one or more implementation packages and users of those packages.
Slite interactively runs your Common Lisp tests (currently only FiveAM and Parachute are supported). It allows you to see the summary of test failures, jump to test definitions, rerun tests with debugger all from inside Emacs.
In order to work, this also requires the slite Common Lisp system to be present. See the *cl-slite packages.
cl-ansi-text provides utilities which enable printing to an ANSI terminal with colored text. It provides the macro with-color which causes everything printed in the body to be displayed with the provided color. It further provides functions which will print the argument with the named color.
This library allows creation of hash tables with arbitrary test/hash functions, in addition to the test functions allowed by the standard (EQ, EQL, EQUAL and EQUALP), even in implementations that don't support this functionality directly.
On Cliki.net <http://www.cliki.net/Common%20Lisp%20Utilities>, there is a collection of Common Lisp Utilities, things that everybody writes since they're not part of the official standard. There are some very useful things there; the only problems are that they aren't implemented as well as you'd like (some aren't implemented at all) and they aren't conveniently packaged and maintained. It takes quite a bit of work to carefully implement utilities for common use, commented and documented, with error checking placed everywhere some dumb user might make a mistake.
This package provides easy access to the defining class and its options during initialization or reinitialization of its subcomponents.
Plump is a parser for HTML/XML-like documents, focusing on being lenient towards invalid markup. It can handle things like invalid attributes, bad closing tag order, unencoded entities, inexistent tag types, self-closing tags and so on. It parses documents to a class representation and offers a small set of DOM functions to manipulate it. It can be extended to parse to your own classes.
Eager Future2 is a Common Lisp library that provides composable concurrency primitives that unify parallel and lazy evaluation, are integrated with the Common Lisp condition system, and have automatic resource management.
doplus is an iteration macro for Common Lisp.
CL-TYPESETTING is a cross-platform Common Lisp typesetting library for all kind of typesetting applications.
This is a system to help you easily and quickly deploy standalone common lisp applications as binaries. Specifically it is geared towards applications with foreign library dependencies that run some kind of GUI.
This package provides a small utility library to open a thing (usually a file or URL) in an appropriate handler (usually an external file manager or browser).
This is a Common Lisp library to load images in the PNG image format, both from files on disk, or streams in memory.
Salza2 is a Common Lisp library for creating compressed data in the zlib, deflate, or gzip data formats, described in RFC 1950, RFC 1951, and RFC 1952, respectively.