_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


ecl-cl-base16 0.0-0.ae4b7f4
Dependencies: git@2.54.0 ecl-cl-yaml@0.1-1.c3202be ecl-cl-mustache@0.12.1 ecl-cl-slug@0.4.1-1.ffb229d ecl-trivial-shell@0.2.0-1.e02ec19
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/tpine/cl-base16
Licenses: GPL 3+
Build system: asdf/ecl
Synopsis: Common Lisp base 16 implementation
Description:

This package provides an implementation of a base 16 builder for Common Lisp.

cl-gopher 0.0.0-3.0899e7f
Propagated dependencies: cl-bordeaux-threads@0.9.3 cl-drakma@2.0.8 cl-flexi-streams@1.0.20-1.4951d57 cl-quri@0.7.0-0.03ecaf3 cl-split-sequence@2.0.1 cl-usocket@0.8.9
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/knusbaum/cl-gopher
Licenses: FreeBSD
Build system: asdf/source
Synopsis: Gopher protocol library in Common Lisp
Description:

cl-gopher is a Common Lisp library for interacting with the Gopher protocol.

It is suitable for building both clients and servers, and provides a sample client.

cl-mk-string-metrics 0.1.2
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/cbaggers/mk-string-metrics/
Licenses: X11
Build system: asdf/source
Synopsis: Calculate various string metrics efficiently in Common Lisp
Description:

This library implements efficient algorithms that calculate various string metrics in Common Lisp:

  • Damerau-Levenshtein distance

  • Hamming distance

  • Jaccard similarity coefficient

  • Jaro distance

  • Jaro-Winkler distance

  • Levenshtein distance

  • Normalized Damerau-Levenshtein distance

  • Normalized Levenshtein distance

  • Overlap coefficient

sbcl-series 2.2.11-1.da9061b
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://series.sourceforge.net/
Licenses: Expat
Build system: asdf/sbcl
Synopsis: Series data structure for Common Lisp
Description:

This Common Lisp library provides a series data structure much like a sequence, with similar kinds of operations. The difference is that in many situations, operations on series may be composed functionally and yet execute iteratively, without the need to construct intermediate series values explicitly. In this manner, series provide both the clarity of a functional programming style and the efficiency of an iterative programming style.

ecl-parse-declarations 1.0.0-1.549aebb
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://common-lisp.net/project/parse-declarations/
Licenses: Expat
Build system: asdf/ecl
Synopsis: Parse, filter, and build declarations
Description:

Parse-Declarations is a Common Lisp library to help writing macros which establish bindings. To be semantically correct, such macros must take user declarations into account, as these may affect the bindings they establish. Yet the ANSI standard of Common Lisp does not provide any operators to work with declarations in a convenient, high-level way. This library provides such operators.

cl-envy 0.1-2.26a7faa
Propagated dependencies: cl-osicat@0.7.0-4.9823279 cl-prove@1.0.0-2.5d71f02
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/fukamachi/envy
Licenses: FreeBSD
Build system: asdf/source
Synopsis: Common Lisp configuration switcher inspired by Perl's Config::ENV
Description:

Envy is a configuration manager for various applications. Envy uses an environment variable to determine a configuration to use. This can separate configuration system from an implementation.

cl-trivial-open-browser 0.1-1.7ab4743
Dependencies: xdg-utils@1.2.1
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/eudoxia0/trivial-open-browser
Licenses: Expat
Build system: asdf/source
Synopsis: Open a browser window from Common Lisp
Description:

This package provides a library to open a web browser to a URL.

sbcl-for 1.2.0-1.a397829
Dependencies: sbcl-documentation-utils@1.2.0-1.cd5b506 sbcl-form-fiddle@1.1.0-0.e0c2359 sbcl-lambda-fiddle@1.0.0-1.d16bba5
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://shinmera.com/docs/for/
Licenses: Zlib
Build system: asdf/sbcl
Synopsis: Extensible iteration macro library
Description:

For is a library for an extensible iteration macro. It allows you to write concise looping constructs similar to loop and iterate. Unlike loop however it is extensible and sensible, and unlike iterate it does not require code-walking and is easier to extend.

cl-uffi 2.1.2
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://quickdocs.org/uffi/
Licenses: LLGPL
Build system: asdf/source
Synopsis: Universal foreign function library for Common Lisp
Description:

UFFI provides a universal foreign function interface (FFI) for Common Lisp.

ecl-py-configparser 1.0.3
Dependencies: ecl-parse-number@1.8
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://common-lisp.net/project/py-configparser/
Licenses: Expat
Build system: asdf/ecl
Synopsis: ConfigParser Python module functionality for Common Lisp
Description:

The py-configparser package implements the ConfigParser Python module functionality in Common Lisp. In short, it implements reading and writing of .INI-file style configuration files with sections containing key/value pairs of configuration options. In line with the functionalities in the python module, does this package implement basic interpolation of option values in other options.

clasp-parse-js 0.0.0-1.fbadc60
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://marijnhaverbeke.nl/parse-js/
Licenses: Zlib
Build system: asdf/clasp
Synopsis: Parse JavaScript
Description:

Parse-js is a Common Lisp package for parsing JavaScript (ECMAScript 3). It has basic support for ECMAScript 5.

sbcl-trivial-documentation 0-0.e71e7cf
Dependencies: sbcl-closer-mop@1.0.0-3.7b86f2a
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/eugeneia/trivial-documentation
Licenses: AGPL 1
Build system: asdf/sbcl
Synopsis: Scrape on-line documentation out of a running Lisp image
Description:

Scrape on-line documentation out of a running Lisp image.

sbcl-3bz 0.0.0-1.569614c
Dependencies: sbcl-alexandria@1.4-0.009b7e5 sbcl-babel@0.5.0-3.627d6a6 sbcl-cffi@0.24.1-2.32c90d4 sbcl-mmap@1.0.0-0.ba2e98c sbcl-nibbles@0.14-3.a46a677 sbcl-trivial-features@1.0
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/3b/3bz
Licenses: Expat
Build system: asdf/sbcl
Synopsis: Deflate decompression for Common Lisp
Description:

3bz is an implementation of Deflate decompression (RFC 1951) optionally with zlib (RFC 1950) or gzip (RFC 1952) wrappers, with support for reading from foreign pointers (for use with mmap and similar, etc), and from CL octet vectors and streams.

sbcl-colored 1.0.0-2.54e6184
Dependencies: sbcl-documentation-utils@1.2.0-1.cd5b506
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://shinmera.com/docs/colored
Licenses: Zlib
Build system: asdf/sbcl
Synopsis: Colour representation, conversion, and operation for Common Lisp
Description:

This is a library for representing and mapping colours between their various spaces.

cl-ascii-table 0.0.0-1.d9f5e77
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/telephil/cl-ascii-table
Licenses: Expat
Build system: asdf/source
Synopsis: Library to make ascii-art tables
Description:

This is a Common Lisp library to present tabular data in ascii-art tables.

cl-colors 0.0.0-1.8274105
Propagated dependencies: cl-alexandria@1.4-0.009b7e5 cl-let-plus@0.0.0-2.455e657
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/tpapp/cl-colors
Licenses: Boost 1.0
Build system: asdf/source
Synopsis: Simple color library for Common Lisp
Description:

This is a very simple color library for Common Lisp, providing

  • Types for representing colors in HSV and RGB spaces.

  • Simple conversion functions between the above types (and also hexadecimal representation for RGB).

  • Some predefined colors (currently X11 color names – of course the library does not depend on X11).Because color in your terminal is nice.

This library is no longer supported by its author.

ecl-rfc2388 0.0.0-1.591bcf7
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/jdz/rfc2388/
Licenses: FreeBSD
Build system: asdf/ecl
Synopsis: Implementation of RFC 2388 in Common Lisp
Description:

This package contains an implementation of RFC 2388, which is used to process form data posted with HTTP POST method using enctype "multipart/form-data".

sbcl-async-process 0.0.1-2.3b16b91
Dependencies: libasyncprocess@0.0.1-2.3b16b91 sbcl-cffi@0.24.1-2.32c90d4
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/lem-project/async-process
Licenses: Expat
Build system: asdf/sbcl
Synopsis: Asynchronous process execution for Common Lisp
Description:

This library provides an asynchronous process execution mechanism for Common Lisp.

clasp-cl-colors2 0.6.1
Dependencies: clasp-alexandria@1.4-0.009b7e5 clasp-cl-ppcre@2.1.1 clasp-parse-number@1.8
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://codeberg.org/cage/cl-colors2
Licenses: Boost 1.0
Build system: asdf/clasp
Synopsis: Color library for Common Lisp
Description:

This is a very simple color library for Common Lisp, providing:

  • Types for representing colors in HSV, HSL, and RGB spaces.

  • Simple conversion functions between the above types.

  • Function printing colors to HEX, RGB, RGBA, and HSL.

  • Predefined colors from X11, SVG, and GDK.

cl-fare-utils 1.0.0.5-1.66e9c6f
Propagated dependencies: cl-hu.dwim.stefil@0.0.0-2.414902c
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://gitlab.common-lisp.net/frideau/fare-utils
Licenses: Expat
Build system: asdf/source
Synopsis: Collection of utilities and data structures
Description:

fare-utils is a small collection of utilities. It contains a lot of basic everyday functions and macros.

sbcl-helambdap 20220103-0.5bf65f5
Dependencies: sbcl-cl-fad@0.7.6-1.3f4d32d sbcl-clad@2023-01-21-0.1ff6f41 sbcl-split-sequence@2.0.1 sbcl-xhtmlambda@2022-01-21-0.c86376b
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://helambdap.sourceforge.net
Licenses: Expat
Build system: asdf/sbcl
Synopsis: Common Lisp documentation system
Description:

HELambdap is a Common Lisp documentation system which strives to be simple to use, yet easily customizable.

sbcl-do-urlencode 0.0.0-1.1998464
Dependencies: sbcl-alexandria@1.4-0.009b7e5 sbcl-babel@0.5.0-3.627d6a6
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/drdo/do-urlencode
Licenses: ISC
Build system: asdf/sbcl
Synopsis: Percent Encoding (aka URL Encoding) Common Lisp library
Description:

This library provides trivial percent encoding and decoding functions for URLs.

cl-trucler 0.0.0-2.39d4ba1
Propagated dependencies: cl-acclimation@0.0.0-2.9339b92
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/s-expressionists/Trucler
Licenses: FreeBSD
Build system: asdf/source
Synopsis: Environment protocol for Common Lisp compilers
Description:

Trucler defines a CLOS-based protocol to be used by Common Lisp compilers for environment query and update. In addition, library authors can use the trucler-native interface to inspect native environments. Trucler supports introspection for variables, functions, tags, blocks and optimization policies.

sbcl-ucons 0.0.0-0.d976810
Dependencies: sbcl-alexandria@1.4-0.009b7e5 sbcl-atomics@1.0.0-3.5b36bf2 sbcl-bordeaux-threads@0.9.3 sbcl-named-readtables@0.9-5.aa6dab5 sbcl-trivia@0.1-0.8b406c3
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/marcoheisig/ucons
Licenses: Expat
Build system: asdf/sbcl
Synopsis: Unique conses for Common Lisp
Description:

UCONS is a Common Lisp library providing unique conses. Unique conses are different from regular conses in that, in addition to their car and cdr, they maintain a table of past users. Also, the cdr of each ucons is restricted to other uconses or nil. Uconses are meant for those situations where even reusing regular conses (to avoid consing) is too computationally expensive.

Total packages: 32836