Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides CFFI bindings to the ASSIMP library for Common Lisp.
This is a system presenting a protocol for "file systems": things that present a collection of "files," which are things that have several attributes, and a central data payload. Most notably this includes the OS filesystem, but can also be used to address other filesystem-like things like archives, object stores, etc. in the same manner.
This library defines most Common Lisp standard macros that can be defined in a portable way and that can generate portable code. Some of these macros may not be good enough as the final version for a typical implementation, but they will work.
CXML implements a namespace-aware, validating XML 1.0 parser as well as the DOM Level 2 Core interfaces. Two parser interfaces are offered, one SAX-like, the other similar to StAX.
This library provides a drop-in replacement function for cl:documentation that supports multiple docstrings per-language, allowing you to write documentation that can be internationalised.
This library is an implementation of Deflate (RFC 1951) decompression, with optional support for ZLIB-style (RFC 1950) and gzip-style (RFC 1952) wrappers of deflate streams. It currently does not handle compression.
LTK is a Common Lisp binding for the Tk graphics toolkit. It is written in pure Common Lisp and does not require any Tk knowledge for its usage.
This is a minimalistic parser of command line options. The main advantage of the library is the ability to concisely define command line options once and then use this definition for parsing and extraction of command line arguments, as well as printing description of command line options (you get --help for free). This way you don't need to repeat yourself. Also, unix-opts doesn't depend on anything and precisely controls the behavior of the parser via Common Lisp restarts.
atomichron is a Common Lisp library which implements a time meter which tracks how many times a form is evaluated, and how long evaluation takes. It uses atomic instructions so that meters will present correct results in the presence of multiple threads, while trying to minimize synchronization latency.
Closer to MOP is a compatibility layer that rectifies many of the absent or incorrect CLOS MOP features across a broad range of Common Lisp implementations.
Often times we need to destructure a form definition in a Common Lisp macro. This library provides a set of simple utilities to help with that.
This package provides CFFI bindings to the libflac audio library for Common Lisp.
This package provides a PNG Common Lisp system to operate with Portable Network Graphics file format.
This package provides an enhanced version of typep that is exactly like the one in the Lisp spec, except it can also accept a single type argument, in which case it returns the appropriate closure.
CLX-TrueType is pure common lisp solution for antialiased TrueType font rendering using CLX and XRender extension.
This package provides CFFI bindings to the libflac audio library for Common Lisp.
GENERIC-COMPARABILITY is an implementation of CDR-8 (Generic Equality and Comparison for Common Lisp). CDR-8 provides an interface for the EQUALS function, which is defined as a general equality predicate, as well as a set of ordering (COMPARE) functions for comparison. The semantics are described in the CDR-8 standard.
This package exports the following function to parse floating-point values from a string in Common Lisp.
This package extends the Common Lisp reader syntax such that is accepts Org files as Lisp source code files.
QURI (pronounced "Q-ree") is yet another URI library for Common Lisp. It is intended to be a replacement of PURI.
This Common Lisp library provides functions for lzip (LZMA) compression/decompression using bindings to the lzlib C library.
This package provides Common Lisp CFFI bindings to the Raylib game development library.
This package provides a UTF-8 string input stream over a binary stream for Common Lisp.
This package provides an enhanced version of typep that is exactly like the one in the Lisp spec, except it can also accept a single type argument, in which case it returns the appropriate closure.