Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This a Common Lisp library to convert geographic coordinates between latitude/longitude and MGRS.
This package provide a Common Lisp library for .zip-file reading and writing.
This library features a rectangle packer for sprite and texture atlases.
CL-PPCRE is a portable regular expression library for Common Lisp, which is compatible with perl. It is pretty fast, thread-safe, and compatible with ANSI-compliant Common Lisp implementations.
Convenient macros for common lambda patterns.
An implementation of the exponential backoff algorithm in Common Lisp. Inspired by the implementation found in Chromium. Read the header file to learn about each of the parameters.
TRIVIAL-OCTET-STREAMS is a Common Lisp library implementing in-memory octet streams analogous to string streams.
This library is a portable compatibility layer around package local nicknames (PLN). This was done so there is a portability library for the PLN API not included in DEFPACKAGE.
This is a utility kit for functionality related to OpenGL. It provides the following:
kit.glm: This re-exportssb-cgaandmathkitfor convenience.kit.gl.shader: This provides shader dictionary and compilation functionality similar to what was originally found insdl2kit.kit.gl.vao: This provides an interface for Vertex Array Objects.
Ningle is a lightweight web application framework for Common Lisp.
This library is an extension of the Common Lisp Object System (CLOS) that allows a compiler to inline a generic function under certain conditions.
zsort is a collection of portable sorting algorithms. Common Lisp provides the sort and stable-sort functions but these can have different algorithms implemented according to each implementation. Also, the standard sorting functions might not be the best for a certain situations. This library aims to provide developers with more options.
This system is an implementation of the Common Lisp type system; particularly cl:typep and cl:subtypep.
This library allows you to define custom indentation hints for your macros if the one recognised by SLIME automatically produces unwanted results.
This package provides the Common Lisp HTTP server WOO, which is built on top of the libev event library.
Alexandria is a collection of portable utilities. It does not contain conceptual extensions to Common Lisp. It is conservative in scope, and portable between implementations.
This is a system to help you easily and quickly deploy standalone common lisp applications as binaries. Specifically it is geared towards applications with foreign library dependencies that run some kind of GUI.
This package provides support routines for the claw Common Lisp package.
exit-hooks provides a portable way to automatically call some user-defined function when exiting Common Lisp (both quit from the REPL or a kill in a shell). Like atexit in C and Python or Java’s Runtime.addShutdownHook(). It currently supports SBCL, CCL, ECL, ABCL, Allegro CL, clisp and CMUCL. Before exit-hooks, there was no portable way of doing so and no staightforward way to use an exit hook on ABCL. It can be used for tasks like parmenantly save something when exiting Lisp.
DEFLATE data, defined in RFC1951, forms the core of popular compression formats such as zlib (RFC 1950) and gzip (RFC 1952). As such, Chipz also provides for decompressing data in those formats as well. BZIP2 is the format used by the popular compression tool bzip2.
This package provides data frames for Common Lisp, a two-dimensional array-like structure in which each column contains values of one variable and each row contains one set of values from each column.
Alloy is a user interface toolkit. It is defined through a set of protocols that allow for a clear interface, as well as a standardised way to integrate Alloy into a target backend.
This package provides the Common Lisp part of the emacs-slite test runner.
This library extracts the TLD (Top Level Domain) from domains. The information is taken from https://publicsuffix.org.