Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
SQL generator for Common Lisp.
Caveman is intended to be a collection of common parts for web applications. Caveman2 has three design goals:
Be extensible.
Be practical.
Don't force anything.
This package contains the specification of all functions and variables from GLSL as data.
This is a Common Lisp library providing a set of macros for generating lexical analyzers automatically. The lexers generated using cl-lex can be used with cl-yacc.
This is a Common Lisp library that implements the 9p network filesystem protocol.
Splits sequence into a list of subsequences delimited by objects satisfying the test.
This library provides functions for determining the value types of Common Lisp forms, based on type information contained in the environment.
In order for this library to work the values types of variables and return types of functions have to be declared.
Macros and symbol-macros are fully expanded and all special forms, except CATCH, are supported.
This package provides CFFI bindings to the Graphviz library in Common Lisp.
FARE-MOP is a small collection of utilities using the MetaObject Protocol. It notably contains a SIMPLE-PRINT-OBJECT method, and a SIMPLE-PRINT-OBJECT-MIXIN mixin that allow you to trivially define PRINT-OBJECT methods that print the interesting slots in your objects, which is great for REPL interaction and debugging.
Croatoan provides high-level Common Lisp CLOS bindings for the ncurses terminal library.
string-case is a Common Lisp macro that generates specialised decision trees to dispatch on string equality.
The Babel library solves a similar problem while understanding more encodings. Trivial UTF-8 was written before Babel existed, but for new projects you might be better off going with Babel. The one plus that Trivial UTF-8 has is that it doesn't depend on any other libraries.
Babel is a charset encoding and decoding library, not unlike GNU libiconv, but completely written in Common Lisp.
This package provides Common Lisp bindings for libev.
Linedit is a readline-style library written in Common Lisp that provides customizable line-editing for Common Lisp programs.
Flexi-streams is an implementation of "virtual" bivalent streams that can be layered atop real binary or bivalent streams and that can be used to read and write character data in various single- or multi-octet encodings which can be changed on the fly. It also supplies in-memory binary streams which are similar to string streams.
A simple templating library loosely based on BRL (the Beautiful Report Language). It leverages the power of the lisp reader to create a dynamic templating system that is easy to understand and powerful enough for most applications.
This library is a portable socket interface that allows CL programs to open connected (client) stream sockets to network services.
This library contains a collection of machine learning algorithms for online linear classification written in Common Lisp.
This is a small library to help you with managing the Common Lisp docstrings for your library.
cl-forms provides functionality for managing web forms in Common Lisp.
It supports various field types (string, boolean, integer, email, password, and more) and allows rendering through multiple backends, such as cl-who and djula.
This package provides an implementation of the which UNIX command in Common Lisp.
This library is an implementation of Deflate (RFC 1951) decompression, with optional support for ZLIB-style (RFC 1950) and gzip-style (RFC 1952) wrappers of deflate streams. It currently does not handle compression.
This package provides a SuperCollider client for Common Lisp.