Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
Inquisitor is a cross-implementation library providing encoding/end-of-line detection and external-format abstraction for Common Lisp.
This library simplifies functional programming in Common Lisp by making it easier to make new data structures with specified changes in place.
This package defines a Common Lisp package, :elements, with an ELEMENT structure and a number of functions to search the periodic table.
This is a trivial utility for distinguishing between a process running in a real terminal window and a process running in a dumb one, e.g. emacs-slime.
This library is a fork of SSL-CMUCL. The original SSL-CMUCL source code was written by Eric Marsden and includes contributions by Jochen Schmidt. Development into CL+SSL was done by David Lichteblau.
This library is an implementation of the XML Path Language (XPath) Version 1.0.
CAMBL is a Common Lisp library providing a convenient facility for working with commoditized values. It does not allow compound units (and so is not suited for scientific operations) but does work rather nicely for the purpose of financial calculations.
This is a library to provide cross-platform access to gamepads, joysticks, and other such HID devices.
Simple scheme to classify file types in a hierarchical fashion.
CL-ANA is a data analysis library in Common Lisp providing tabular and binned data analysis along with nonlinear least squares fitting and visualization.
This library is part of NUMCL. It provides a macro SPECIALIZED that performs a Julia-like dispatch on the arguments, lazily compiling a type-specific version of the function from the same code. The main target of this macro is speed.
cl-cookie is a Common Lisp library featuring parsing of cookie headers, cookie creation, cookie jar creation and more.
This package provides a stream based JSON parser/writer, well suited as building block for higher level libraries.
This package parses and prints dates in RFC-1123 format.
This package defines a simple extensible protocol for computing a guess using advisors.
This lisp library handles physical quantities which consist of
value / magnitude
uncertainty / error
unit
where the type of the value can be any subtype of real. For the uncertainty, both absolute and relative values are possible. Combinations of lisp symbols or strings are used to describe units. User defined units including abbreviations and prefixes are supported. Error propagation and unit checking is performed for all defined operations.
cl-jpl-util is a collection of Common Lisp utility functions and macros, primarily for software projects written in CL by the author.
Salza2 is a Common Lisp library for creating compressed data in the zlib, deflate, or gzip data formats, described in RFC 1950, RFC 1951, and RFC 1952, respectively.
This package is a simple date and time library.
simple-matrix is a Common Lisp library implementing some functions to work with matrices.
This library tries to provide a way to detect what kind of type the given predicate is trying to check. This is different from inferring the return type of a function.
This package provides a functionality augmenting Hunchentoot error pages and logs with request and session information.
A common lisp library that provides extensible function result caching based on arguments (an expanded form of memoization).
The variates package provides portable random number generation as well as numerous distributions.