Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
MOP utilities provide a common interface between Lisps and make the MOP easier to use.
cl-irc is a Common Lisp IRC client library that features (partial) DCC, CTCP and all relevant commands from the IRC RFCs (RFC2810, RFC2811 and RFC2812).
Features:
implements all commands in the RFCs
extra convenience commands such as op/deop, ban, ignore, etc.
partial DCC SEND/CHAT support
event driven model with hooks makes interfacing easy
the user can keep multiple connections
all CTCP commands
This library strives to provide a portable TCP/IP and UDP/IP socket interface for as many Common Lisp implementations as possible, while keeping the abstraction and portability layer as thin as possible.
This library introduces fast generic functions, i.e. functions that behave just like regular generic functions, except that the can be sealed on certain domains. If the compiler can then statically detect that the arguments to a fast generic function fall within such a domain, it will perform a variety of optimizations.
This library is an implementation of the XML Path Language (XPath) Version 1.0.
cl-all is a library and script for evaluating Common Lisp expressions in multiple implementations.
Vom is a logging library for Common Lisp. It's goal is to be useful and small. It does not provide a lot of features as other loggers do, but has a small codebase that's easy to understand and use.
This library is an implementation of the Secure Hash Algorithm 3 (SHA-3), also known as Keccak. The implementation is constrained to messages with an integral number of octets,i.e. sub-byte length messages are not supported.
UFFI provides a universal foreign function interface (FFI) for Common Lisp.
Birch is a simple Common Lisp IRC client library. It makes use of CLOS for event handling.
This data structure can be used to store the history of visited paths or URLs with a file or web browser, in a way that no “forward” element is ever forgotten.
The history tree is “global” in the sense that multiple owners (e.g. tabs) can have overlapping histories. On top of that, an owner can spawn another one, starting from one of its nodes (typically when you open a URL in a new tab).
LLA is a high-level Common Lisp library built on BLAS and LAPACK, but providing a much more abstract interface with the purpose of freeing the user from low-level concerns and reducing the number of bugs in numerical code.
An implementation of Relax NG schema validation written in Common Lisp, including support for compact syntax, DTD Compatibility, and the XSD type library.
This package provides an embedded template engine for Common Lisp.
This is a a Common Lisp re-implementation of the Rails routes system for mapping URLs.
This package provides an automatic generator for ASDF's .asd files.
Plump is a parser for HTML/XML-like documents, focusing on being lenient towards invalid markup. It can handle things like invalid attributes, bad closing tag order, unencoded entities, inexistent tag types, self-closing tags and so on. It parses documents to a class representation and offers a small set of DOM functions to manipulate it. It can be extended to parse to your own classes.
This package provides an extensible implementation of defclass that can accurately control the expansion according to the metaclass and automatically detect the suitable metaclass by analyzing the defclass form.
Converts Markdown text into CommonDoc nodes and vice versa.
This is a Common Lisp library which provides functionality to read/write Bit Map Font (BMF) into text, JSON and XML.
This library contains generic hacks meant to be used in any project. It was originally developed for the Cells library.
Stealth-mixin is a Common Lisp library for creating stealth mixin classes. These are classes that are dynamically mixed into other classes without the latter being aware of it.
Various ASDF extensions such as attached test and documentation system, explicit development support, etc.
Dufy is a library for exact color manipulation and conversion in various color spaces, which supports many color models.