Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This Common Lisp library provides an implementation of in-memory input streams, output streams and io streams for any type of elements.
This package creates GraphViz DOT files from an equivalent s-expression representation.
This package provides CFFI bindings to convert between different character encodings using iconv.
CL-FastCGI is a generic version of SB-FastCGI, targeting to run on mostly Common Lisp implementation.
DEFLATE data, defined in RFC1951, forms the core of popular compression formats such as zlib (RFC 1950) and gzip (RFC 1952). As such, Chipz also provides for decompressing data in those formats as well. BZIP2 is the format used by the popular compression tool bzip2.
This package provides a JSON Pointer (RFC6901) implementation for Common Lisp. This library aims to be independent from any JSON libraries (as much as possible).
Duologue is high-level interaction library for Common Lisp. It features coloured printing via cl-ansi-text and readline completion.
MAP-BIND is a macro that allows visual grouping of variables with their corresponding values in calls to mapping operators when using an inline LAMBDA.
The Common Lisp Application Directories (CLAD) library is a simple API collection that provides access to a set of standard Common Lisp folders on a per-application or per-library basis.
Domain specific language for producing TeX documents with Common Lisp.
This is a c2ffi-based wrapper generator for Common Lisp.
Closer to MOP is a compatibility layer that rectifies many of the absent or incorrect CLOS MOP features across a broad range of Common Lisp implementations.
Portable Threads (and Scheduled and Periodic Functions) API for Common Lisp (from GBBopen project).
CL-FTP is a library which provides FTP client functionality to a Common Lisp program. CL-FTP uses the USOCKET package for network sockets and the SPLIT-SEQUENCE package for some parsing needs.
This Common Lisp library implements the quoted-printable encoding as described in RFC 2045 (see http://tools.ietf.org/html/rfc2045).
This is a native Common Lisp graphics math library with an emphasis on performance and correctness.
The GNU Scientific Library for Lisp (GSLL) allows the use of the GNU Scientific Library (GSL) from Common Lisp. This library provides a full range of common mathematical operations useful to scientific and engineering applications. The design of the GSLL interface is such that access to most of the GSL library is possible in a Lisp-natural way; the intent is that the user not be hampered by the restrictions of the C language in which GSL has been written. GSLL thus provides interactive use of GSL for getting quick answers, even for someone not intending to program in Lisp.
SLY is a fork of SLIME, an IDE backend for Common Lisp. It also features a completely redesigned REPL based on Emacs's own full-featured comint-mode, live code annotations, and a consistent interactive button interface. Everything can be copied to the REPL. One can create multiple inspectors with independent history.
This is a Common Lisp utilities library originating from the Zombie Raptor game engine project.
This is a Common Lisp bindings library to libfond, a simple OpenGL text rendering engine.
This library provides two strata to access the POSIX shm API:
the package
posix-shm/ffi, a collection of slim bindings to the POSIX APIthe package
posix-shm, a lispy wrapper around the FFI that integrates more closely to the features of Common Lisp, and provides a handful of utilities and macros
Features include:
open, close, create, resize, change ownership of, change permissions of, and memory map to shared memory objects
open-shmappears more likeopenfrom the standard libraryopen-shm*, for creating anonymous shm objectswith-open-shm,with-mmapand similarwith-macros for safely accessing resources with dynamic extent
Pileup is a portable, performant, and thread-safe binary heap for Common Lisp.
ST-JSON (ST because it originated at Streamtech) is a Common Lisp library for encoding and decoding JSON values (as specified on json.org).
This library does mostly the same thing as CL-JSON, but is simpler and more precise about types (distinguishing boolean false, the empty array, and the empty object).
assoc-utils provides utilities for manipulating association lists in Common Lisp.