Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
fmt provides an alternative to the Common Lisp format function by utilizing s-expressions for formatting directives instead of control strings.
3bz is an implementation of Deflate decompression (RFC 1951) optionally with zlib (RFC 1950) or gzip (RFC 1952) wrappers, with support for reading from foreign pointers (for use with mmap and similar, etc), and from CL octet vectors and streams.
This is a a Common Lisp re-implementation of the Rails routes system for mapping URLs.
This package provides a statistical computing environment for Common Lisp.
This is a Common Lisp implementation for the Mustache template system. More details on the standard are available at https://mustache.github.io.
S-XML is a simple XML parser implemented in Common Lisp. This XML parser implementation has the following features:
It works (handling many common XML usages).
It is very small (the core is about 700 lines of code, including comments and whitespace).
It has a core API that is simple, efficient and pure functional, much like that from SSAX (see also http://ssax.sourceforge.net).
It supports different DOM models: an XSML-based one, an LXML-based one and a classic xml-element struct based one.
It is reasonably time and space efficient (internally avoiding garbage generatation as much as possible).
It does support CDATA.
It should support the same character sets as your Common Lisp implementation.
It does support XML name spaces.
This XML parser implementation has the following limitations:
It does not support any special tags (like processing instructions).
It is not validating, even skips DTD's all together.
This is a websocket server for Common Lisp using usockets to be portable between implementations and operating systems. It has a programming interface that allows for multiple websocket apps per server using Common Lisp keywords for different websocket events. It has useful restarts and customizable errors.
For is a library for an extensible iteration macro. It allows you to write concise looping constructs similar to loop and iterate. Unlike loop however it is extensible and sensible, and unlike iterate it does not require code-walking and is easier to extend.
The NUMPY-FILE-FORMAT library is a Common Lisp library for reading and writing NumPy .npy and .npz files.
It can sometimes be useful to be able to parse chemical compounds in a user-friendly syntax into easy-to-manipulate s-expressions. You also want to be able to go in reverse. You could probably write your own parser — or you could just install the chemical-compounds package.
MT19937 is a portable Mersenne Twister pseudo-random number generator for Common Lisp.
A modern markup generation library for Common Lisp that features:
Fast (even faster through compiling the code)
Safety
Support for multiple document types (markup, xml, html, html5, xhtml)
Output with doctype
Direct output to stream
TRIVIAL-TYPES provides missing but important type definitions such as PROPER-LIST, ASSOCIATION-LIST, PROPERTY-LIST and TUPLE.
Forge is a generic build system. Refer to documentation for the specific kind of project you're building to get the full picture.
Feeder is a syndication feed library. It presents a general protocol for representation of feed items, as well as a framework to translate these objects from and to external formats. It also implements the RSS 2.0 and Atom formats within this framework.
Small library aiming to cut down time spent moving data between CLOS and JSON objects. It depends on YASON and it should be possible to use it alongside straight calls to functions from YASON.
PAX provides an extremely poor man's Explorable Programming environment. Narrative primarily lives in so called sections that mix markdown docstrings with references to functions, variables, etc, all of which should probably have their own docstrings.
The primary focus is on making code easily explorable by using SLIME's M-. (slime-edit-definition). See how to enable some fanciness in Emacs Integration. Generating documentation from sections and all the referenced items in Markdown or HTML format is also implemented.
With the simplistic tools provided, one may accomplish similar effects as with Literate Programming, but documentation is generated from code, not vice versa and there is no support for chunking yet. Code is first, code must look pretty, documentation is code.
This library is a little experiment in reducing verbosity in Common Lisp, inspired by BODOL (https://github.com/bodil/BODOL).
cl-docutils is a Common Lisp implementation of the Docutils text processing system for processing plaintext into presentational formats such as HTML and LaTeX. It is based upon the Python Docutils reference implementation but uses Common Lisp idioms making it easier to extend and more flexible. As with the reference implementation it includes a parser for the reStructured text plaintext markup syntax which is suitable for marking up documentation and for use as user markup for collaborative web sites. It is successfully used to support a higher education peer-review assessment and online tutorial system.
POLICY-COND provides tools to insert and execute code based on a compiler's OPTIMIZE policy. It also contains a contract-like notion of expectations, which allow dynamic checking or inclusion of various things that should happen depending on compiler policy.
PARSER-COMBINATORS is a library implementing monadic parser combinators in Common Lisp, similar in concept to Haskell Parsec system.
Fully auto-generated Common Lisp bindings to Raylib and Raygui.
CL-INTERPOL is a library for Common Lisp which modifies the reader so that you can have interpolation within strings similar to Perl or Unix Shell scripts. It also provides various ways to insert arbitrary characters into literal strings even if your editor/IDE doesn't support them.
Named readtables is a library that creates a namespace for named readtables, which is akin to package namespacing in Common Lisp.