Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
CLSS is a DOM traversal engine based on CSS selectors. It makes use of the Plump-DOM and is used by lQuery.
Clop is a Common Lisp library for parsing strings in the TOML configuration file format.
This package provides Common Lisp support for reading the Terragen .TER format. The format specification can be found at https://planetside.co.uk/wiki/index.php?title=Terragen_.TER_Format
This Common Lisp library provides a series data structure much like a sequence, with similar kinds of operations. The difference is that in many situations, operations on series may be composed functionally and yet execute iteratively, without the need to construct intermediate series values explicitly. In this manner, series provide both the clarity of a functional programming style and the efficiency of an iterative programming style.
This package provides a Common Lisp implementation of Base64 encoding and decoding. Base64 encoding is a technique to encode binary data in a portable, safe printable, 7-bit ASCII format.
Trivia is a pattern matching compiler that is compatible with Optima, another pattern matching library for Common Lisp. It is meant to be faster and more extensible than Optima.
This library implements various functions to access status information about the machine, process, etc.
This is a utility library providing access to the mmap family of functions in a portable way. It allows you to directly map a file into the address space of your process without having to manually read it into memory sequentially. Typically this is much more efficient for files that are larger than a few Kb.
3D-MATRICES is a library implementing common matrix operations, mainly intended as the counterpiece to 3d-vectors and thus being aimed at operations in 3D space.
This is a Common Lisp package for hash table creation with flexible, extensible initializers.
S-XML-RPC is an implementation of XML-RPC in Common Lisp for both client and server.
repl-utilities is a set of utilities which ease life at the REPL. It includes three sorts of features: introspective procedures, miscellaneous utility functions, and, pulling them together, methods to conveniently keep these symbols and optionally additional symbols available in whichever package you switch to.
This Common Lisp library provides a tiny utility to change the size of a simple-array ensuring that the resulting array is still a simple-array.
A hook, in the present context, is a certain kind of extension point in a program that allows interleaving the execution of arbitrary code with the execution of a the program without introducing any coupling between the two. Hooks are used extensively in the extensible editor Emacs.
In the Common LISP Object System (CLOS), a similar kind of extensibility is possible using the flexible multi-method dispatch mechanism. It may even seem that the concept of hooks does not provide any benefits over the possibilities of CLOS. However, there are some differences:
There can be only one method for each combination of specializers and qualifiers. As a result this kind of extension point cannot be used by multiple extensions independently.
Removing code previously attached via a
:before,:afteror:aroundmethod can be cumbersome.There could be other or even multiple extension points besides
:beforeand:afterin a single method.Attaching codes to individual objects using eql specializers can be cumbersome.
Introspection of code attached a particular extension point is cumbersome since this requires enumerating and inspecting the methods of a generic function.
This library tries to complement some of these weaknesses of method-based extension-points via the concept of hooks.
This library exports three symbols: with-raw-io, read-char, and read-line, to provide raw POSIX I/O in Common Lisp.
Library to fuzzily parse time and date strings into a universal-time timestamp.
cl-numerical-utilities is a collection of packages useful in numerical applications, each big enough to be its own package, but too small to split out into a separate ASDF system.
This package provides a BNF parser in Common Lisp.
This library contains generic hacks meant to be used in any project. It was originally developed for the Cells library.
The Metering System is a portable Common Lisp code profiling tool. It gathers timing and consing statistics for specified functions while a program is running.
This library allows you to define custom indentation hints for your macros if the one recognised by SLIME automatically produces unwanted results.
cl-irc is a Common Lisp IRC client library that features (partial) DCC, CTCP and all relevant commands from the IRC RFCs (RFC2810, RFC2811 and RFC2812).
Features:
implements all commands in the RFCs
extra convenience commands such as op/deop, ban, ignore, etc.
partial DCC SEND/CHAT support
event driven model with hooks makes interfacing easy
the user can keep multiple connections
all CTCP commands
Binary-types is a Common Lisp package for reading and writing binary files. Binary-types provides macros that are used to declare the mapping between Lisp objects and some binary (i.e. octet-based) representation.
Plump is a parser for HTML/XML-like documents, focusing on being lenient towards invalid markup. It can handle things like invalid attributes, bad closing tag order, unencoded entities, inexistent tag types, self-closing tags and so on. It parses documents to a class representation and offers a small set of DOM functions to manipulate it. It can be extended to parse to your own classes.