Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides Python bindings to use the Notmuch mail indexing and search library.
alterMIME is a small program which is used to alter your mime-encoded mailpack. What can alterMIME do?
Insert disclaimers,
insert arbitrary X-headers,
modify existing headers,
remove attachments based on filename or content-type,
replace attachments based on filename.
.
Claws-Mail is an email client (and news reader) based on GTK+. The appearance and interface are designed to be familiar to new users coming from other popular email clients, as well as experienced users. Almost all commands are accessible with the keyboard. Plus, Claws-Mail is extensible via addons which can add many functionalities to the base client.
public-inbox implements the sharing of an email inbox via Git to complement or replace traditional mailing lists. Readers may read via NNTP, IMAP, Atom feeds or HTML archives.
Email::Simple provides simple parsing of RFC 2822 message format and headers.
A third-party, open-source ProtonMail bridge. It is designed to run on a server. It supports CardDAV, IMAP and SMTP.
This is an address lookup tool using a Notmuch database, useful for email address completion.
This project is a reimplementation of the Python stdlib smtpd.py based on asyncio.
The RSS2email program (r2e) fetches RSS/Atom news feeds, converts them into emails, and sends them.
Sieve-connect lets you view, upload, edit, delete, and otherwise manage Sieve scripts on any mail server that speaks the ManageSieve protocol, as specified in RFC 5804.
Sieve (RFC 5228) is a specialised language for e-mail filtering. Sieve scripts are stored on the server and run whenever mail arrives. They can automatically sort new messages into folders, silently reject them, send an automated response, and more.
sieve-connect is designed to be both a tool which can be invoked from scripts as well as a decent interactive client. It supports TLS for connection privacy, as well as authentication with SASL or GSSAPI client certificates. It should be a drop-in replacement for sieveshell from the Cyrus IMAP project.
GNU Mailman is software for managing email discussion and mailing lists. Both users and administrators generally perform their actions in a web interface, although email and command-line interfaces are also provided. The system features built-in archiving, automatic bounce processing, content filtering, digest delivery, and more.
The mailmanclient library provides official Python bindings for the GNU Mailman 3 REST API.
fdm fetches and delivers mail in various ways.
Mail may be fetched from IMAP or POP3 servers, from local maildirs, or read from standard input. It is then filtered based on regular expressions, its size or age, or the output of a (shell) command. It can be rewritten by an external process, dropped, left on the server or delivered into maildirs, mboxes, to a file or pipe, or any combination.
fdm is primarily designed for use by a single user, but can use privilege separation to safely deliver mail in multi-user setups.
bubger is a mailing list archive generator for mail stored in IMAP. It produces static files of HTML, Atom and mboxrd, making its output easy to serve from a host without IMAP access. It requires the IMAP THREAD extension.
Urlscan is a small program that is designed to integrate with the Mutt mail reader to allow you to easily launch a Web browser for URLs contained in email messages. It parses an email message or file and scans it for URLs and email addresses. It then displays the URLs and their context within the message, and allows you to choose one or more URLs to send to your Web browser. Alternatively, it send a list of all URLs to standard output. It is a replacement for the urlview program.
Python module that implements DKIM (DomainKeys Identified Mail) email signing and verification (RFC6376). It also provides helper scripts for command line signing and verification. It supports DKIM signing/verifying of ed25519-sha256 signatures (RFC 8463). It also supports the RFC 8617 Authenticated Received Chain (ARC) protocol.
ripMIME is a small program to extract the attached files out of a MIME-encoded email package.
Email::MessageID generates recommended message-ids to identify a message uniquely.
Muchsync brings Notmuch to all of your computers by synchronizing your mail messages and Notmuch tags across machines. The protocol is heavily pipelined to work efficiently over high-latency networks such as mobile broadband. Muchsync supports arbitrary pairwise synchronization among replicas. A version-vector-based algorithm allows it to exchange only the minimum information necessary to bring replicas up to date regardless of which pairs have previously synchronized.
Email::MIME is an extension of the Email::Simple module, to handle MIME encoded messages. It takes a message as a string, splits it up into its constituent parts, and allows you access to various parts of the message. Headers are decoded from MIME encoding.
GNU Mailutils is a collection of programs for managing, viewing and processing electronic mail. It contains both utilities and server daemons and all operate in a protocol-agnostic way. The underlying libraries are also available, simplifying the addition of mail capabilities to new software. GNU Mailutils provides the following commands:
dotlock
decodemail
frm
from
guimb
mail
mailutils
mailutils-config
messages
mimeview
movemail
popauth
putmail
readmsg
sieve
Pigeonhole adds support for the Sieve language (RFC 5228) and the ManageSieve protocol (RFC 5804) to the Dovecot e-mail server.
Sieve is a language for filtering incoming mail. Messages can be forwarded or sorted into separate folders. Unwanted messages can be rejected or discarded, and, when the user is not available, the Sieve interpreter can send an automated reply.
Sieve is meant to be simple, extensible, and system-independent. The intention is to make it impossible to write anything more complex (and dangerous) than simple mail filters. Unlike most other mail filtering script languages, Sieve does not allow users to execute arbitrary programmes.
Through the ManageSieve protocol, users can remotely manage their Sieve scripts without needing file system access. The server accepts only valid scripts to prevent embarrassing errors later on.
Email::Address::XS implements RFC 5322 parser and formatter of email addresses and groups. Unlike Email::Address, this module does not use regular expressions for parsing but instead is implemented in XS and uses shared code from Dovecot IMAP server.
msmtp is an SMTP client. In the default mode, it transmits a mail to an SMTP server (for example at a free mail provider) which takes care of further delivery.