Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
The ngtcp2 project is an effort to implement the RFC9000 (IETF) QUIC protocol.
Net::CIDR::Lite merges IPv4 or IPv6 CIDR addresses.
wireproxy-awg is a completely userspace application that connects to a WireGuard peer, and exposes a SOCKS5/HTTP proxy or tunnels on the machine.
Nebula is a peer-to-peer networking tool based on the Noise Protocol Framework. It is not a fully decentralized network, but instead uses central discovery nodes and a certificate authority to facilitate direct, encrypted peer-to-peer connections from behind most firewalls and NAT layers.
Proxychains-ng is a preloader which hooks calls to sockets in dynamically linked programs and redirects them through one or more SOCKS or HTTP proxies.
wireproxy is a completely userspace application that connects to a wireguard peer, and exposes a socks5/http proxy or tunnels on the machine.
LibNice is a library that implements the Interactive Connectivity Establishment (ICE) standard (RFC 5245 & RFC 8445). It provides a GLib-based library, libnice, as well as GStreamer elements to use it.
Danga::Socket is an abstract base class for objects backed by a socket which provides the basic framework for event-driven asynchronous IO, designed to be fast. Danga::Socket is both a base class for objects, and an event loop.
Command-line interface for LibreSpeed internet bandwidth testing. It functions as a command-line alternative to https://librespeed.org/. It features ping, jitter, download, and upload testing, as well as the ability to test using multiple servers in a single run.
ipcalc takes an IP address and netmask and calculates the resulting broadcast, network, Cisco wildcard mask, and host range. By giving a second netmask, you can design subnets and supernets. It is also intended to be a teaching tool and presents the subnetting results as easy-to-understand binary values.
bmon is a monitoring and debugging tool to capture networking-related statistics and prepare them visually in a human-friendly way. It features various output methods including an interactive curses user interface and a programmable text output for scripting.
Quagga is a routing software suite, providing implementations of OSPFv2, OSPFv3, RIP v1 and v2, RIPng and BGP-4 for Unix platforms.
The Quagga architecture consists of a core daemon, zebra, which acts as an abstraction layer to the underlying Unix kernel and presents the Zserv API over a Unix or TCP stream to Quagga clients. It is these Zserv clients which typically implement a routing protocol and communicate routing updates to the zebra daemon.
The lksctp-tools project provides a user-space library for SCTP (libsctp) and C language header files (netinet/sctp.h) for accessing SCTP-specific APIs not provided by the standard sockets. It also includes some SCTP-related helper utilities.
This package provides CAN utilities in the following areas:
Basic tools to display, record, generate and replay CAN traffic
CAN access via IP sockets
CAN in-kernel gateway configuration
CAN bus measurement and testing
ISO-TP (ISO15765-2:2016 - this means messages with a body larger than eight bytes) tools
Log file converters
Serial Line Discipline configuration for slcan driver
This package contains a small set of tools to capture and convert packets from wireless devices for use with hashcat or John the Ripper.
This package provides header-only C++ bindings for ØMQ. The header files contain direct mappings of the abstractions provided by the ØMQ C API.
libplum (Port Lightweight and Universal Mapping) is a high-level library which allows forwarding ports on Network Address Translators (NAT). Under the hood, it implements multiple protocols and automatically detects which one to use:
Port Control Protocol (PCP)
NAT Port Mapping Protocol (NAT-PMP)
UPnP Internet Gateway Device Protocol (UPnP-IGD)
BIRD is an Internet routing daemon with full support for all the major routing protocols. It allows redistribution between protocols with a powerful route filtering syntax and an easy-to-use configuration interface.
Dropwatch is an interactive utility for monitoring and recording packets that are dropped by the kernel. It provides the commands dropwatch and dwdump.
vnStat is a console-based network traffic monitor that keeps a log of network traffic for the selected interface(s). It uses the network interface statistics provided by the kernel as information source. This means that vnStat won't actually be sniffing any traffic and also ensures light use of system resources regardless of network traffic rate.
SRT is a transport technology that optimizes streaming performance across unpredictable networks, such as the Internet.
NZBGet is a binary newsgrabber, which downloads files from Usenet based on information given in nzb files. NZBGet can be used in standalone and in server/client modes. In standalone mode, you pass NZBGet nzb files as command-line parameters and it downloads them and exits. NZBGet also contains a Web interface. Its server can be controlled through remote procedure calls (RPCs).
Aircrack-ng is a complete suite of tools to assess WiFi network security. It focuses on different areas of WiFi security: monitoring, attacking, testing, and cracking. All tools are command-line driven, which allows for heavy scripting.
Blueman is a Bluetooth management utility using the Bluez D-Bus backend. It is designed to be easy to use for most common Bluetooth tasks.