Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
parprouted is a daemon for transparent IP (Layer 3) proxy ARP bridging. Unlike standard bridging, proxy ARP bridging can bridge Ethernet networks behind wireless nodes. Normal layer 2 bridging does not work between wireless nodes because wireless does not know about MAC addresses used in the wired Ethernet networks. This daemon can also be useful for making transparent firewalls.
IO::Socket::INET6 is an interface for AF_INET/AF_INET6 domain sockets in Perl.
Bandwidth Monitor NG is a small and simple console based live network and disk I/O bandwidth monitor.
Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. It reduces bandwidth and improves response times by caching and reusing frequently-requested web pages.
NNG project is a rewrite of the scalability protocols library known as libnanomsg, and adds significant new capabilities, while retaining compatibility with the original. It is a lightweight, broker-less library, offering a simple API to solve common recurring messaging problems, such as publish/subscribe, RPC-style request/reply, or service discovery.
Pixiewps implements the pixie-dust attack to brute force the Wi-Fi Protected Setup (WPS) PIN by exploiting the low or non-existing entropy of some access points.
knockd is a port-knock daemon. It listens to all traffic on an ethernet or PPP interface, looking for special "knock" sequences of port-hits (UDP/TCP packets sent to a server port). This port need not be open, since knockd listens at the link-layer level.
Yggdrasil is an early-stage implementation of a fully end-to-end encrypted IPv6 network. It is lightweight, self-arranging, supported on multiple platforms and allows pretty much any IPv6-capable application to communicate securely with other Yggdrasil nodes. Yggdrasil does not require you to have IPv6 Internet connectivity - it also works over IPv4.
Spiped (pronounced "ess-pipe-dee") is a utility for creating symmetrically encrypted and authenticated pipes between socket addresses, so that one may connect to one address (e.g., a UNIX socket on localhost) and transparently have a connection established to another address (e.g., a UNIX socket on a different system). This is similar to 'ssh -L' functionality, but does not use SSH and requires a pre-shared symmetric key.
NNG project is a rewrite of the scalability protocols library known as libnanomsg, and adds significant new capabilities, while retaining compatibility with the original. It is a lightweight, broker-less library, offering a simple API to solve common recurring messaging problems, such as publish/subscribe, RPC-style request/reply, or service discovery.
czmq provides bindings for the ØMQ core API that hides the differences between different versions of ØMQ.
Netdiscover is a network address discovery tool developed mainly for wireless networks without a DHCP server. It also works on hub/switched networks. It is based on ARP packets, it will send ARP requests and sniff for replies.
whois searches for an object in a WHOIS (RFC 3912) database. It is commonly used to look up the registered users or assignees of an Internet resource, such as a domain name, an IP address block, or an autonomous system. It can automatically select the appropriate server for most queries.
For historical reasons, this package also includes mkpasswd, which encrypts passwords using crypt(3) and is unrelated to the Expect command of the same name.
GNU MAC Changer is a utility for viewing and changing MAC addresses of networking devices. New addresses may be set explicitly or randomly. They can include MAC addresses of the same or other hardware vendors or, more generally, MAC addresses of the same category of hardware.
With this package you can monitor and filter incoming requests for network services. It includes a library which may be used by daemons to transparently check connection attempts against an access control list.
Reaver performs a brute force attack against an access point's Wi-Fi Protected Setup (WPS) PIN. Once the PIN is found, the WPA passphrase can be recovered and the AP's wireless settings can be reconfigured.
RTMPdump is a toolkit for RTMP streams. All forms of RTMP are supported, including rtmp://, rtmpt://, rtmpe://, rtmpte://, and rtmps://.
uBridge is a simple program to create user-land bridges between various technologies. Currently, bridging between UDP tunnels, Ethernet and TAP interfaces is supported. Packet capture is also supported.
This library provides methods for using the stream control transmission protocol (SCTP) in a Go application.
This package provides a C implementation of a lightweight application-protocol for devices that are constrained their resources such as computing power, RF range, memory, bandwidth, or network packet sizes. This protocol, CoAP, is standardized by the IETF as RFC 7252.
aMule is an eMule-like client for the eD2k and Kademlia peer-to-peer file sharing networks. It includes a graphical user interface (GUI), a daemon allowing you to run a client with no graphical interface, and a Web GUI for remote access. The amulecmd command allows you to control aMule remotely.
libnatpmp is a portable and asynchronous implementation of the Network Address Translation - Port Mapping Protocol (NAT-PMP) written in the C programming language.
ENet's purpose is to provide a relatively thin, simple and robust network communication layer on top of UDP. The primary feature it provides is optional reliable, in-order delivery of packets. ENet omits certain higher level networking features such as authentication, server discovery, encryption, or other similar tasks that are particularly application specific so that the library remains flexible, portable, and easily embeddable.
libyang is a YANG data modelling language parser and toolkit written (and providing API) in C. Current implementation covers YANG 1.0 (RFC 6020) as well as YANG 1.1 (RFC 7950).