Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
IFStatus is a simple, easy-to-use program for displaying commonly needed/wanted real-time traffic statistics of multiple network interfaces, with a simple and efficient view on the command line. It is intended as a substitute for the PPPStatus and EthStatus projects.
iwd is a wireless daemon for Linux that aims to replace WPA Supplicant. It optimizes resource utilization by not depending on any external libraries and instead utilizing features provided by the Linux kernel to the maximum extent possible.
Zapret2 is a packet manipulator primarily designed to perform various autonomous real-time attacks on DPI systems. Its main objective is to bypass resource blocks or protocol restrictions. However, zapret2's capabilities are not limited to this; its architecture allows for other types of packet manipulation, such as bidirectional (client-server) protocol obfuscation to hide traffic from DPI, among other applications.
The configuration file is read from /etc/zapret2/config.
mtr combines the functionality of the traceroute and ping programs in a single network diagnostic tool. mtr can use several network protocols to detect intermediate routers (or hops) between the local host and a user-specified destination. It then continually measures the response time and packet loss at each hop, and displays the results in real time.
This package provides a multi-threaded TFTP server that implements all options, including all extensions, as specified in RFC 1350, RFC 2090, RFC 2347, RFC 2348, RFC 2349 and RFC7440. Atftpd also supports a multicast protocol known as mtftp, which was defined in the PXE specification.
The server is socket activated by default but supports being started from inetd as well as in daemon mode.
Zyre provides reliable group messaging over local area networks using zeromq. It has these key characteristics:
Zyre needs no administration or configuration.
Peers may join and leave the network at any time.
Peers talk to each other without any central brokers or servers.
Peers can talk directly to each other.
Peers can join groups, and then talk to groups.
Zyre is reliable, and loses no messages even when the network is heavily loaded.
Zyre is fast and has low latency, requiring no consensus protocols.
Zyre is designed for WiFi networks, yet also works well on Ethernet networks.
The THC IPv6 Toolkit provides command-line tools and a library for researching IPv6 implementations and deployments. It requires Linux 2.6 or newer and only works on Ethernet network interfaces.
This package provides a control tool for the B.A.T.M.A.N. mesh networking routing protocol provided by the Linux kernel module batman-adv, for Layer 2.
sslh is a network protocol demultiplexer. It acts like a switchboard, accepting connections from clients on one port and forwarding them to different servers based on the contents of the first received data packet. Detection of common protocols like HTTP(S), SSL, SSH, OpenVPN, tinc, and XMPP is already implemented, but any other protocol that matches a regular expression can be added. sslh's name comes from its original application of serving both SSH and HTTPS on port 443, allowing SSH connections from inside corporate firewalls that block port 22.
This package provides a modern, but Linux-specific implementation of the traceroute command that can be used to follow the route taken by packets on an IP network on their way to a given host. It utilizes the IP protocol's time to live (TTL) field and attempts to elicit an ICMP TIME_EXCEEDED response from each gateway along the path to the host. Compared to other implementations, this traceroute command allows some traces for unprivileged users.
mbuffer is a tool for buffering data streams with a large set of features:
direct support for TCP based network targets (IPv4 and IPv6)
ability to send to multiple targets in parallel (distribution mode)
support for multiple volumes
I/O rate limitation
high/low watermark based restart criteria
configurable buffer size
on the fly MD5 hash calculation
highly efficient, multi-threaded implementation
Tool to send a magic packet to wake another host on the network. This must be enabled on the target host, usually in the BIOS.
OpenDHT provides an easy to use distributed in-memory data store. Every node in the network can read and write values to the store. Values are distributed over the network, with redundancy. It includes the following features:
Lightweight and scalable, designed for large networks and small devices;
High resilience to network disruption;
Public key cryptography layer providing optional data signature and encryption (using GnuTLS);
IPv4 and IPv6 support;
Clean and powerful C++14 map API;
Bindings for C, Rust & Python 3;
REST API with an optional HTTP client and server with push notification support.
The following tools are also included:
dhtnodeA command line tool to run a DHT node and perform operations supported by the library (get, put, etc.) with text values.
dhtchatA very simple IM client working over the DHT.
Nload is a console application which monitors network traffic and bandwidth usage in real time. It visualizes the in- and outgoing traffic using two graphs, and provides additional info like total amount of transferred data and min/max network usage.
Open vSwitch is a multilayer virtual switch. It is designed to enable massive network automation through programmatic extension, while still supporting standard management interfaces and protocols (e.g. NetFlow, sFlow, IPFIX, RSPAN, CLI, LACP, 802.1ag).
Wireless networking GUI front-end for iwd, with supported functionality similar to that of iwctl. Features include viewing and connecting to available networks, managing known networks, provisioning new networks via WPS or Wi-Fi Easy Connect, and an indicator icon displaying connection status and signal strength.
Libnet provides a fairly portable framework for network packet construction and injection. It features portable packet creation interfaces at the IP layer and link layer, as well as a host of supplementary functionality. Using libnet, quick and simple packet assembly applications can be whipped up with little effort.
This package is a fast tunnel proxy that helps you bypass firewalls.
Features:
TCP & UDP support
User management API
TCP Fast Open
Workers and graceful restart
Destination IP blacklist
httping measures how long it takes to connect to a web server, send an HTTP(S) request, and receive the reply headers. It is somewhat similar to ping, but can be used even in cases where ICMP traffic is blocked by firewalls or when you want to monitor the response time of the actual web application stack itself.
The Link Layer Discovery Protocol (LLDP) is an industry standard protocol designed to supplant proprietary Link-Layer protocols such as EDP or CDP. The goal of LLDP is to provide an inter-vendor compatible mechanism to deliver Link-Layer notifications to adjacent network devices. lldpd is an implementation of LLDP. It also supports some proprietary protocols.
ENet's purpose is to provide a relatively thin, simple and robust network communication layer on top of UDP. The primary feature it provides is optional reliable, in-order delivery of packets. ENet omits certain higher level networking features such as authentication, server discovery, encryption, or other similar tasks that are particularly application specific so that the library remains flexible, portable, and easily embeddable.
Net::DNS::Resolver::Mock is a subclass of Net::DNS::Resolver, but returns static data from any provided DNS zone file instead of querying the network. It is intended primarily for use in testing.
Eduroam provides roaming network access across all participating research and education networks. Geteduroam-cli is the command line interface version of geteduroam, which sets up a connection in NetworkManager, allowing you to connect to eduroam access points.
Socket6 binds the IPv6 related part of the C socket header definitions and structure manipulators for Perl.