_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


ocaml-monolith 20210525
Propagated dependencies: ocaml-afl-persistent@1.3 ocaml-pprint@20220103 ocaml-seq@0.1
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://gitlab.inria.fr/fpottier/monolith
Licenses: LGPL 3+
Build system: dune
Synopsis: Framework for testing an OCaml library using afl-fuzz
Description:

Monolith offers facilities for testing an OCaml library (for instance, a data structure implementation) by comparing it against a reference implementation. It can be used to perform either random testing or fuzz testing by using the afl-fuzz tool.

ocaml5.0-merlin 4.14-500
Propagated dependencies: ocaml5.0-merlin-lib@4.14-500 ocaml5.0-yojson@2.0.2
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://ocaml.github.io/merlin/
Licenses: Expat
Build system: dune
Synopsis: Context sensitive completion for OCaml in Vim and Emacs
Description:

Merlin is an editor service that provides modern IDE features for OCaml. Emacs and Vim support is provided out-of-the-box. External contributors added support for Visual Studio Code, Sublime Text and Atom.

ocaml-async-rpc-kernel 0.15.0
Propagated dependencies: ocaml-async-kernel@0.15.0 ocaml-core@0.15.1 ocaml-ppx-jane@0.15.0 ocaml-protocol-version-header@0.15.0
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/janestreet/async_rpc_kernel
Licenses: Expat
Build system: dune
Synopsis: Platform-independent core of Async RPC library
Description:

Library for building RPC-style protocols. This library is the portable part of the Unix-oriented Async_rpc library, and is actively used in JavaScript.

ocaml-cmdliner 1.1.1
Dependencies: ocaml-result@1.5
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://erratique.ch/software/cmdliner
Licenses: Modified BSD
Build system: ocaml
Synopsis: Declarative definition of command line interfaces for OCaml
Description:

Cmdliner is a module for the declarative definition of command line interfaces. It provides a simple and compositional mechanism to convert command line arguments to OCaml values and pass them to your functions. The module automatically handles syntax errors, help messages and UNIX man page generation. It supports programs with single or multiple commands and respects most of the POSIX and GNU conventions.

ocaml-dot-merlin-reader 4.14-414
Propagated dependencies: ocaml-merlin-lib@4.14-414
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://ocaml.github.io/merlin/
Licenses: Expat
Build system: dune
Synopsis: Reads config files for @code{ocaml-merlin}
Description:

ocaml-dot-merlin-reader is an external reader for ocaml-merlin configurations.

ocaml-mirage-profile-unix 0.9.1
Propagated dependencies: ocaml-cstruct@6.1.1 ocaml-ocplib-endian@1.2 ocaml-lwt@5.6.1 ocaml-mtime@2.0.0 ocaml-ppx-cstruct@6.1.1
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/mirage/mirage-profile
Licenses: FreeBSD
Build system: dune
Synopsis: Collects Ocaml/Lwt profiling information in CTF format
Description:

Used to trace execution of OCaml/Lwt programs (such as Mirage unikernels) at the level of Lwt threads. The traces can be viewed using JavaScript or GTK viewers provided by mirage-trace-viewer or processed by tools supporting the Common Trace Format. When compiled against a normal version of Lwt, OCaml's cross-module inlining will optimise these calls away, meaning there should be no overhead in the non-profiling case.

ocaml-parsexp 0.15.0
Dependencies: ocaml-sexplib0@0.15.1 ocaml-base@0.15.0
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/janestreet/parsexp
Licenses: Expat
Build system: dune
Synopsis: S-expression parsing library
Description:

This library provides generic parsers for parsing S-expressions from strings or other medium.

The library is focused on performances but still provide full generic parsers that can be used with strings, bigstrings, lexing buffers, character streams or any other sources effortlessly.

It provides three different class of parsers:

  • the normal parsers, producing [Sexp.t] or [Sexp.t list] values

  • the parsers with positions, building compact position sequences so that one can recover original positions in order to report properly located errors at little cost

  • the Concrete Syntax Tree parsers, produce values of type Parsexp.Cst.t which record the concrete layout of the s-expression syntax, including comments

This library is portable and doesn't provide IO functions. To read s-expressions from files or other external sources, you should use parsexp_io.

ocaml-uring 0.5
Propagated dependencies: ocaml-cstruct@6.1.1 ocaml-fmt@0.9.0 ocaml-optint@0.3.0
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/ocaml-multicore/ocaml-uring
Licenses: ISC Expat
Build system: dune
Synopsis: OCaml bindings for Linux io_uring
Description:

This package provides OCaml bindings to the Linux io_uring kernel IO interfaces.

ocaml-sedlex 2.6
Dependencies: ucd@15.1.0
Propagated dependencies: ocaml-gen@1.0 ocaml-ppxlib@0.28.0 ocaml-uchar@0.0.2
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://www.cduce.org/download.html#side
Licenses: Expat
Build system: dune
Synopsis: Lexer generator for Unicode and OCaml
Description:

Lexer generator for Unicode and OCaml.

dune-ordering 3.19.1
Propagated dependencies: dune-configurator@3.19.1
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/ocaml/dune
Licenses: Expat
Build system: dune
Synopsis: Dune element ordering
Description:

This library represents element ordering in OCaml.

ocaml5.0-dune-configurator 3.19.1
Propagated dependencies: ocaml5.0-csexp@1.5.1
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/ocaml/dune
Licenses: Expat
Build system: dune
Synopsis: Dune helper library for gathering system configuration
Description:

Dune-configurator is a small library that helps writing OCaml scripts that test features available on the system, in order to generate config.h files for instance. Among other things, dune-configurator allows one to:

  • test if a C program compiles

  • query pkg-config

  • import #define from OCaml header files

  • generate config.h file

ocaml-emile 1.1
Propagated dependencies: ocaml-angstrom@0.15.0 ocaml-ipaddr@5.3.1 ocaml-base64@3.5.1 ocaml-pecu@0.6 ocaml-bigstringaf@0.9.0 ocaml-uutf@1.0.3
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/mirage/emile
Licenses: Expat
Build system: dune
Synopsis: Parser of email address according RFC822
Description:

This package provides a parser of email address according RFC822, RFC2822, RFC5321 and RFC6532. It handles UTF-8 email addresses and encoded-word according RFC2047.

ocaml-uunf 15.0.0
Propagated dependencies: ocaml-uutf@1.0.3
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://erratique.ch/software/uunf
Licenses: ISC
Build system: ocaml
Synopsis: Unicode text normalization for OCaml
Description:

Uunf is an OCaml library for normalizing Unicode text. It supports all Unicode normalization forms. The library is independent from any IO mechanism or Unicode text data structure and it can process text without a complete in-memory representation.

ocaml5.0-eio-main 0.8.1
Propagated dependencies: ocaml5.0-eio@0.8.1 ocaml5.0-eio-luv@0.8.1 ocaml5.0-eio-linux@0.8.1
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/ocaml-multicore/eio
Licenses: ISC
Build system: dune
Synopsis: Eio backend selector
Description:

Eio_main selects an appropriate backend (e.g. eio_linux or eio_luv), depending on your platform.

ocamlmod 0.0.9
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://forge.ocamlcore.org/projects/ocamlmod
Licenses: LGPL 2.1+
Build system: ocaml
Synopsis: Generate modules from OCaml source files
Description:

Generate modules from OCaml source files.

ocaml-jst-config 0.16.0
Propagated dependencies: ocaml-base@0.15.0 ocaml-ppx-assert@0.15.0 ocaml-stdio@0.15.0 dune-configurator@3.19.1
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/janestreet/jst-config
Licenses: Expat
Build system: dune
Synopsis: Compile-time configuration for Jane Street libraries
Description:

Defines compile-time constants used in Jane Street libraries such as Base, Core, and Async. This package has an unstable interface; it is intended only to share configuration between different packages from Jane Street. Future updates may not be backward-compatible, and we do not recommend using this package directly.

ocaml5.0-merlin-lib 4.14-500
Propagated dependencies: ocaml5.0-csexp@1.5.1 ocaml5.0-menhir@20220210
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://ocaml.github.io/merlin/
Licenses: Expat
Build system: dune
Synopsis: Merlin libraries
Description:

These libraries provides access to low-level compiler interfaces and the standard higher-level merlin protocol.

ocaml-camomile 1.0.2
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/yoriyuki/Camomile
Licenses: LGPL 2.0+
Build system: dune
Synopsis: Comprehensive Unicode library
Description:

Camomile is a Unicode library for OCaml. Camomile provides Unicode character type, UTF-8, UTF-16, UTF-32 strings, conversion to/from about 200 encodings, collation and locale-sensitive case mappings, and more. The library is currently designed for Unicode Standard 3.2.

ocaml5.0-eio-luv 0.8.1
Propagated dependencies: ocaml5.0-eio@0.8.1 ocaml5.0-luv@0.5.14
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/ocaml-multicore/eio
Licenses: ISC
Build system: dune
Synopsis: Libuv-based backend for Ocaml Eio
Description:

Eio_luv provides a cross-platform backend for Ocaml Eio's APIs using luv (libuv)

ocaml-hmap 0.8.1
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://erratique.ch/software/hmap
Licenses: ISC
Build system: ocaml
Synopsis: Heterogeneous value maps for OCaml
Description:

Hmap provides heterogeneous value maps for OCaml. These maps bind keys to values with arbitrary types. Keys witness the type of the value they are bound to which allows adding and looking up bindings in a type safe manner.

ocaml-ppx-module-timer 0.15.0
Propagated dependencies: ocaml-base@0.15.0 ocaml-ppx-base@0.15.0 ocaml-stdio@0.15.0 ocaml-time-now@0.15.0 ocaml-ppxlib@0.28.0
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/janestreet/ppx_module_timer
Licenses: Expat
Build system: dune
Synopsis: Ppx rewriter that records top-level module startup times
Description:

Modules using ppx_module_timer have instrumentation to record their startup time.

ocaml-textutils 0.15.0
Propagated dependencies: ocaml-core@0.15.1 ocaml-core-kernel@0.15.0 ocaml-core-unix@0.15.2 ocaml-ppx-jane@0.15.0 ocaml-textutils-kernel@0.15.0 ocaml-uutf@1.0.3
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: https://github.com/janestreet/textutils
Licenses: Expat
Build system: dune
Synopsis: Text output utilities
Description:

Utilities for working with terminal output, such as color printing.

ocaml5.0-findlib 1.9.5
Channel: guix
Location: gnu/packages/ocaml.scm (gnu packages ocaml)
Home page: http://projects.camlcity.org/projects/findlib.html
Licenses: X11
Build system: gnu
Synopsis: Management tool for OCaml libraries
Description:

The "findlib" library provides a scheme to manage reusable software components (packages), and includes tools that support this scheme. Packages are collections of OCaml modules for which metainformation can be stored. The packages are kept in the file system hierarchy, but with strict directory structure. The library contains functions to look the directory up that stores a package, to query metainformation about a package, and to retrieve dependency information about multiple packages. There is also a tool that allows the user to enter queries on the command-line. In order to simplify compilation and linkage, there are new frontends of the various OCaml compilers that can directly deal with packages.

Total packages: 32836