Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
AnyIO is an asynchronous networking and concurrency library that works on top of either asyncio or trio. It implements trio-like structured concurrency on top of asyncio, and works in harmony with the native SC of trio itself.
This package automatically generates shell tab completion scripts for Python CLI apps.
Polling2 is a utility used to wait for a function to return a certain expected condition.
This package provides a pythonic way to manipulate color representations (HSL, RVB,web, X11, ...).
Grako takes a grammar in a variation of EBNF as input, and outputs a memoizing PEG/Packrat parser in Python.
This package provides a fast, regex-based date parsing library in pure Python.
This package draws tree structures using characters.
Python implementation of the ERIS.
Python client for Consul, a tool for service discovery, monitoring and configuration.
The Python FTP server library provides a high-level interface to write efficient, scalable and asynchronous FTP servers with Python. It is the most complete RFC-959 FTP server implementation available for Python, and has the following traits:
It is lightweight, fast and scalable.
It uses the
sendfile(2)system call for uploads.It uses
epoll,kqueueandselectto handle concurrency asynchronously.It supports FTPS (RFC-4217), IPv6 (RFC-2428), Unicode file names (RFC-2640) and MLSD/MLST commands (RFC-3659).
It has a flexible system of authorizers able to manage both virtual and real users.
SQLGlot is a no-dependency SQL parser, transpiler, optimizer, and engine. It can be used to format SQL or translate between 31 different dialects like DuckDB, Presto / Trino, Spark / Databricks, Snowflake, and BigQuery. It aims to read a wide variety of SQL inputs and output syntactically and semantically correct SQL in the targeted dialects.
This Python package provides a schema-driven structured log data format for the ease of writing and parsing.
PyJWT is a JSON Web Token implementation written in Python.
NLTK provides interfaces to over 50 corpora and lexical resources such as WordNet, along with a suite of text processing libraries for classification, tokenization, stemming, tagging, parsing, and semantic reasoning, wrappers for natural language processing libraries.
sarge is a wrapper for subprocess which provides command pipeline functionality.
Python-GSSAPI provides both low-level and high level wrappers around the GSSAPI C libraries. While it focuses on the Kerberos mechanism, it should also be usable with other GSSAPI mechanisms.
This package provides a port of node.js's EventEmitter to python. Additionally, it includes a number of subclasses useful for implementing async and threaded programming in python, such as async/await.
The cytoolz package implements the same API as provided by toolz. The main differences are that cytoolz is faster and cytoolz offers a C API that is accessible to other projects developed in Cython.
This package contains codecs for transliterating ISO 10646 texts into best-effort representations using smaller coded character sets (ASCII, ISO 8859, etc.).
Docutils is a modular system for processing documentation into useful formats, such as HTML, XML, and LaTeX. It uses reStructuredText, an easy to use markup language, for input.
This package provides tools for converting .rst files to other formats via commands such as rst2man, as well as supporting Python code.
The pip-run command provides on-demand temporary package installation for a single interpreter run. It replaces this series of commands:
$ virtualenv --python pythonX.X --system-site-packages /tmp/env $ /tmp/env/bin/pip install pkg1 pkg2 -r reqs.txt $ /tmp/env/bin/python ... $ rm -rf /tmp/env
This package contains the asynchat module as found in Python versions prior to 3.12. It is provided so that existing code relying on import asynchat is able to continue being used without significant refactoring.
kitchen module provides a python API for all sorts of little useful snippets of code that everybody ends up writing for their projects but never seem big enough to build an independent release. Use kitchen and stop cutting and pasting that code over and over.
This package provides a faster version of dbus-next.