Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides a cython wrapping of the C++ Cap'n Proto library.
This package is designed to load data in Python literal format that was saved to file by the latex2pydata LaTeX package. This allows data to be passed from LaTeX to Python.
Panflute is a Python package that makes Pandoc filters fun to write. It is a pythonic alternative to John MacFarlane's pandocfilters, from which it is heavily inspired.
Blessed is a thin, practical wrapper around terminal styling, screen positioning, and keyboard input.
This library computes and verifies Cyclic Redundancy Check checksums, using predefined and custom CRC configurations.
Configurations:
- CRC8
CCITT AUTOSAR SAEJ1850 SAEJ1850_ZERO BLUETOOTH MAXIM-DOW
- CRC16
XMODEM GSM PROFIBUS MODBUS IBM-3740 KERMIT
- CRC32
CRC32 AUTOSAR BZIP2 POSIX
- CRC64
CRC64
Catppuccin for Python is a soothing pastel palette for Python libraries. It aims to be the middle ground between low and high contrast themes. It also includes themes for IPython, Matplotlib, Pygments and Rich.
This plugin for Flake8 checks for print statements in Python files.
This tool helps to install Rust into a temporary directory, allowing support of Rust-based Python builds. Cargo and rustc are installed into a cache directory, to avoid modifying the host's environment, and further activated using a set of environment variables.
Pystache is a Python implementation of the framework agnostic, logic-free templating system Mustache.
ipyparallel is a Python package and collection of CLI scripts for controlling clusters for Jupyter. ipyparallel contains the following CLI scripts:
ipcluster - start/stop a cluster
ipcontroller - start a scheduler
ipengine - start an engine
This is Python module for RAR archive reading. The interface is made as zipfile like as possible.
pyfavicon is an async favicon fetcher.
This package provides a parser for the "old style" OpenStep property list format (also known as ASCII plist), written in Cython.
This package provides a tool to split a kernel image with appended DTB into separated kernel and DTB files.
This package provides an unmaintained port of sgmllib to Python 3. It is used to parse text files formatted in SGML.
PyDispatcher is an enhanced version of Patrick K. O’Brien’s original dispatcher.py module. It provides the Python programmer with a robust mechanism for event routing within various application contexts.
Included in the package are the robustapply and saferef modules, which provide the ability to selectively apply arguments to callable objects and to reference instance methods using weak-references.
littleutils is a small collection of Python utility functions, useful in the context of writing unit tests among other uses.
Python implementation of the Happy Eyeballs Algorithm described in RFC 6555. Provided with a single file and dead-simple API to allow easy vendoring and integration into other projects.
SocksiPy - A Python SOCKS client module. It provides a socket-like interface that supports connections to any TCP service through the use of a SOCKS4, SOCKS5 or HTTP proxy. The original version was developed by Dan Haim, this is a branch created by Mario Vilas to address some open issues,as the original project seems to have been abandoned circa 2007.
PyMsgBox is a simple, cross-platform, pure Python module for JavaScript-like message boxes. Types of dialog boxes include:
alert
confirm
prompt
password
This package provides Python interface to the SANE scanner and frame grabber interface.
This package provides a Python interface to the MPFR library for multiprecision arithmetic.
This package lets you parse Python docstrings in reST, Google and Numpydoc format.
rfc3987 provides routines for parsing and validation of URIs (see RFC 3986) and IRIs (see RFC 3987).