_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


tissue 0.1.0
Dependencies: bash-minimal@5.2.37 guile@3.0.9 guile-filesystem@0.2.0 guile-git@0.12.1 guile-xapian@0.5.0
Propagated dependencies: skribilo@0.11.1
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://tissue.systemreboot.net
Licenses: GPL 3+
Build system: gnu
Synopsis: Text based project information management system
Description:

tissue is an issue tracker and project information management system built on plain text files and git. It is specifically intended for small free software projects. It features a static site generator to build a project website and a powerful search interface to search through project issues and documentation. The search interface is built on the Xapian search engine library, and is available both as a command-line program and as a web server.

jq 1.8.2
Dependencies: oniguruma@6.9.10
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://jqlang.org
Licenses: CC-BY 3.0 X11 Expat
Build system: gnu
Synopsis: Command-line JSON processor
Description:

jq is like sed for JSON data – you can use it to slice and filter and map and transform structured data with the same ease that sed, awk, grep and friends let you play with text. It is written in portable C. jq can mangle the data format that you have into the one that you want with very little effort, and the program to do so is often shorter and simpler than you'd expect.

perl-io-socket-ip 0.41
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://metacpan.org/release/IO-Socket-IP
Licenses: GPL 1+
Build system: perl
Synopsis: Family-neutral IP socket supporting both IPv4 and IPv6
Description:

This module provides a protocol-independent way to use IPv4 and IPv6 sockets, intended as a replacement for IO::Socket::INET.

perl-plack-middleware-deflater 0.12
Propagated dependencies: perl-plack@1.0033
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://metacpan.org/release/Plack-Middleware-Deflater
Licenses: GPL 1+
Build system: perl
Synopsis: Compress response body with Gzip or Deflate
Description:

Plack::Middleware::Deflater is a middleware to encode your response body in gzip or deflate, based on "Accept-Encoding" HTTP request header. It would save the bandwidth a little bit but should increase the Plack server load, so ideally you should handle this on the frontend reverse proxy servers.

kcgi 1.0.1
Dependencies: zlib@1.3.1
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://kristaps.bsd.lv/kcgi/
Licenses: ISC
Build system: gnu
Synopsis: Minimal CGI and FastCGI library for C/C++
Description:

This package provides a CGI and FastCGI library for C/C++ web applications. It is minimal, secure, and auditable.

wasi-compiler-rt 21.1.8
Dependencies: wasi-libc@28
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://compiler-rt.llvm.org
Licenses: ASL 2.0
Build system: cmake
Synopsis: LLVM compiler runtime builtins for WASI
Description:

This package provides the LLVM compiler runtime builtins library for the WebAssembly System Interface (WASI) target. It includes software implementations of arithmetic operations that are not directly supported by the WebAssembly instruction set.

nghttp3 1.11.0
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://nghttp2.org/nghttp3/
Licenses: Expat
Build system: gnu
Synopsis: HTTP/3 protocol library
Description:

nghttp3 is an implementation of RFC 9114 HTTP/3 mapping over QUIC and RFC 9204 QPACK in C. It does not depend on any particular QUIC transport implementation.

It implements extensions specified in RFC 9218 and RFC 9220. It supports SETTINGS_H3_DATAGRAM from RFC 9297.

It does not support server push.

webhook 2.8.3
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://github.com/adnanh/webhook
Licenses: Expat ASL 2.0
Build system: go
Synopsis: Lightweight incoming webhook server
Description:

webhook is a lightweight configurable tool to create HTTP endpoints (hooks) which can execute configured commands. Data from the HTTP request (such as headers, payload or query variables) can be passed on to the configured commands. Hooks may also be configured to trigger only when certain rules are satisfied.

webhook aims to be minimal and do nothing more than it should do. And, that is:

  • receive the request

  • parse the headers, payload and query variables

  • check if the specified rules for the hook are satisfied

  • and finally, pass the specified arguments to the specified command via command line arguments or via environment variables.

perl-www-opensearch 0.17
Dependencies: perl-data-page@2.03 perl-libwww@6.78 perl-uri@5.05 perl-uri-template@0.24 perl-xml-feed@0.63 perl-xml-libxml@2.0134
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://metacpan.org/release/WWW-OpenSearch
Licenses: GPL 1+
Build system: perl
Synopsis: Search A9 OpenSearch compatible engines
Description:

WWW::OpenSearch is a module to search http://opensearch.a9.com compatible search engines.

darkhttpd 1.17
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://unix4lyfe.org/darkhttpd/
Licenses: ISC
Build system: gnu
Synopsis: Simple static web server
Description:

darkhttpd is a simple static web server. It is standalone and does not need inetd or ucspi-tcp. It does not need any config files---you only have to specify the www root.

gumbo-parser 0.10.1
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://github.com/google/gumbo-parser
Licenses: ASL 2.0
Build system: gnu
Synopsis: HTML5 parsing library
Description:

Gumbo is an implementation of the HTML5 parsing algorithm implemented as a pure C99 library.

java-signpost-core 1.2.1.2
Propagated dependencies: java-commons-codec@1.15
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://github.com/mttkay/signpost
Licenses: ASL 2.0
Build system: ant
Synopsis: Lightweight client-side OAuth library for Java
Description:

Signpost is the easy and intuitive solution for signing HTTP messages on the Java platform in conformance with the OAuth Core 1.0a standard. Signpost follows a modular and flexible design, allowing you to combine it with different HTTP messaging layers.

civetweb 1.16
Dependencies: zlib@1.3.1
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://github.com/civetweb/civetweb
Licenses: Expat
Build system: cmake
Synopsis: C/C++ embeddable web server
Description:

CivetWeb is a web server with optional CGI and SSL support. It can be embedded into C/C++ applications or used as a standalone web server.

libsass 3.6.4
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://sass-lang.com/libsass
Licenses: Expat
Build system: gnu
Synopsis: SASS Compiler, implemented as a C/C++ library
Description:

LibSass is a SASS compiler library designed for portability and efficiency. To actually compile SASS stylesheets, you'll need to use another program that uses this library, sassc for example.

perl-catalyst-devel 1.42
Propagated dependencies: perl-catalyst-action-renderview@0.16 perl-catalyst-plugin-configloader@0.35 perl-catalyst-plugin-static-simple@0.36 perl-catalyst-runtime@5.90124 perl-config-general@2.63 perl-file-changenotify@0.24 perl-file-copy-recursive@0.38 perl-file-sharedir@1.116 perl-module-install@1.19 perl-moose@2.2015 perl-moosex-emulate-class-accessor-fast@0.009032 perl-namespace-autoclean@0.29 perl-namespace-clean@0.27 perl-path-class@0.37 perl-template-toolkit@2.28
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://metacpan.org/release/Catalyst-Devel
Licenses: GPL 1+
Build system: perl
Synopsis: Catalyst Development Tools
Description:

The Catalyst-Devel distribution includes a variety of modules useful for the development of Catalyst applications, but not required to run them. Catalyst-Devel includes the Catalyst::Helper system, which autogenerates scripts and tests; Module::Install::Catalyst, a Module::Install extension for Catalyst; and requirements for a variety of development-related modules.

perl-html-parser 3.85
Propagated dependencies: perl-html-tagset@3.20 perl-http-message@6.37 perl-uri@5.05
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://metacpan.org/release/HTML-Parser
Licenses: GPL 1+
Build system: perl
Synopsis: Perl HTML parser class
Description:

Objects of the HTML::Parser class will recognize markup and separate it from plain text (alias data content) in HTML documents. As different kinds of markup and text are recognized, the corresponding event handlers are invoked.

kiwix-lib 13.1.0
Dependencies: aria2@1.37.0 curl@8.20.0 icu4c@73.1 libmicrohttpd@1.0.10 libzim@9.8.1 pugixml@1.12.1 xapian@2.1.0 zlib@1.3.1 zstd@1.5.6
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://github.com/kiwix/kiwix-lib/
Licenses: GPL 3
Build system: meson
Synopsis: Common code base for all Kiwix ports
Description:

The Kiwix library provides the Kiwix software suite core. It contains the code shared by all Kiwix ports.

perl-catalyst-view-download 0.09
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://metacpan.org/release/Catalyst-View-Download
Licenses: GPL 1+
Build system: perl
Synopsis: Download data in many formats
Description:

The purpose of this module is to provide a method for downloading data into many supportable formats. For example, downloading a table based report in a variety of formats (CSV, HTML, etc.).

perl-html-tidy 1.60
Dependencies: perl-libwww@6.78 tidyp@1.04
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://metacpan.org/release/HTML-Tidy
Licenses: Artistic License 2.0
Build system: perl
Synopsis: (X)HTML validation in a Perl object
Description:

HTML::Tidy is an HTML checker in a handy dandy object. It's meant as a replacement for HTML::Lint, which is written in Perl but is not nearly as capable as HTML::Tidy.

iocaine 3.5.1
Dependencies: clang@22.1.8 lua@5.4.8 mimalloc@3.3.2 nftables@1.0.8 zstd@1.5.6
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://iocaine.madhouse-project.org/
Licenses: Expat
Build system: cargo
Synopsis: Serves poisonous data to large language model scrapers
Description:

Iocaine is an HTTP server that generates a stable endless maze of Markov-babble-filled web pages. Placed behind a heavily rate-limited reverse proxy, it becomes a ``tar pit'' for trapping aggressive web scrapers commonly used to train large language models, and poisoning the collected data.

httrack 3.49.6
Dependencies: coucal@0-1.73ada07 libressl@4.3.2 zlib@1.3.1
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://www.httrack.com/
Licenses: GPL 3+
Build system: gnu
Synopsis: Easy-to-use offline browser utility
Description:

HTTrack allows you to download a World Wide Web site from the Internet to a local directory, building recursively all directories, getting HTML, images, and other files from the server to your computer.

HTTrack arranges the original site's relative link-structure. Simply open a page of the mirrored website in your browser, and you can browse the site from link to link, as if you were viewing it online. HTTrack can also update an existing mirrored site, and resume interrupted downloads.

HTTrack is fully configurable, and has an integrated help system.

perl-html-tree 5.07
Propagated dependencies: perl-html-parser@3.85 perl-html-tagset@3.20 perl-libwww@6.78
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://metacpan.org/release/HTML-Tree
Licenses: GPL 1+
Build system: perl
Synopsis: Work with HTML in a DOM-like tree structure
Description:

This distribution contains a suite of modules for representing, creating, and extracting information from HTML syntax trees.

websocketpp-next 0.8.2-next
Dependencies: boost@1.83.0 openssl@3.5.7
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://www.zaphoyd.com/websocketpp/
Licenses: Modified BSD
Build system: cmake
Synopsis: C++ library implementing the WebSocket protocol
Description:

WebSocket++ is a C++ library that can be used to implement WebSocket functionality. The goals of the project are to provide a WebSocket implementation that is simple, portable, flexible, lightweight, low level, and high performance.

perl-catalyst-plugin-stacktrace 0.12
Propagated dependencies: perl-catalyst-runtime@5.90124 perl-devel-stacktrace@2.04 perl-mro-compat@0.13
Channel: guix
Location: gnu/packages/web.scm (gnu packages web)
Home page: https://metacpan.org/release/Catalyst-Plugin-StackTrace
Licenses: GPL 1+
Build system: perl
Synopsis: Stack trace on the Catalyst debug screen
Description:

This plugin enhances the standard Catalyst debug screen by including a stack trace of your application up to the point where the error occurred. Each stack frame is displayed along with the package name, line number, file name, and code context surrounding the line number.

Total packages: 32967