_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


go-github-com-ooni-oohttp 0.8.1
Propagated dependencies: go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/ooni/oohttp
Licenses: Modified BSD
Build system: go
Synopsis: Modified fork of Go stdlib's @code{net/http}
Description:

Package http is a fork of stdlib's net/http that provides HTTP client and server implementations that are compatible with alternative TLS libraries such as github.com/refraction-networking/utls.

go-github-com-pion-mdns 0.0.12
Propagated dependencies: go-github-com-pion-logging@0.2.4 go-github-com-pion-transport-v3@3.1.1 go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/pion/mdns/
Licenses: Expat
Build system: go
Synopsis: Pure Go implementation of Multicast DNS
Description:

This package implements a mDNS (multicast DNS) used by Pion.

go-github-com-datadog-datadog-go-v5 5.5.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/DataDog/datadog-go
Licenses: Expat
Build system: go
Synopsis: Golang client library to work with DataDog's API
Description:

datadog-go is a library that provides a DogStatsD client in Golang.

go-github-com-stathat-go 1.0.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/stathat/go
Licenses: Expat
Build system: go
Synopsis: Post statistics to StatHat
Description:

This is a Go package for posting to a StatHat account.

go-github-com-chris-ramon-douceur 0.2.0
Propagated dependencies: go-github-com-aymerick-douceur@0.2.0 go-github-com-gorilla-css@1.0.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/chris-ramon/douceur/
Licenses: Expat
Build system: go
Synopsis: CSS parser and inliner
Description:

This package provides a CSS parser and inliner.

go-github-com-aphistic-golf 0.0.0-20180712155816-02c07f170c5a
Propagated dependencies: go-github-com-google-uuid@1.6.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/aphistic/golf
Licenses: Expat
Build system: go
Synopsis: Integration client for Graylog backed services
Description:

This package implement a functionality to send logs to services supporting GELF specified in https://go2docs.graylog.org/current/home.html.

go-github-com-tink-crypto-tink-go-awskms-v2 2.1.0
Propagated dependencies: go-github-com-aws-aws-sdk-go@1.55.7 go-github-com-tink-crypto-tink-go-v2@2.6.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/tink-crypto/tink-go-awskms
Licenses: ASL 2.0
Build system: go
Synopsis: Tink Go AWS KMS extension
Description:

This is an extension to the Tink Go library that provides support for AWS KMS.

go-github-com-lestrrat-go-httpcc 1.0.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/lestrrat-go/httpcc
Licenses: Expat
Build system: go
Synopsis: HTTP/1.1 Cache-Control header parser for Golang
Description:

This package provides a Go library that parses HTTP/1.1 Cache-Control header and returns a struct that is convenient for the end-user to do what they will with.

go-github-com-hetznercloud-hcloud-go-v2 2.43.0
Propagated dependencies: go-github-com-prometheus-client-golang@1.23.2 go-golang-org-x-crypto@0.53.0 go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/hetznercloud/hcloud-go
Licenses: Expat
Build system: go
Synopsis: Golang library for the Hetzner Cloud API
Description:

This package provides a library for the Hetzner Cloud API.

go-github-com-ccding-go-stun 0.1.4
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/ccding/go-stun
Licenses: ASL 2.0
Build system: go
Synopsis: STUN client implementation
Description:

Go-stun is a go implementation of the STUN client (RFC 3489 and RFC 5389).

go-github-com-azure-azure-sdk-for-go-sdk-security-keyvault-internal 1.2.0
Propagated dependencies: go-github-com-azure-azure-sdk-for-go-sdk-azcore@1.20.0 go-github-com-azure-azure-sdk-for-go-sdk-internal@1.11.2
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/Azure/azure-sdk-for-go
Licenses: Expat
Build system: go
Synopsis: Key Vault Internal Module for Go
Description:

This module contains shared code for all the Key Vault SDKs, mainly the challenge authentication policy.

go-github-com-internxt-rclone-adapter 0.0.0-20260904121407-404a75f3d031
Propagated dependencies: go-github-com-tyler-smith-go-bip39@1.1.0 go-golang-org-x-crypto@0.53.0 go-golang-org-x-image@0.32.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/internxt/rclone-adapter
Licenses: Expat
Build system: go
Synopsis: Internxt Drive API in Go
Description:

This package provides a pure Go library allowing you to interact with the Internxt Drive API. It's a clone of https://github.com/StarHack/go-internxt-drive.

go-github-com-gorilla-websocket 1.5.3
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/gorilla/websocket
Licenses: FreeBSD
Build system: go
Synopsis: Fast WebSocket implementation for Go
Description:

Gorilla WebSocket is a Go implementation of the WebSocket protocol.

go-github-com-go-ping-ping 1.2.0
Propagated dependencies: go-github-com-google-uuid@1.6.0 go-golang-org-x-net@0.53.0 go-golang-org-x-sync@0.21.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/go-ping/ping
Licenses: Expat
Build system: go
Synopsis: ICMP ping library
Description:

This package provides a simple but powerful ICMP echo (ping) library.

go-github-com-google-nftables 0.3.0
Propagated dependencies: go-github-com-mdlayher-netlink@1.7.2 go-github-com-vishvananda-netns@0.0.5 go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/google/nftables
Licenses: ASL 2.0
Build system: go
Synopsis: Go module for interacting with Linux nftables
Description:

This package provides a library to manipulates Linux nftables (the iptables successor). It does not rely on libnftnl wrappers.

go-modernc-org-ccorpus 1.11.6
Propagated dependencies: go-modernc-org-httpfs@1.0.6
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://gitlab.com/cznic/ccorpus
Licenses: Modified BSD
Build system: go
Synopsis: Test body of C code for Golang
Description:

This package provides a test corpus of C code as subset of modernc.org/httpfs.

go-github-com-lum8rjack-go-ja4h 0.0.0-20250828030157-fa5266d50650
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/lum8rjack/go-ja4h
Licenses: Expat
Build system: go
Synopsis: JA4H Fingerprint in Golang
Description:

This Package provides an implementation of the JA4HTTP (JA4H) hashing algorithm.

go-github-com-pion-rtcp 1.2.16
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/pion/rtcp
Licenses: Expat
Build system: go
Synopsis: Implementation of RTCP protocol in Golang
Description:

Package rtcp implements encoding and decoding of RTCP packets according to RFC 3550, RFC 5506.

go-modernc-org-httpfs 1.0.6
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://gitlab.com/cznic/httpfs
Licenses: Modified BSD
Build system: go
Synopsis: HTTP file system implementation in Golang
Description:

Package httpfs implements http.FileSystem on top of a map[string]string.

go-github-com-elazarl-goproxy 0.0.0-20241221210044-9faedc2f9e9f
Propagated dependencies: go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/elazarl/goproxy
Licenses: Modified BSD
Build system: go
Synopsis: HTTP proxy library for Go
Description:

GoProxy is a library to create a customized HTTP/HTTPS proxy server using Go (aka Golang), with several configurable settings available. The target of this project is to offer an optimized proxy server, usable with reasonable amount of traffic, yet customizable and programmable.

go-github-com-hashicorp-go-secure-stdlib-strutil 0.1.2
Propagated dependencies: go-github-com-ryanuber-go-glob@1.0.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/hashicorp/go-secure-stdlib
Licenses: MPL 2.0
Build system: go
Synopsis: Stdlib for HashiCorp Secure products
Description:

This package provides the strutil Golang package. It is part of HashiCorp's Secure division products stdlib.

go-github-com-uptrace-bunrouter 1.0.23
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/uptrace/bunrouter
Licenses: Expat
Build system: go
Synopsis: HTTP router for Golang
Description:

BunRouter is a fast HTTP router for Go with unique combination of features:

  • middlewares allow to extract common operations from HTTP handlers into reusable functions

  • error handling allows to further reduce the size of HTTP handlers by handling errors in middlewares

  • routes priority enables meaningful matching priority for routing rules: first static nodes, then named nodes, lastly wildcard nodes

  • net/http compatible API which means using minimal API without constructing huge wrappers that try to do everything: from serving static files to XML generation (for example, gin.Context or echo.Context)

go-github-com-xeipuuv-gojsonreference 0.0.0-0.bd5ef7b
Propagated dependencies: go-github-com-xeipuuv-gojsonpointer@0.0.0-0.4e3ac27
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/xeipuuv/gojsonreference
Licenses: ASL 2.0
Build system: go
Synopsis: Implementation of JSON Reference for Go
Description:

This package provides an implementation of JSON Reference for the Go programming language.

go-github-com-things-go-go-socks5 0.0.6
Propagated dependencies: go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/things-go/go-socks5
Licenses: Expat
Build system: go
Synopsis: SOCKS5 with full TCP/UDP and IPv4/IPv6 support in Golang
Description:

This package implements a SOCKS5. SOCKS (Secure Sockets) is used to route traffic between a client and server through an intermediate proxy layer. This can be used to bypass firewalls or NATs.

Features:

  • support socks5 server

  • support TCP/UDP and IPv4/IPv6

  • unit tests

  • "No Auth" mode

  • user/password authentication optional user addr limit

  • support for the CONNECT command

  • support for the ASSOCIATE command

  • rules to do granular filtering of commands

  • custom DNS resolution

  • custom goroutine pool

  • buffer pool design and optional custom buffer pool

  • custom logger

Total packages: 33008