Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package implements the data representation portion of the External Data Representation (XDR) standard protocol as specified in RFC4506 (obsoletes RFC 1832 and RFC 1014) in Go.
This package provides a HTTP client functionality that can be used across various Sakura Cloud APIs (IaaS, ObjectStorage, PHY, etc.).
This package allows the kernel's routing tables to be read and altered. Network routes, IP addresses, Link parameters, Neighbor setups,Queueing disciplines, Traffic classes and Packet classifiers may all be controlled. It is based on netlink messages.
This package provides a collection of small Go networking packages.
This package provides a partial Go implementation of the Remote Call Procedure libraries, presented in @urlhttp://pubs.opengroup.org/onlinepubs/9629399/,CDE 1.1: Remote Procedure Call.
This package allows the kernel's routing tables to be read and altered. Network routes, IP addresses, Link parameters, Neighbor setups,Queueing disciplines, Traffic classes and Packet classifiers may all be controlled. It is based on netlink messages.
This package provides Go implementations of components for working with Certificate Transparency (CT) logs. CT is a method for publicly logging TLS certificates to help detect mis-issued or malicious certificates.
This package provides examples to help users get started with gRPC-Go.
They are arranged as follows:
helloworld- a simple example showing a basic client and serverrouteguide- a more complicated example showing different types of streaming RPCsfeatures- a collection of examples, each focused on a single gRPC feature
data is a directory containing data used by the examples, e.g. TLS certificates.
This package implements a functionality plugin domain or vendor specific custom logic into OCI - compatible runtimes. This logic can make controlled changes to containers or perform extra actions outside the scope of OCI at certain points in a containers lifecycle. This can be used, for instance, for improved allocation and management of devices and other container resources.
Server-sent events is a technology where a browser receives automatic updates from a server via HTTP connection. The SSE EventSource API is standardized as part of HTML5[1] by the W3C.
Interceptor is a framework for building RTP/RTCP communication software. This framework defines a interface that each interceptor must satisfy. These interceptors are then run sequentially.
The Microsoft Authentication Library (MSAL) for Go is part of the Microsoft identity platform for developers (formerly named Azure AD) v2.0. It allows you to sign in users or apps with Microsoft identities (Azure AD and Microsoft Accounts) and obtain tokens to call Microsoft APIs such as Microsoft Graph or your own APIs registered with the Microsoft identity platform. It is built using industry standard OAuth2 and OpenID Connect protocols.
Concise Binary Object Representation is a superset of JSON's schema that's faster and more compact.
Package profiler is a client for the Cloud Profiler service.
Package otgrpc provides tests mocks for OpenTracing support for any gRPC client or server.
Package otel provides global access to the OpenTelemetry API. The subpackages of the otel package provide an implementation of the OpenTelemetry API. This package contains 3 Golang modules: go.opentelemetry.io/otel, go.opentelemetry.io/otel/metric and go.opentelemetry.io/otel/trace.
Package zPages implements a collection of HTML pages that display telemetry stats.
Chi is a lightweight, idiomatic and composable router for building Go HTTP services. It is based on the standard Go net/http package and supports middleware, routing groups, and URL parameters.
This package provides a Golang library to determine the real client IP address by inspecting common headers such as X-Forwarded-For and X-Real-IP, with safe fallbacks in the presence of proxies.
This package provides a Go module fasthttp which may be used as replacement for native net/http module. It is optimized for high performance with zero memory allocations in hot paths.
Package opentracing implements a bridge that forwards OpenTracing API calls to the OpenTelemetry SDK.
The jwz package provides an implementation of the email threading algorithm originally designed for use in Netscape Mail 2.0 and 3.0 for Golang.
This package provides gRPC Go Middlewares: interceptors, helpers and utilities - middleware that is executed either on the gRPC Server before the request is passed onto the user's application logic, or on the gRPC client either around the user call. It is a perfect way to implement common patterns: auth, logging, tracing, metrics, validation, retries, rate limiting and more, which can be a great generic building blocks that make it easy to build multiple microservices easily.