_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


go-github-com-emersion-go-imap-id 0.0.0-0.f94a56b
Propagated dependencies: go-github-com-emersion-go-imap@1.2.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/emersion/go-imap-id
Licenses: Expat
Build system: go
Synopsis: ID extension for go-imap
Description:

This package provides an ID extension for go-imap as specified in RFC 2971.

go-github-com-mattn-go-xmlrpc 0.0.3
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/mattn/go-xmlrpc
Licenses: Expat
Build system: go
Synopsis: XML RPC interface for Golang
Description:

This package implements XML RPC interface for Go programming language.

go-github-com-pquerna-cachecontrol 0.2.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/pquerna/cachecontrol
Licenses: ASL 2.0
Build system: go
Synopsis: Golang HTTP Cache-Control Parser and Interpretation
Description:

This package implements RFC 7234 Hypertext Transfer Protocol (HTTP/1.1): Caching.

go-github-com-a-h-templ 0.3.943
Propagated dependencies: go-github-com-a-h-parse@0.0.0-20250122154542-74294addb73e go-github-com-andybalholm-brotli@1.1.1 go-github-com-cenkalti-backoff-v4@4.3.0 go-github-com-cli-browser@1.3.0 go-github-com-fatih-color@1.17.0 go-github-com-fsnotify-fsnotify@1.9.0 go-github-com-google-go-cmp@0.7.0 go-github-com-natefinch-atomic@1.0.1 go-github-com-rs-cors@1.11.1 go-golang-org-x-mod@0.35.0 go-golang-org-x-net@0.53.0 go-golang-org-x-sync@0.21.0 go-golang-org-x-tools@0.46.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://templ.guide/
Licenses: Expat
Build system: go
Synopsis: Language for writing HTML user interfaces in Golang
Description:

This package implements a functionality to create components that render fragments of HTML and compose them to create screens, pages, documents, or apps.

go-github-com-dpotapov-go-spnego 0.0.0-20220426193508-b7f82e4507db
Propagated dependencies: go-github-com-jcmturner-gokrb5-v8@8.4.4 go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/dpotapov/go-spnego
Licenses: Expat
Build system: go
Synopsis: HTTP calls with Kerberos authentication
Description:

The package extends Go's HTTP Transport allowing Kerberos authentication through Negotiate mechanism (see RFC4559).

go-github-com-hokaccha-go-prettyjson 0.0.0-20211117102719-0474bc63780f
Propagated dependencies: go-github-com-fatih-color@1.17.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/hokaccha/go-prettyjson
Licenses: Expat
Build system: go
Synopsis: JSON pretty print for Golang
Description:

Package prettyjson provides JSON pretty print.

go-github-com-gorilla-handlers 1.5.1
Propagated dependencies: go-github-com-felixge-httpsnoop@1.0.4
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/gorilla/handlers
Licenses: Modified BSD
Build system: go
Synopsis: Middleware for Go HTTP services and web applications
Description:

A collection of useful middleware for Go HTTP services and web applications.

go-github-com-circonus-labs-circonus-gometrics 2.3.1
Propagated dependencies: go-github-com-hashicorp-go-retryablehttp@0.7.8 go-github-com-openhistogram-circonusllhist@0.4.0 go-github-com-pkg-errors@0.9.1 go-github-com-tv42-httpunix@0.0.0-0.2ba4b9c
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/circonus-labs/circonus-gometrics
Licenses: Modified BSD
Build system: go
Synopsis: Circonus metrics tracking for Golang
Description:

This library supports named counters, gauges and histograms. It also provides convenience wrappers for registering latency instrumented functions with Go's builtin http server.

go-gitlab-torproject-org-tpo-anti-censorship-geoip 0.0.0-20210928150955-7ce4b3d98d01
Propagated dependencies: go-github-com-smartystreets-goconvey@1.8.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://gitlab.torproject.org/tpo/anti-censorship/geoip
Licenses: Modified BSD
Build system: go
Synopsis: GeoIP go library that uses the tor geoipdb
Description:

This code is for loading database data that maps IP addresses to countries for collecting and presenting statistics on snowflake use that might alert us to censorship events.

go-github-com-pion-datachannel 1.6.0
Propagated dependencies: go-github-com-pion-logging@0.2.4 go-github-com-pion-sctp@1.9.2 go-github-com-pion-transport-v4@4.0.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/pion/datachannel
Licenses: Expat
Build system: go
Synopsis: Implementation of WebRTC Data Channels in Golang
Description:

This package implements WebRTC Data Channels.

go-github-com-lestrrat-go-strftime 1.1.1
Propagated dependencies: go-github-com-pkg-errors@0.9.1 go-github-com-lestrrat-go-envload@0.0.0-20180220234015-a3eb8ddeffcc
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/lestrrat-go/strftime
Licenses: Expat
Build system: go
Synopsis: Strftime for Golang
Description:

This package provides a Golang library implementing the conversion of date and time information from a given calendar time to a character string according to a format string. It is optimized for scenarios where the same pattern is called repeatedly.

go-modernc-org-fileutil 1.3.40
Propagated dependencies: go-modernc-org-mathutil@1.7.1
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://gitlab.com/cznic/fileutil
Licenses: Modified BSD
Build system: go
Synopsis: File utility functions
Description:

Package fileutil collects some file utility functions.

go-github-com-modern-go-concurrent 1.0.3
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/modern-go/concurrent
Licenses: ASL 2.0
Build system: go
Synopsis: Concurrency utilities for Go
Description:

A Go library providing various concurrency utilities including a backport of sync.Map to Go versions below 1.9 and a cancellable Goroutine with explicit ownership.

go-github-com-decred-dcrd-container-lru 1.0.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/decred/dcrd
Licenses: ISC
Build system: go
Synopsis: LRU data structures for Go
Description:

Package lru provides generic type and concurrent safe Least Recently Used data structures with near O(1) perf and optional time-based expiration support.

go-github-com-relvacode-iso8601 1.7.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/relvacode/iso8601
Licenses: Expat
Build system: go
Synopsis: ISO8601 date parser for Golang
Description:

Package iso8601 is a utility for parsing ISO8601 datetime strings into native Go times. The standard library's RFC3339 reference layout can be too strict for working with 3rd party APIs, especially ones written in other languages.

go-go-abhg-dev-komplete 0.1.0
Propagated dependencies: go-github-com-alecthomas-kong@1.12.1 go-github-com-buildkite-shellwords@0.0.0-20180315110454-59467a9b8e10
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://go.abhg.dev/komplete
Licenses: Modified BSD
Build system: go
Synopsis: Shell completion support for Kong CLI parser
Description:

This package provides a command-line completion engine for the Kong CLI parser.

go-github-com-scylladb-termtables 0.0.0-20191203121021-c4c0b6d42ff4
Propagated dependencies: go-github-com-mattn-go-runewidth@0.0.19
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/scylladb/termtables
Licenses: ASL 2.0
Build system: go
Synopsis: Go ASCII table generator
Description:

This package is a Go port of the Ruby terminal-tables library for fast and simple ASCII table generation.

go-github-com-ajstarks-deck-generate 0.0.0-0.d56fad5
Propagated dependencies: go-github-com-ajstarks-deck@0.0.0-0.d56fad5
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/ajstarks/svgo
Licenses: CC-BY 3.0
Build system: go
Synopsis: High-level API for the creation of slide decks
Description:

This package provides a high-level API for the creation of slide decks using the structures of the deck package (github.com/ajstarks/deck). Initialization of the package specifies the io.Writer destination for the generated markup, along with the width and height of the slides's canvas. Each deck element (text, list, image, rect, ellipse, line, curve, arc, and polygon) are supported. Slides use a percentage-based coordinate system (origin at the lower left corner, x increasing left to right, 0-100%, y increasing upwards, 0-100%).

go-github-com-charmbracelet-x-cellbuf 0.0.13
Propagated dependencies: go-github-com-charmbracelet-colorprofile@0.3.2 go-github-com-charmbracelet-x-ansi@0.10.2 go-github-com-charmbracelet-x-term@0.2.1 go-github-com-mattn-go-runewidth@0.0.19 go-github-com-rivo-uniseg@0.4.7
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/charmbracelet/x
Licenses: Expat
Build system: go
Synopsis: Terminal cell buffer functionality
Description:

Package cellbuf provides terminal cell buffer functionality.

go-github-com-c2h5oh-datasize 0.0.0-20231215233829-aa82cc1e6500
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/c2h5oh/datasize
Licenses: Expat
Build system: go
Synopsis: Golang helpers for data sizes
Description:

This package provides Go helpers for data sizes (kilobytes, petabytes), human readable sizes, parsing.

go-github-com-dchest-stemmer 0.0.0-20161207102402-66719a20c4b5
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/dchest/stemmer
Licenses: FreeBSD
Build system: go
Synopsis: Stemmer package for Golang
Description:

Stemmer package provides an interface for stemmers and includes English, German and Dutch stemmers as sub-packages.

go-github-com-bmizerany-perks-quantile 0.0.0-20230307044200-03f9df79da1e
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/bmizerany/perks
Licenses: FreeBSD
Build system: go
Synopsis: Library for computing quantiles
Description:

Perks contains the Go package quantile that computes approximate quantiles over an unbounded data stream within low memory and CPU bounds.

Total packages: 33008