Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides number datatypes which store their values in type parameters, making them runtime constants.
This package implements handy macros @recipe and @series which will define a custom transformation and attach attributes for user types. Its design is an attempt to simplify and generalize the summary and display of types and data from external packages. With this package it is possible to describe visualization routines that can be used as components in more complex visualizations.
AstroTime.jl provides a high-precision, time-scale aware, DateTime-like data type which supports all commonly used astronomical time scales.
This package provides these irrational constants:
twoπ = 2π
fourπ = 4π
halfπ = π / 2
quartπ = π / 4
invπ = 1 / π
twoinvπ = 2 / π
fourinvπ = 4 / π
inv2π = 1 / (2π)
inv4π = 1 / (4π)
sqrt2 = √2
sqrt3 = √3
sqrtπ = √π
sqrt2π = √2π
sqrt4π = √4π
sqrthalfπ = √(π / 2)
invsqrt2 = 1 / √2
invsqrtπ = 1 / √π
invsqrt2π = 1 / √2π
loghalf = log(1 / 2)
logtwo = log(2)
logten = log(10)
logπ = log(π)
log2π = log(2π)
log4π = log(4π)
This minimalistic package serves as the foundation for working with colors in Julia. It defines basic color types and their constructors, and sets up traits and show methods to make them easier to work with.
PositiveFactorizations is a package for computing a positive definite matrix decomposition (factorization) from an arbitrary symmetric input. The motivating application is optimization (Newton or quasi-Newton methods), in which the canonical search direction -H/g (H being the Hessian and g the gradient) may not be a descent direction if H is not positive definite.
This library provides tools for working with Julia code and expressions. This includes a template-matching system and code-walking tools that let you do deep transformations of code.
This package provides reader/writer for delimited text data, as comma-delimited (csv), tab-delimited (tsv), or otherwise.
This package provides the DiffResult type, which can be passed to in-place differentiation methods instead of an output buffer.
ExprTools provides tooling for working with Julia expressions during metaprogramming. This package aims to provide light-weight performant tooling without requiring additional package dependencies.
StackViews provides only one array type: StackView. There are multiple ways to understand StackView:
inverse of
eachslicecatvariantview object
lazy version of
repeatspecial case
Inflate provides a pure Julia implementation of zlib decompression functionality, with both in- memory and streaming interfaces. This covers decompression of the Deflate algorithm and the Zlib and Gzip wrapper formats, as specified in RFC 1950, RFC 1951, and RFC 1952.
LeapSeconds provides a functionality to return the difference between TAI and UTC or vice versa for a given date. For dates after 1972-01-01, this is the number of leap seconds.
This Julia package provides the adapt(T, x) function acts like convert(T, x), but without the restriction of returning a T. This allows you to "convert" wrapper types like Adjoint to be GPU compatible without throwing away the wrapper.
PDMats.jl supports efficient computation on positive definite matrices of various structures. In particular, it provides uniform interfaces to use positive definite matrices of various structures for writing generic algorithms, while ensuring that the most efficient implementation is used in actual computation.
MbedTLS.jl provides a wrapper around the mbed TLS and cryptography C library for Julia.
ReverseDiff.jl is a fast and compile-able tape-based reverse mode AD, that implements methods to take gradients, Jacobians, Hessians, and higher-order derivatives of native Julia functions (or any callable object, really).
This package provides a documentation generator for Julia.
This package provides support for one-dimensional numerical integration in Julia using adaptive Gauss-Kronrod quadrature. The code was originally part of Base Julia. It supports integration of arbitrary numeric types, including arbitrary precision (BigFloat), and even integration of arbitrary normed vector spaces (e.g. matrix-valued integrands).
This package will provide a library of functions useful for machine learning, such as softmax, sigmoid, convolutions and pooling. It doesn't provide any other "high-level" functionality like layers or AD.
This package make loading packages faster, maybe. It supports specifying glue code in packages which will load automatically when another package is loaded, so that explicit dependencies (and long load times) can be avoided.
This package provides support for image resizing, image rotation, and other spatial transformations of arrays.
Parsers.jl is a collection of type parsers and utilities for Julia.
The purpose of this package is to provide test problems for JuliaNLSolvers packages.