Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides a library for parsing MIME types, in the spirit of http://code.google.com/p/mimeparse/, with a Common Lisp flavor.
deeds allows for efficient event delivery to multiple handlers with a complex event filtering system.
This library provides a drop-in replacement function for cl:documentation that supports multiple docstrings per-language, allowing you to write documentation that can be internationalised.
CL-SYNTAX provides Reader Syntax Conventions for Common Lisp and SLIME.
cl-libxml2 is high-level Common Lisp wrapper around the libxml2 and libxslt libraries.
Interfaces for tree manipulation (like
cxml-stp).Interface for HTML 4.0 non-validating parsers.
Specific APIs to process HTML trees, especially serialization.
XPath API.
XSLT API.
Custom URL resolvers.
XPath extension functions.
XSLT extension elements.
Translates
libxml2andlibxslterrors to Lisp conditions.Extends the Common Lisp
iteratelibrary with custom drivers for child nodes enumeration, etc.The
XFACTORYsystem provides a simple and compact syntax for XML generation.
LMDB, the Lightning Memory-mapped Database, is an ACID key-value database with multiversion concurrency control. This package is a Common Lisp wrapper around the C LMDB library. It covers most of C LMDB's functionality, has a simplified API, much needed safety checks, and comprehensive documentation.
Parse-js is a Common Lisp package for parsing JavaScript (ECMAScript 3). It has basic support for ECMAScript 5.
Drakma is a full-featured HTTP client implemented in Common Lisp. It knows how to handle HTTP/1.1 chunking, persistent connections, re-usable sockets, SSL, continuable uploads, file uploads, cookies, and more.
This system implements a general definitions introspection library. It gives you the ability to retrieve definitions or bindings associated with designators such as symbols, packages, and names in general. For instance, it allows you to retrieve all function, type, variable, method, etc. definitions of a symbol.
A library for encoding text in various web-savvy encodings.
This library is an implementation of Deflate (RFC 1951) decompression, with optional support for ZLIB-style (RFC 1950) and gzip-style (RFC 1952) wrappers of deflate streams. It currently does not handle compression.
Transducers are an ergonomic and extremely memory-efficient way to process a data source. Data source refers to simple collections like lists or vectors, but also potentially large files or generators of infinite data.
This is a Common Lisp kernel for Jupyter along with a library for building Jupyter kernels, based on Maxima-Jupyter which was based on cl-jupyter.
CIEL is a ready-to-use collection of libraries providing: a binary, to run CIEL scripts; a simple full-featured REPL for the terminal; a Lisp library and a core image.
string-case is a Common Lisp macro that generates specialised decision trees to dispatch on string equality.
This package provides CFFI binding to libmixed audio library for Common Lisp with support of other audio formats available on GNU/Linux systems:
Alsa
Jack
Openmpt
PulseAudio
Flac (via CL-FLAC)
Mpg123 (via CL-MPG123)
Ogg/vorbis (via CL-VORBIS)
Out123 (via CL-OUT123)
WAV
Simple and fast marshalling of Lisp datastructures. Convert any object into a string representation, put it on a stream an revive it from there. Only minimal changes required to make your CLOS objects serializable.
defclass-star provides defclass* and defcondition* to simplify class and condition declarations. Features include:
Automatically export all or select slots at compile time.
Define the
:initargand:accessorautomatically.Specify a name transformer for both the
:initargand:accessor, etc.Specify the
:initformas second slot value.
See https://common-lisp.net/project/defclass-star/configuration.lisp.html for an example.
cl-draw-cons-tree draws a cons tree in ASCII-art style.
DEFPACKAGE-PLUS is an extensible DEFPACKAGE variant with predictable cross-platform behavior and some utilities useful for versioning.
mito-auth provides a mito mixin class for user authorization.
This package provides a consolidation of Common Lisp statistics libraries.
This library implements various functions to access status information about the machine, process, etc.
This is a Common Lisp library which provides functionality to read/write Bit Map Font (BMF) into text, JSON and XML.