Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides Common Lisp bindings to GSSAPI, which is designed to provide a standard API to authentication services. The API itself is generic, and the system can provide different underlying implementations. The most common one is Kerberos, which has several implementations, the most common of which is probably Active Directory.
cl-amb provides an implementation of John McCarthy's ambiguous operator in portable Common Lisp.
This implements encoding and decoding of Punycode strings, specified in RFC 3492 and used for unicode characters in domain names.
This package provides a safer variant of READ secure against internbombing, excessive input and macro characters.
Portability library for IEEE float features that are not covered by the Common Lisp standard.
Cluffer is a library for representing the buffer of a text editor. As such, it defines a set of CLOS protocols for client code to interact with the buffer contents in various ways, and it supplies different implementations of those protocols for different purposes.
Croatoan provides high-level Common Lisp CLOS bindings for the ncurses terminal library.
Quickproject provides a quick way to make a Common Lisp project. After creating a project, it extends the ASDF registry so the project may be immediately loaded.
This package provides a Common Lisp system which has only one function to return the CPU count of the current system.
DEFLATE data, defined in RFC1951, forms the core of popular compression formats such as zlib (RFC 1950) and gzip (RFC 1952). As such, Chipz also provides for decompressing data in those formats as well. BZIP2 is the format used by the popular compression tool bzip2.
simple-optimization is a Common Lisp library providing a function to solve unconstrained optimization problems numerically using either the gradient descent or a quasi-Newton method.
Simplified-Types is a library that provides functions for simplifying Common Lisp type specifiers. The API consists of two functions:
simplify-typetakes a type specifier and, optionally, an environment, and returns the corresponding simplified type.simplified-type-oftakes an object and returns the simplified type of that object.
Anaphora is the anaphoric macro collection from Hell: it includes many new fiends in addition to old friends like aif and awhen.
This is a Common Lisp library that publishes D-Bus objects as well as send and notify other objects connected to a bus.
This package provides Common Lisp bindings to create OpenGL window and context manipulation code as well as system input handling. Direct FFI bindings to system functions are used so no third party C lib is required except system libraries.
ALEXA is a tool similar to lex or flex for generating lexical analyzers. Unlike tools like lex, however, ALEXA defines a domain-specific language within your Lisp program, so you don't need to invoke a separate tool.
This library allows you to define custom indentation hints for your macros if the one recognised by SLIME automatically produces unwanted results.
Screamer is an extension of Common Lisp that adds support for nondeterministic programming. Screamer consists of two levels. The basic nondeterministic level adds support for backtracking and undoable side effects. On top of this nondeterministic substrate, Screamer provides a comprehensive constraint programming language in which one can formulate and solve mixed systems of numeric and symbolic constraints. Together, these two levels augment Common Lisp with practically all of the functionality of both Prolog and constraint logic programming languages such as CHiP and CLP(R). Furthermore, Screamer is fully integrated with Common Lisp. Screamer programs can coexist and interoperate with other extensions to as CLIM and Iterate.
Often times we need to destructure a form definition in a Common Lisp macro. This library provides a set of simple utilities to help with that.
iterate is an iteration construct for Common Lisp. It is similar to the CL:LOOP macro, with these distinguishing marks:
it is extensible,
it helps editors like Emacs indent iterate forms by having a more lisp-like syntax, and
it isn't part of the ANSI standard for Common Lisp.
trivial-garbage provides a portable API to finalizers, weak hash-tables and weak pointers on all major implementations of the Common Lisp programming language.
cl-alexandria-plus is a conservative set of extensions to cl-alexandria utilities.
FLARE is a library designed to allow quick and precise particle effect creations. It does not concern itself with displaying and only with the management and movement of particles. As such, it can easily be integrated into any existing or future application.
This is a very short and simple program, written in Common Lisp, that extends Common Lisp to embed shell code in a manner similar to Perl's backtick. It has been forked from SHELISP.