Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
Eazy-Gnuplot is a Common Lisp interface to gnuplot which eschews CFFI, CLOS and structures. It communicates with gnuplot via *standard-output*, and users can plot data by printing to that stream.
The py-configparser package implements the ConfigParser Python module functionality in Common Lisp. In short, it implements reading and writing of .INI-file style configuration files with sections containing key/value pairs of configuration options. In line with the functionalities in the python module, does this package implement basic interpolation of option values in other options.
With static-vectors, you can create vectors allocated in static memory.
definitions-systems provides a simple unified extensible way of processing named definitions.
CL-INTERPOL is a library for Common Lisp which modifies the reader so that you can have interpolation within strings similar to Perl or Unix Shell scripts. It also provides various ways to insert arbitrary characters into literal strings even if your editor/IDE doesn't support them.
Babel is a charset encoding and decoding library, not unlike GNU libiconv, but completely written in Common Lisp.
3bz is an implementation of Deflate decompression (RFC 1951) optionally with zlib (RFC 1950) or gzip (RFC 1952) wrappers, with support for reading from foreign pointers (for use with mmap and similar, etc), and from CL octet vectors and streams.
40ants-asdf-system provides a class for being used instead of asdf:package-inferred-system in 40ANT systems.
This Common Lisp package provides a regular expression engine.
This Common Lisp library provides utilities for the Bodge library collection.
Portable Threads (and Scheduled and Periodic Functions) API for Common Lisp (from GBBopen project).
This library is a collection of pseudo random number generators.
While Common Lisp does provide a RANDOM function, it does not allow the user to pass an explicit SEED, nor to portably exchange the random state between implementations. This can be a headache in cases like games, where a controlled seeding process can be very useful.
For both curiosity and convenience, this library offers multiple algorithms to generate random numbers, as well as a bunch of generally useful methods to produce desired ranges.
This package provides an enhanced version of typep that is exactly like the one in the Lisp spec, except it can also accept a single type argument, in which case it returns the appropriate closure.
Cells is a mature, stable extension to CLOS allowing one to create classes whose instances can have slot values determined by instance-specific formulas.
Spatial-trees is a set of dynamic index data structures for spatially-extended data.
This package provides GNU gettext completely implemented in Common Lisp without any C library bindings.
cl-strings is a small, portable, dependency-free set of utilities that make it even easier to manipulate text in Common Lisp. It has 100% test coverage and works at least on sbcl, ecl, ccl, abcl and clisp.
GENERIC-COMPARABILITY is an implementation of CDR-8 (Generic Equality and Comparison for Common Lisp). CDR-8 provides an interface for the EQUALS function, which is defined as a general equality predicate, as well as a set of ordering (COMPARE) functions for comparison. The semantics are described in the CDR-8 standard.
The py-configparser package implements the ConfigParser Python module functionality in Common Lisp. In short, it implements reading and writing of .INI-file style configuration files with sections containing key/value pairs of configuration options. In line with the functionalities in the python module, does this package implement basic interpolation of option values in other options.
This package provides audio input and output functions to Common Lisp using bindings to the portaudio library.
This library contains generic hacks meant to be used in any project. It was originally developed for the Cells library.
This package provides a pure-lisp implementation of a DNS client. It can be used to resolve hostnames, reverse-lookup IP addresses, and fetch other kinds of DNS records.
The purpose of this library is to provide a collection of implementations of trees.
In contrast to existing libraries such as cl-containers, it does not impose a particular use for the trees. Instead, it aims for a stratified design, allowing client code to choose between different levels of abstraction.
As a consequence of this policy, low-level interfaces are provided where the concrete representation is exposed, but also high level interfaces where the trees can be used as search trees or as trees that represent sequences of objects.
Eager Future2 is a Common Lisp library that provides composable concurrency primitives that unify parallel and lazy evaluation, are integrated with the Common Lisp condition system, and have automatic resource management.