_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


go-github-com-containerd-imgcrypt 1.1.11
Propagated dependencies: go-github-com-containerd-typeurl@1.0.2 go-github-com-containers-ocicrypt@1.2.1 go-github-com-gogo-protobuf@1.3.2 go-github-com-opencontainers-go-digest@1.0.0 go-github-com-opencontainers-image-spec@1.1.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/containerd/imgcrypt
Licenses: ASL 2.0
Build system: go
Synopsis: OCI Image Encryption Package
Description:

The imgcrypt library provides API extensions for containerd to support encrypted container images.

go-github-com-go-faster-city 1.0.1
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/go-faster/city
Licenses: Expat
Build system: go
Synopsis: CityHash implementation in Go
Description:

Package city implements CityHash, a family of hash functions for strings, in Go and it's a fork of https://github.com/tenfyzhong/cityhash.

go-github-com-stefanberger-go-pkcs11uri 0.0.0-20230803200340-78284954bff6
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/stefanberger/go-pkcs11uri
Licenses: ASL 2.0
Build system: go
Synopsis: Golang pkcs11 URI library
Description:

This package implements RFC 7512 - the PKCS #11 URI Scheme; and errata specifications.

go-github-com-dgryski-dgoogauth 0.0.0-20190221195224-5a805980a5f3
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/dgryski/dgoogauth
Licenses: ASL 2.0
Build system: go
Synopsis: Google Authenticator for Golang
Description:

This is a Go implementation of the Google Authenticator library as specified in RFC 4226 and RFC 6238.

go-filippo-io-age 1.3.2
Propagated dependencies: go-filippo-io-edwards25519@1.2.0 go-filippo-io-hpke@0.4.0 go-filippo-io-nistec@0.0.4 go-golang-org-x-crypto@0.53.0 go-golang-org-x-sys@0.46.0 go-golang-org-x-term@0.44.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://filippo.io/age
Licenses: Modified BSD
Build system: go
Synopsis: Secure file encryption tool, format, and Go library
Description:

This package implements file encryption according to the https://age-encryption.org/v1 specification. It features small explicit keys, no configuration options, and Unix-style composability.

go-c2sp-org-cctv-age 0.0.0-20240306222714-3ec4d716e805
Propagated dependencies: go-golang-org-x-crypto@0.53.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://c2sp.org/CCTV/age
Licenses: CC0
Build system: go
Synopsis: Community Cryptography Test Vectors
Description:

This package provides a large set of test vectors for the age file encryption format, as well as a framework to easily generate them.

The test suite can be applied to any age implementation, regardless of the language it's implemented in, and the level of abstraction of its interface. For the simplest, most universal integration, the implementation can just attempt to decrypt the test files, check the operation only succeeds if expect is success, and compare the decrypted payload. Test vectors involving unimplemented features (such as passphrase encryption or armoring) can be ignored.

go-github-com-oneofone-xxhash 1.2.8
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/OneOfOne/xxhash
Licenses: ASL 2.0
Build system: go
Synopsis: Go implementation of xxHash
Description:

This is a native Go implementation of the xxHash algorithm, an extremely fast non-cryptographic hash algorithm, working at speeds close to RAM limits.

go-github-com-protonmail-go-crypto 1.3.0-0.a8cc4f0
Propagated dependencies: go-github-com-cloudflare-circl@1.6.5 go-golang-org-x-crypto@0.53.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/ProtonMail/go-crypto
Licenses: Modified BSD
Build system: go
Synopsis: Fork of x/crypto with up-to-date OpenPGP implementation
Description:

This package provides cryptography for Go. This version of the package is a fork that adds a more up-to-date OpenPGP implementation. It is completely backwards compatible with golang.org/x/crypto, the official package.

go-github-com-refraction-networking-utls 1.8.2
Propagated dependencies: go-github-com-andybalholm-brotli@1.1.1 go-github-com-cloudflare-circl@1.6.5 go-github-com-gaukas-godicttls@0.0.4 go-github-com-klauspost-compress@1.18.0 go-github-com-quic-go-quic-go@0.59.0 go-golang-org-x-crypto@0.53.0 go-golang-org-x-net@0.53.0 go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/refraction-networking/utls
Licenses: Modified BSD
Build system: go
Synopsis: Fork of the Go standard TLS library
Description:

uTLS is a fork of crypto/tls, which provides ClientHello fingerprinting resistance, low-level access to handshake, fake session tickets and some other features. Handshake is still performed by crypto/tls, this library merely changes ClientHello part of it and provides low-level access.

go-github-com-operatorfoundation-obfs4 1.0.0
Propagated dependencies: go-github-com-dchest-siphash@1.2.3 go-github-com-operatorfoundation-ed25519@0.0.0-0.b22b4bd go-github-com-willscott-goturn@0.0.0-20170802220503-19f41278d0c9 go-golang-org-x-crypto@0.53.0 go-golang-org-x-net@0.53.0 go-torproject-org-pluggable-transports-goptlib@1.1.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/OperatorFoundation/obfs4
Licenses: FreeBSD
Build system: go
Synopsis: Network obfourscator to scramble network traffic
Description:

Obfs4 is a look-like nothing obfuscation protocol that incorporates ideas and concepts from Philipp Winter's ScrambleSuit protocol.

The notable differences between ScrambleSuit and obfs4 are:

  • The handshake always does a full key exchange (no such thing as a Session Ticket Handshake).

  • The handshake uses the Tor Project's ntor handshake with public keys obfuscated via the Elligator 2 mapping.

  • The link layer encryption uses NaCl secret boxes (Poly1305/XSalsa20).

go-github-com-btcsuite-btcd-chaincfg-chainhash 1.2.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/btcsuite/btcd
Licenses: ISC
Build system: go
Synopsis: Bitcoin hash functionality in Go
Description:

This package provides Bitcoin hash functionality.

go-github-com-dgryski-go-farm 0.0.0-20200201041132-a6ae2369ad13
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/dgryski/go-farm
Licenses: Expat
Build system: go
Synopsis: Farmhash implementation in Golang
Description:

FarmHash provides hash functions for strings and other data. The functions mix the input bits thoroughly but are not suitable for cryptography. It is implemented as a mechanical translation of the non-SSE4/non-AESNI hash functions from Google's FarmHash.

go-github-com-operatorfoundation-shapeshifter-ipc 2.0.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/OperatorFoundation/shapeshifter-ipc
Licenses: Expat
Build system: go
Synopsis: Go implementation of the Pluggable Transports IPC protocol
Description:

Shapeshifter-IPC is a library for Go implementing the IPC protocol from the Pluggable Transports 2.0 specification.

go-github-com-google-go-tpm 0.9.8
Propagated dependencies: go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/google/go-tpm
Licenses: ASL 2.0
Build system: go
Synopsis: Go-TPM Legacy TPM 2.0 library
Description:

This package provides a functionality to communicate directly with a Trusted Platform Module device. The libraries don't implement the entire spec for neither 1.2 nor 2.0.

Included submodules:

  • tpm - TPM 1.2 client library

  • tpm2 - TPM 2.0 client library.

  • direct - the prototype "TPMDirect" TPM 2.0 API, which is intended to (eventually) be 1:1 with the TPM 2.0 spec

go-github-com-dgryski-go-mph 0.0.0-20211217222804-81a8625fb7ed
Propagated dependencies: go-github-com-dgryski-go-metro@0.0.0-20250106013310-edb8663e5e33
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/dgryski/go-mph
Licenses: Expat
Build system: go
Synopsis: Go minimal perfect hash function
Description:

This package implements a hash/displace minimal perfect hash function.

go-github-com-gaukas-godicttls 0.0.4
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/gaukas/godicttls
Licenses: Modified BSD
Build system: go
Synopsis: Dictionary for TLS
Description:

This package provides a dictionary for TLS written in Go providing bidirectional mapping values to their names, plus enum convenience for values.

go-github-com-golang-jwt-jwt-v4 4.5.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/golang-jwt/jwt
Licenses: Expat
Build system: go
Synopsis: Go implementation of JSON Web Tokens
Description:

This package provides a Go implementation of JSON Web Tokens and supports the parsing and verification as well as the generation and signing of JSON Web Tokens. The currently supported signing algorithms are HMAC SHA, RSA, RSA-PSS, and ECDSA, though hooks are present for adding your own.

ssh-to-pgp 1.1.6
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/Mic92/ssh-to-pgp
Licenses: Expat
Build system: go
Synopsis: Convert SSH RSA keys to GPG keys
Description:

This package provides ssh-to-pgp: a Go command line +utility to convert SSH RSA keys to GPG keys.

go-github-com-tscholl2-siec 0.0.0-20240310163802-c2c6f6198406
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/tscholl2/siec
Licenses: Expat
Build system: go
Synopsis: Isolated Elliptic Curve Implementation in Golang
Description:

This package exports a super-isolated elliptic curve. Over the base field 𝔽ₚ, the curve E does not admit any isogenies to other curves.

go-github-com-cespare-xxhash-v2 2.3.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/cespare/xxhash
Licenses: Expat
Build system: go
Synopsis: Go implementation of xxHash
Description:

Package xxhash implements the 64-bit variant of xxHash (XXH64) as described at https://xxhash.com/.

go-github-com-cloudwego-base64x 0.1.7
Propagated dependencies: go-github-com-bytedance-sonic-loader@0.5.1 go-github-com-klauspost-cpuid-v2@2.3.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/cloudwego/base64x
Licenses: ASL 2.0 ASL 2.0
Build system: go
Synopsis: Drop-in replacement of the std @code{encoding/base64} library
Description:

This package provides a drop-in replacement of the Golang standard encoding/base64 library.

go-github-com-jphastings-jwker 0.2.2
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/jphastings/jwker
Licenses: Expat
Build system: go
Synopsis: PEM -> JWK conversion tool
Description:

This package implements a functionality to convert keys between the PEM and JWK file formats.

go-github-com-protonmail-bcrypt 0.0.0-20211005172633-e235017c1baf
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/ProtonMail/bcrypt
Licenses: Modified BSD
Build system: go
Synopsis: Bcrypt hash algorithm in Golang
Description:

This package provides a Golang implementation of the bcrypt hash algorithm. It is a fork of github.com/jameskeane/bcrypt.

go-github-com-youmark-pkcs8 1.3
Propagated dependencies: go-golang-org-x-crypto@0.53.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/youmark/pkcs8
Licenses: Expat
Build system: go
Synopsis: Functions to parse and convert private keys in PKCS#8 format
Description:

pkcs8 implements functions to process private keys in PKCS#8 format, as defined in RFC 5208 and RFC 5958. It can handle both unencrypted PKCS#8 PrivateKeyInfo format and EncryptedPrivateKeyInfo format with PKCS#5 (v2.0) algorithms.

Total packages: 33008