_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


go-github-com-minio-md5-simd 1.1.2
Propagated dependencies: go-github-com-klauspost-cpuid-v2@2.3.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/minio/md5-simd
Licenses: ASL 2.0
Build system: go
Synopsis: Accelerate MD5 computations in pure Golang
Description:

This is a SIMD accelerated MD5 package, allowing up to either 8 (AVX2) or 16 (AVX512) independent MD5 sums to be calculated on a single CPU core.

md5-simd integrates a similar mechanism as described in minio/sha256-simd for making it easy for clients to take advantages of the parallel nature of the MD5 calculation. This will result in reduced overall CPU load.

go-jwker 0.2.2
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/jphastings/jwker
Licenses: Expat
Build system: go
Synopsis: PEM -> JWK conversion tool
Description:

This package implements a functionality to convert keys between the PEM and JWK file formats.

go-filippo-io-keygen 1.0.0
Propagated dependencies: go-filippo-io-bigmod@0.1.1-0.f8a4777 go-golang-org-x-crypto@0.53.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://filippo.io/keygen
Licenses: ISC
Build system: go
Synopsis: Deterministic key generation for Go
Description:

Package keygen implements deterministic key generation algorithms.

go-github-com-zeebo-blake3 0.2.4
Propagated dependencies: go-github-com-klauspost-cpuid-v2@2.3.0 go-github-com-zeebo-pcg@1.0.1
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/zeebo/blake3
Licenses: CC0
Build system: go
Synopsis: Pure Go implementation of BLAKE3
Description:

blake3 is an implementation of BLAKE3 with AVX2 and SSE4.1 acceleration.

age 1.3.2
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://filippo.io/age
Licenses: Modified BSD
Build system: go
Synopsis: Secure file encryption tool, format, and Go library
Description:

This package implements file encryption according to the https://age-encryption.org/v1 specification. It features small explicit keys, no configuration options, and Unix-style composability. This package provides a command line interface (CLI) tools.

go-github-com-libp2p-go-libp2p-peer 2.3.8-0.993d742
Propagated dependencies: go-github-com-btcsuite-btcd-btcec@0.12.0-beta-0.67e573d go-github-com-gogo-protobuf@1.3.2 go-github-com-libp2p-go-libp2p-crypto@2.0.1-0.7240b40 go-github-com-multiformats-go-multihash@0.2.3
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/libp2p/go-libp2p-peer
Licenses: Expat
Build system: go
Synopsis: PKI based identities for use in go-libp2p
Description:

PKI based identities for use in go-libp2p.

go-github-com-gxed-hashland-murmur3 0.0.1
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/gxed/hashland
Licenses: Modified BSD
Build system: go
Synopsis: Golang implementation of MurmurHash3 algorithm
Description:

This package provides a native Go implementation of Austin Appleby's third MurmurHash revision (aka MurmurHash3).

go-github-com-42wim-sshsig 0.0.0-20260317195500-b9f38cf0d432
Propagated dependencies: go-golang-org-x-crypto@0.53.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/42wim/sshsig
Licenses: ASL 2.0
Build system: go
Synopsis: Armored SSH signatures in Go
Description:

Package sshsig implements signing/verifying armored SSH signatures. It may be used to sign data and verify signatures using SSH private keys or SSH agent. It gives the same output as using ssh-keygen, eg when signing ssh-keygen -Y sign -f keyfile -n namespace data.

go-github-com-serialx-hashring 0.0.0-20200727003509-22c0c7ab6b1b
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/serialx/hashring
Licenses: Expat
Build system: go
Synopsis: Consistent hashing for Golang
Description:

This package implements consistent hashing that can be used when the number of server nodes increase or decrease (like in memcached). The hashing ring is built using the same algorithm as libketama.

go-github-com-xtls-reality 0.0.0-20260322125925-9234c772ba8f
Propagated dependencies: go-github-com-cloudflare-circl@1.6.5 go-github-com-juju-ratelimit@1.0.2 go-github-com-pires-go-proxyproto@0.11.0 go-github-com-refraction-networking-utls@1.8.2 go-golang-org-x-crypto@0.53.0 go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/xtls/reality
Licenses: Modified BSD MPL 2.0
Build system: go
Synopsis: Implementation of REALITY protocol
Description:

This package provides an implementation of REALITY protocol, which is intented to eliminate the detectable TLS fingerprint on the server side, while still maintain the secrecy. It achieves full real TLS that is undistingwishable with the specified SNI to the middleman.

go-github-com-multiformats-go-multihash 0.2.3
Propagated dependencies: go-github-com-minio-sha256-simd@0.1.1 go-github-com-mr-tron-base58@1.2.0 go-github-com-multiformats-go-varint@0.0.7 go-github-com-spaolacci-murmur3@1.1.0 go-golang-org-x-crypto@0.53.0 go-lukechampine-com-blake3@1.1.5
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/multiformats/go-multihash
Licenses: Expat
Build system: go
Synopsis: Multihash implementation in Go
Description:

Multihash implementation in Go.

go-github-com-xdg-go-pbkdf2 1.0.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/xdg-go/pbkdf2
Licenses: ASL 2.0
Build system: go
Synopsis: Go implementation of PBKDF2
Description:

Package pbkdf2 implements password-based key derivation using the PBKDF2 algorithm described in RFC 2898 and RFC 8018.

go-gitlab-com-yawning-bsaes-git 0.0.0-20190805113838-0a714cd429ec
Propagated dependencies: go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://gitlab.com/yawning/bsaes
Licenses: Expat
Build system: go
Synopsis: AES implementation in Golang
Description:

The bsaes is a portable pure-Go constant time AES implementation based on the code from BearSSL. On appropriate systems, with a sufficiently recent Go runtime, it will transparently call crypto/aes when NewCipher is invoked.

go-github-com-btcsuite-btcd-btcec-v2 2.5.0
Propagated dependencies: go-github-com-btcsuite-btcd-chaincfg-chainhash@1.2.0 go-github-com-btcsuite-btcd-chainhash-v2@2.0.0 go-github-com-decred-dcrd-dcrec-secp256k1-v4@4.4.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/btcsuite/btcd
Licenses: ISC
Build system: go
Synopsis: Elliptic curves for Bitcoin
Description:

This package implements elliptic curves needed for Bitcoin.

go-github-com-codahale-rfc6979 0.0.0-20141003034818-6a90f24967eb
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/codahale/rfc6979
Licenses: ISC
Build system: go
Synopsis: Deterministic ECDSA signatures in Go
Description:

This package implements RFC 6979, which describes how to generate deterministic ECDSA signatures. Deterministic signatures remove the need for a random number generator during signing.

go-github-com-jcmturner-aescts-v2 2.0.0
Propagated dependencies: go-github-com-stretchr-testify@1.11.1
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/jcmturner/aescts
Licenses: ASL 2.0
Build system: go
Synopsis: Encrypt and decrypt data in Go using AES CipherText Stealing
Description:

This package provides AES Cipher Block Chaining CipherText Stealing encryption and decryption methods.

go-github-com-hdevalence-ed25519consensus 0.2.0
Propagated dependencies: go-filippo-io-edwards25519@1.2.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/hdevalence/ed25519consensus
Licenses: Modified BSD
Build system: go
Synopsis: Ed25519 signature library for Golang
Description:

This package provides an Ed25519 implementation with validation rules intended for consensus-critical contexts.

go-github-com-containers-libtrust 0.0.0-20230121012942-c1716e8a8d01
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/containers/libtrust
Licenses: ASL 2.0
Build system: go
Synopsis: Primitives for identity and authorization for containers
Description:

Libtrust is a library for managing authentication and authorization using public key cryptography. It provides authorization and access control through a distributed trust graph. It's maintained fork of https://github.com/docker-archive-public/docker.libtrust.

go-gitlab-com-nyarla-go-crypt 0.0.0-20160106005555-d9a5dc2b789b
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://gitlab.com/nyarla/go-crypt
Licenses: Modified BSD
Build system: go
Synopsis: Implementation of @code{crypt(3)} in Golang
Description:

Package crypt is a implementation of crypt(3) by golang, originated from https://code.google.com/p/go-crypt.

go-filippo-io-hpke 0.4.0
Propagated dependencies: go-golang-org-x-crypto@0.53.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://filippo.io/hpke
Licenses: Modified BSD
Build system: go
Synopsis: Hybrid Public Key Encryption (HPKE) in Golang
Description:

This package implements Hybrid Public Key Encryption (HPKE) as defined in https://www.rfc-editor.org/rfc/rfc9180.html RFC 9180.

go-github-com-golang-jwt-jwt-v5 5.3.1
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/golang-jwt/jwt
Licenses: Expat
Build system: go
Synopsis: Go implementation of JSON Web Tokens
Description:

This package provides a Go implementation of JSON Web Tokens and supports the parsing and verification as well as the generation and signing of JSON Web Tokens. The currently supported signing algorithms are HMAC SHA, RSA, RSA-PSS, and ECDSA, though hooks are present for adding your own.

go-github-com-libp2p-go-libp2p-crypto 2.0.1-0.7240b40
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/libp2p/go-libp2p-crypto
Licenses: Expat
Build system: go
Synopsis: Various cryptographic utilities used by IPFS
Description:

Various cryptographic utilities used by IPFS

go-github-com-jzelinskie-whirlpool 0.0.0-20201016144138-0675e54bb004
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/jzelinskie/whirlpool
Licenses: Modified BSD
Build system: go
Synopsis: Cryptographic hashing library
Description:

Package whirlpool implements the ISO/IEC 10118-3:2004 whirlpool cryptographic hash as specified in http://www.larc.usp.br/~pbarreto/WhirlpoolPage.html.

go-github-com-decred-dcrd-dcrec-secp256k1-v4 4.4.0
Propagated dependencies: go-github-com-decred-dcrd-crypto-blake256@1.1.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/decred/dcrd
Licenses: ISC
Build system: go
Synopsis: Optimized secp256k1 elliptic curve operations
Description:

This package provides an optimized pure Go implementation of elliptic curve cryptography operations over the secp256k1 curve as well as data structures and functions for working with public and private secp256k1 keys as cpecified in the https://www.secg.org/sec2-v2.pdf standard.

In addition, sub packages are provided to produce, verify, parse, and serialize ECDSA signatures and EC-Schnorr-DCRv0 (a custom Schnorr-based signature scheme specific to Decred) signatures. See the README.md files in the relevant sub packages for more details about those aspects.

Total packages: 33008