_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


go-github-com-xanzy-go-gitlab 0.114.0
Propagated dependencies: go-github-com-google-go-querystring@1.1.0 go-github-com-hashicorp-go-cleanhttp@0.5.2 go-github-com-hashicorp-go-retryablehttp@0.7.8 go-golang-org-x-oauth2@0.36.0 go-golang-org-x-time@0.14.0
Channel: guix
Location: gnu/packages/golang-vcs.scm (gnu packages golang-vcs)
Home page: https://github.com/xanzy/go-gitlab
Licenses: ASL 2.0
Build system: go
Synopsis: GitLab Go SDK
Description:

This package provides a GitLab API client enabling Go programs to interact with GitLab in a simple and uniform way.

git-sync 4.4.3
Channel: guix
Location: gnu/packages/golang-vcs.scm (gnu packages golang-vcs)
Home page: https://github.com/kubernetes/git-sync
Licenses: ASL 2.0
Build system: go
Synopsis: Keep repository in sync with the upstream
Description:

git-sync is a simple command that pulls a git repository into a local directory. It is a perfect "sidecar" container in Kubernetes - it can periodically pull files down from a repository so that an application can consume them.

go-github-com-git-lfs-pktline 0.0.0-1.ca444d5
Channel: guix
Location: gnu/packages/golang-vcs.scm (gnu packages golang-vcs)
Home page: https://github.com/git-lfs/pktline
Licenses: Expat
Build system: go
Synopsis: Git pkt-line Go toolkit
Description:

This package is a Go language toolkit for reading and writing files using the Git pkt-line format used in various Git operations.

go-github-com-alexliesenfeld-health 0.8.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/alexliesenfeld/health
Licenses: Expat
Build system: go
Synopsis: Simple and flexible health check library for Go
Description:

This library provides a http.Handler that acts as a health endpoint. It can be used by cloud infrastructure or other services to determine the availability of an application.

Rather than simply returning a response with HTTP status code 200, this library allows building health checks that test the availability of all required dependencies. The HTTP response contains the aggregated health result and details about the health status of each component.

go-github-com-apex-log 1.9.0
Propagated dependencies: go-github-com-apex-logs@1.1.0 go-github-com-aphistic-golf@0.0.0-20180712155816-02c07f170c5a go-github-com-aws-aws-sdk-go@1.55.7 go-github-com-aybabtme-rgbterm@0.0.0-20170906152045-cc83f3b3ce59 go-github-com-fatih-color@1.17.0 go-github-com-go-logfmt-logfmt@0.6.0 go-github-com-mattn-go-colorable@0.1.14 go-github-com-pkg-errors@0.9.1 go-github-com-rogpeppe-fastuuid@1.2.0 go-github-com-tj-go-buffer@1.2.0 go-github-com-tj-go-elastic@0.0.0-20171221160941-36157cbbebc2 go-github-com-tj-go-kinesis@0.0.0-20171128231115-08b17f58cb1b go-github-com-tj-go-spin@1.1.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/apex/log
Licenses: Expat
Build system: go
Synopsis: Structured logging package for Golang
Description:

Package log implements a simple structured logging API designed with few assumptions. Designed for centralized logging solutions such as Kinesis which require encoding and decoding before fanning-out to handlers.

go-github-com-aws-smithy-go-tracing-smithyoteltracing 1.0.2
Propagated dependencies: go-go-opentelemetry-io-otel@1.42.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/aws/smithy-go
Licenses: ASL 2.0
Build system: go
Synopsis: AWS Smithy OTEL tracing adapter
Description:

Package smithyoteltracing implements a Smithy client tracing adapter for the OTEL Go SDK.

go-github-com-swaggo-echo-swagger 1.4.1
Propagated dependencies: go-github-com-ghodss-yaml@1.0.0 go-github-com-labstack-echo-v4@4.15.2 go-github-com-swaggo-files-v2@2.0.2 go-github-com-swaggo-swag@1.16.4
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/swaggo/echo-swagger
Licenses: Expat
Build system: go
Synopsis: Echo middleware to generate RESTful API documentation with Swagger
Description:

This package provides echo (web framework) middleware to automatically generate RESTful API documentation with Swagger 2.0.

go-github-com-jmespath-go-jmespath 0.4.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/jmespath/go-jmespath
Licenses: ASL 2.0
Build system: go
Synopsis: Golang implementation of JMESPath
Description:

This package implements JMESPath, a query language for JSON. It transforms one JSON document into another through a JMESPath expression.

go-github-com-google-go-github-v78 78.0.0
Propagated dependencies: go-github-com-google-go-querystring@1.1.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/google/go-github/
Licenses: Modified BSD
Build system: go
Synopsis: Client library for accessing the GitHub API v3
Description:

go-github is a Go client library for accessing the GitHub API v3.

go-github-com-google-go-github-v31 31.0.0
Propagated dependencies: go-github-com-google-go-querystring@1.1.0 go-golang-org-x-crypto@0.53.0 go-golang-org-x-oauth2@0.36.0 go-golang-org-x-sync@0.21.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/google/go-github/
Licenses: Modified BSD
Build system: go
Synopsis: Client library for accessing the GitHub API v3
Description:

go-github is a Go client library for accessing the GitHub API v3.

go-go-opentelemetry-io-otel-exporters-otlp-otlpmetric-otlpmetrichttp 1.33.0
Propagated dependencies: go-github-com-cenkalti-backoff-v4@4.3.0 go-github-com-google-go-cmp@0.7.0 go-go-opentelemetry-io-otel@1.42.0 go-go-opentelemetry-io-otel-sdk-metric@1.33.0 go-go-opentelemetry-io-proto-otlp@1.7.0 go-google-golang-org-grpc@1.69.2 go-google-golang-org-protobuf@1.36.11
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://go.opentelemetry.io/otel
Licenses: ASL 2.0
Build system: go
Synopsis: OTLP Metric HTTP Exporter
Description:

Package otlpmetrichttp provides an OTLP metrics exporter using HTTP with protobuf payloads.

go-github-com-emersion-go-smtp 0.22.0
Propagated dependencies: go-github-com-emersion-go-sasl@0.0.0-20241020182733-b788ff22d5a6
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/emersion/go-smtp
Licenses: Expat
Build system: go
Synopsis: SMTP implementation for Go
Description:

This package implements the Simple Mail Transfer Protocol as defined by RFC 5321.

go-github-com-gfleury-go-bitbucket-v1 0.0.0-0.df385ef
Propagated dependencies: go-github-com-mitchellh-mapstructure@1.5.0 go-golang-org-x-net@0.53.0 go-golang-org-x-oauth2@0.36.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/gfleury/go-bitbucket-v1
Licenses: Expat
Build system: go
Synopsis: Go API client for Bitbucket (bitbucket-server V1)
Description:

This package imlements API client for Atlassian's Bitbucket Server (former stash) in Go. This API client was generated by the swagger-codegen project. By using the swagger-spec from a remote server, you can easily generate an API client.

go-sigs-k8s-io-knftables 0.0.21
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/kubernetes-sigs/knftables
Licenses: ASL 2.0
Build system: go
Synopsis: Golang nftables library for Kubernetes
Description:

This package provides nftables bindings in Go. It is not intended to support arbitrary use cases, but instead specifically focuses on supporting Kubernetes components which are using nftables.

go-github-com-planetscale-vtprotobuf 0.5.0
Propagated dependencies: go-google-golang-org-grpc@1.69.2 go-google-golang-org-protobuf@1.36.11
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/planetscale/vtprotobuf
Licenses: Modified BSD
Build system: go
Synopsis: Protocol Buffers compiler for ProtoBuf APIv2 Golang code
Description:

This package provides protoc-gen-go-vtproto plug-in for protoc, which is used by Vitess to generate optimized marshall & unmarshal code.

go-github-com-francoispqt-gojay 1.2.13
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/francoispqt/gojay
Licenses: Expat
Build system: go
Synopsis: JSON encoder/decoder with powerful stream API for Golang
Description:

GoJay is a performant JSON encoder/decoder for Golang. It has a simple API and doesn't use reflection. It relies on small interfaces to decode/encode structures and slices.

go-go-opentelemetry-io-otel-exporters-prometheus 0.62.0
Propagated dependencies: go-github-com-prometheus-client-golang@1.23.2 go-github-com-prometheus-client-model@0.6.2 go-github-com-prometheus-otlptranslator@1.0.0 go-go-opentelemetry-io-otel@1.42.0 go-go-opentelemetry-io-otel-metric@1.42.0 go-go-opentelemetry-io-otel-sdk@1.33.0 go-go-opentelemetry-io-otel-sdk-metric@1.33.0 go-go-opentelemetry-io-otel-trace@1.42.0 go-google-golang-org-protobuf@1.36.11
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://go.opentelemetry.io/otel
Licenses: ASL 2.0
Build system: go
Synopsis: OTLP Prometheus Exporter
Description:

Package prometheus provides a Prometheus Exporter that converts OTLP metrics into the Prometheus exposition format and implements prometheus.Collector to provide a handler for these metrics.

go-github-com-buger-jsonparser 1.1.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/buger/jsonparser
Licenses: Expat
Build system: go
Synopsis: Alternative JSON parser for Golang
Description:

This package provides an alternative JSON parser for Go. It does not require to know the structure of the payload (eg. create structs), and allows accessing fields by providing the path to them.

go-git-sr-ht-rockorager-go-jmap 0.5.2
Propagated dependencies: go-golang-org-x-oauth2@0.36.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://git.sr.ht/~rockorager/go-jmap
Licenses: Expat
Build system: go
Synopsis: JSON meta application protocol in Golang
Description:

Package jmap implements JMAP Core protocol as defined in RFC 8620 published on July 2019.

go-github-com-go-openapi-analysis 0.23.0
Propagated dependencies: go-github-com-go-openapi-jsonpointer@0.21.0 go-github-com-go-openapi-spec@0.21.0 go-github-com-go-openapi-strfmt@0.23.0 go-github-com-go-openapi-swag@0.23.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/go-openapi/analysis
Licenses: ASL 2.0
Build system: go
Synopsis: OpenAPI specification object model analyzer
Description:

This package provides a foundational library to analyze an OpenAPI Initiative specification document for easier reasoning about the content.

go-github-com-mholt-acmez-v2 2.0.3
Propagated dependencies: go-golang-org-x-crypto@0.53.0 go-golang-org-x-net@0.53.0 go-go-uber-org-zap@1.27.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/mholt/acmez
Licenses: ASL 2.0
Build system: go
Synopsis: ACME (RFC 8555) client library for Go
Description:

ACMEz is a lightweight, fully-compliant RFC 8555 (ACME) implementation, that provides an API for getting certificates. ACMEz is suitable for large-scale enterprise deployments. It also supports common IETF-standardized ACME extensions.

This module has two primary packages:

  • acmez is a high-level wrapper for getting certificates. It implements the ACME order flow described in RFC 8555 including challenge solving using pluggable solvers.

  • acme is a low-level RFC 8555 implementation that provides the fundamental ACME operations, mainly useful if you have advanced or niche requirements.

Main features:

  • Go API that thoroughly documented with spec citations.

  • Structured error values (problems as defined in RFC 7807.)

  • Smart retries (resilient against network and server hiccups.)

  • Challenge plasticity (randomized challenges, and will retry others if one fails.)

  • Context cancellation (suitable for high-frequency config changes or reloads.)

  • Highly flexible and customizable.

  • External Account Binding (EAB) support.

  • Tested with numerous ACME CAs (more than just Let's Encrypt.)

  • Implements niche aspects of RFC 8555 (such as alt cert chains and account key rollover.)

  • Efficient solving of large SAN lists (e.g. for slow DNS record propagation.)

  • Utility functions for solving challenges: device attestation challenges (draft-acme-device-attest-02), RFC 8737 (tls-alpn-01 challenge), RFC 8823 (email-reply-00 challenge; S/MIME.)

  • ACME Renewal Information (ARI) support (draft-ietf-acme-ari-03.)

Total packages: 33008