Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides an implementation of the UNIX socket family data types and related helper functions.
This package is a Go Implementation of WireGuard.
Package transfermanager implements the Amazon S3 Transfer Manager, a high-level S3 client library.
This package contains Go bindings and sample code for Hyper-V sockets and virtio sockets.
This package provides an API to interact with GCP.
Package httprc implements a cache for resources available over http(s). Its aim is not only to cache these resources so that it saves on HTTP roundtrips, but it also periodically attempts to auto-refresh these resources once they are cached based on the user-specified intervals and HTTP Expires and Cache-Control headers, thus keeping the entries relativelyfresh.
Package advancedtls provides gRPC transport credentials that allow easy configuration of advanced TLS features. For example, periodic credential reloading,support for certificate revocation lists, and customizable certificate verification behaviors.
This package provides a semi-automatically exported from github.com/ooni/probe-cli.
Package ws implements a client and server for the WebSocket protocol as specified in RFC 6455.
This package provides a Go library for authenticating emails.
This package provides a toolkit for building TURN, specified in RFC 8656, servers and clients.
pion/turn is an API for building STUN/TURN clients and servers, not a binary you deploy then configure. It may require copying the examples and making minor modifications to fit your need, no knowledge of Go is required however.
The advantage of this is that you don't need to deal with complicated configuration files, or custom APIs to modify the state of Pion TURN. After you instantiate an instance of a Pion TURN server or client you interact with it like any library. The quickest way to get started is to look at the examples or GoDoc.
jsonpatch is a library which provides functionality for both applying RFC6902 JSON patches against documents, as well as for calculating & applying RFC7396 JSON merge patches.
This package provides a Gitter API for Golang.
Package client is a Go client for the Docker Engine API.
This package enables OpenID Connect support for the go-golang-org-x-oauth2 package.
Some CNI network plugins, maintained by the containernetworking team.
This package provides a Go library that finds a free open TCP port that is ready to use.
Multiaddr is a standard way to represent addresses that does the following:
Support any standard network protocols.
Self-describe (include protocols).
Have a binary packed format.
Have a nice string representation.
Encapsulate well.
This package is a request router and dispatcher with a pat-like interface. It is an alternative to gorilla/mux that showcases how it can be used as a base for different API flavors.
If you use certificate-based access to protect your Google Cloud resources, the end user device certificate is one of the credentials that is verified before access to a resource is granted. You can configure Google Cloud to use the device certificates in your operating system key store when verifying access to a resource from the gcloud CLI or Terraform by using the enterprise certificates feature.
The Azure Identity module provides Microsoft Entra ID token-based authentication support across the Azure SDK. It includes a set of TokenCredential implementations, which can be used with Azure SDK clients supporting token authentication.
Package webrtc implements the WebRTC (Real-Time Communication in Browsers) 1.0 as defined in W3C WebRTC specification document. Features:
implementation of webrtc-pc and
https://www.w3.org/TR/webrtc-stats/,webrtc-statsDataChannels
Send/Receive audio and video
Renegotiation
Plan-B and Unified Plan
SettingEngine for Pion specific extensions
implemented connectivity - Full ICE Agent, ICE Restart, Trickle ICE, STUN, TURN mDNS candidates
This is a parser for GraphQL, written to mirror the graphql-js reference implementation as closely while remaining idiomatic and easy to use.
Package otlptracegrpc provides an OTLP span exporter using gRPC. By default the telemetry is sent to @urlhttps://localhost:4317.