Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
OpenTelemetry Google Cloud Monitoring Exporter allows the user to send collected metrics to Google Cloud.
This package exposes a registry of data types to support string formats in the go-openapi toolkit. strfmt represents a well known string format such as credit card or email. The Go toolkit for OpenAPI specifications knows how to deal with those.
This package implements an encoding and decoding of TCP-level socket options regarding connection information.
This package contains code and types that were left behind when the old inet.af/netaddr package moved to the standard library in Go 1.18 as net/netip.
This package provides a Go language implementation of the QUIC network protocol.
Azure File Shares offers fully managed file shares in the cloud that are accessible via the industry standard Server Message Block (SMB) protocol. Azure file shares can be mounted concurrently by cloud or on-premises deployments of Windows, Linux, and macOS. Additionally, Azure file shares can be cached on Windows Servers with Azure File Sync for fast access near where the data is being used.
Package hub provides a simple event dispatcher for publish/subscribe pattern.
This package provides helpers to validate Swagger 2.0 specification (aka OpenAPI 2.0).
This package is a lightweight secrets management service that uses Tailscale for access control.
mCaptcha is a Go library to interact with mCaptcha.
This package implements a functionality to exposes API to decode Fedora CoreOS streams into Go structs, as well as a convenience API to find the URL for a given stream.
This package is a light, drop-in replacement for gRPC, a Remote Procedure Call (RPC) framework.
This package provides a functionality to get the hash used to differentiate between installs of Mozilla software in installs.ini and profiles.ini.
certmagic provides API for TLS Automation with full control over almost every aspect of the system.
Main features:
Fully automated certificate management including issuance and renewal, with support for certificate revocation. Also works in conjunction with your own certificates.
Wildcard certificates.
One-line, fully managed HTTPS servers, with HTTP->HTTPS redirects.
Multiple issuers supported: get certificates from multiple sources/CAs for redundancy and resiliency.
Solves all 3 common ACME challenges: HTTP, TLS-ALPN, and DNS (and capable of others.)
Robust error handling:
Challenges are randomized to avoid accidental dependence and rotated to overcome certain network blockages.
Robust retries for up to 30 days.
Exponential backoff with carefully-tuned intervals.
Retries with optional test/staging CA endpoint instead of production, to avoid rate limits.
All libdns DNS providers work out-of-the-box.
Pluggable storage backends (default: file system) and key sources.
Automatic OCSP stapling.
Distributed solving of all challenges (works behind load balancers.)
Supports on-demand issuance of certificates.
Optional event hooks for observation.
One-time private keys by default (new key for each cert) to discourage pinning and reduce scope of key compromise.
Works with any certificate authority (CA) compliant with the ACME specification RFC 8555.
Must-Staple (optional; not default.)
Full support for draft-ietf-acme-ari (ACME Renewal Information; ARI) extension.
This package provides a Golang implementation of the SRP protocol, used for authentication of ProtonMail users.
jsonpatch is a library which provides functionality for both applying RFC6902 JSON patches against documents, as well as for calculating & applying RFC7396 JSON merge patches.
This package provies a library to create, store, and control access to the keys used to encrypt your data.
The dnsutils package provides a Go function to return a map of Service Records (SRV) in the order they should be used for a given service, protocol and name. The order is determined by the records' priority and randomized selection based on their relative weighting. This package is useful for network applications that require accessing services using SRV records.
The Docker Engine API is an HTTP API used by the command-line client to communicate with the daemon. It can also be used by third-party software to control the daemon.
This is a Go port of the exponential backoff algorithm from Google's HTTP Client Library for Java.
Exponential backoff is an algorithm that uses feedback to multiplicatively decrease the rate of some process, in order to gradually find an acceptable rate. The retries exponentially increase and stop increasing when a certain threshold is met.
Package websocket implements the WebSocket protocol defined in RFC 6455 for fasthttp.
This package provides a minimalistic implementation of the OpenVPN protocol in Go (client only).
The netns package provides a simple interface for handling network namespaces in Go.
Package aws implement the interface with Amazon AWS KMS service.