Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides WebAssembly a WebAssembly data model and binary encoder.
Package autoprop provides an OpenTelemetry TextMapPropagator creation function. The OpenTelemetry specification states that the default TextMapPropagator needs to be a no-operation implementation. The opentelemetry-go project adheres to this requirement. However, for systems that perform propagation this default is not ideal. This package provides a TextMapPropagator with useful defaults (a combined TraceContext and Baggage TextMapPropagator), and supports environment overrides using the OTEL_PROPAGATORS environment variable.
This packages implements a trivial HTTP client.
This package provides a HTTP Transport that implements the RoundTripper interface and can be used as a built in replacement for the standard library.
This package is the official QingStor SDK for the Go programming language.
The Microsoft Azure Storage SDK for Go to build applications that takes advantage of Azure's scalable cloud storage.
jsonpatch is a library which provides functionality for both applying RFC6902 JSON patches against documents, as well as for calculating & applying RFC7396 JSON merge patches.
Eduoauth is a Go library in use by geteduroam and eduVPN to handle OAuth.
This package provides an implementation of JSON Pointer for the Go programming language.
This package implements encoding and decoding of JSON as defined in RFC 4627 and provides interfaces with identical syntax of standard lib encoding/json. Converting from encoding/json to jsoniter is no more than replacing the package with jsoniter and variable type declarations (if any). jsoniter interfaces gives 100% compatibility with code using standard lib.
Package kinesis implements a batch producer built on top of the official AWS SDK.
This package is an implementation of a client for various UPnP services. It's an alternative fork of https://github.com/huin/goupnp.
Xurls extracts urls from plain text using regular expressions. It can be used as both a binary and a library.
This package provides a high performance and feature rich codec and encoding library for the MessagePack, CBOR, JSON and the Binc formats.
This package provides the github.com/hashicorp/vault/api Golang package. It contains code for interacting with a Vault server.
Package otgrpc provides OpenTracing support for any gRPC client or server.
Package easyproto provides building blocks for marshaling and unmarshaling (encoding/decoding) protobuf v3 messages according to https://protobuf.dev/programming-guides/encoding.
This package provides a Go redirect format parser to match Netlify's https://www.netlify.com/docs/redirects/, format.
This package implements a functionality to help filling out plain html forms during testing. Will automatically take the existing values from the form so there is no need to manually set things like csrf tokens. Alerts about missing required fields, or when pattern validation does not match.
Package ftp implements a File Transfer Protocol client as described in RFC 959.
Package grpc implements an RPC system called gRPC.
This package provides a Go SDK based on the official APIs of Alibaba Cloud OSS.
This package provides a net.Conn wrapper around https://github.com/flynn/noise crypto protocols.
ACMEz is a lightweight, fully-compliant RFC 8555 (ACME) implementation, that provides an API for getting certificates. ACMEz is suitable for large-scale enterprise deployments. It also supports common IETF-standardized ACME extensions.
This module has two primary packages:
acmezis a high-level wrapper for getting certificates. It implements the ACME order flow described in RFC 8555 including challenge solving using pluggable solvers.acmeis a low-level RFC 8555 implementation that provides the fundamental ACME operations, mainly useful if you have advanced or niche requirements.
Main features:
Go API that thoroughly documented with spec citations.
Structured error values (problems as defined in RFC 7807.)
Smart retries (resilient against network and server hiccups.)
Challenge plasticity (randomized challenges, and will retry others if one fails.)
Context cancellation (suitable for high-frequency config changes or reloads.)
Highly flexible and customizable.
External Account Binding (EAB) support.
Tested with numerous ACME CAs (more than just Let's Encrypt.)
Implements niche aspects of RFC 8555 (such as alt cert chains and account key rollover.)
Efficient solving of large SAN lists (e.g. for slow DNS record propagation.)
Utility functions for solving challenges: device attestation challenges (draft-acme-device-attest-02), RFC 8737 (tls-alpn-01 challenge), RFC 8823 (email-reply-00 challenge; S/MIME.)
ACME Renewal Information (ARI) support (draft-ietf-acme-ari-03.)