_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


go-golang-org-x-oauth2 0.36.0
Propagated dependencies: go-cloud-google-com-go-compute-metadata@0.9.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://go.googlesource.com/oauth2
Licenses: Modified BSD
Build system: go
Synopsis: Client implementation of the OAuth 2.0 spec
Description:

This package contains a client implementation for OAuth 2.0 spec in Go.

go-github-com-cevatbarisyilmaz-ara 0.0.5
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/cevatbarisyilmaz/ara
Licenses: Expat
Build system: go
Synopsis: Dialer with customizable resolver
Description:

Package ara provides a dialer with customizable resolver. It can be used with http.Client and http.Transport to alter host lookups.

go-github-com-anthropics-anthropic-sdk-go 1.19.0
Propagated dependencies: go-github-com-aws-aws-sdk-go-v2@1.41.7 go-github-com-aws-aws-sdk-go-v2-config@1.32.17 go-github-com-aws-aws-sdk-go-v2-credentials@1.19.7 go-github-com-tidwall-gjson@1.18.0 go-github-com-tidwall-sjson@1.2.5 go-golang-org-x-oauth2@0.36.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/anthropics/anthropic-sdk-go
Licenses: Expat
Build system: go
Synopsis: Go client library for the Anthropic API
Description:

This package provides a client library for convenient access to the Anthropic REST API. It includes support for message creation, streaming, tool calling, and integration with Amazon Bedrock.

go-github-com-doridian-gopacket 1.3.4
Propagated dependencies: go-github-com-vishvananda-netlink@1.3.1 go-github-com-vishvananda-netns@0.0.5 go-golang-org-x-net@0.53.0 go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/Doridian/gopacket
Licenses: Modified BSD
Build system: go
Synopsis: Provides packet processing capabilities for Go
Description:

Package gopacket provides packet decoding for the Go language. It's a fork of https://github.com/google/gopacket.

go-github-com-zeebo-admission-v3 3.0.3
Propagated dependencies: go-github-com-spacemonkeygo-monkit-v3@3.0.24 go-github-com-zeebo-errs@1.4.0 go-github-com-zeebo-float16@0.1.0 go-github-com-zeebo-incenc@0.0.0-20180505221441-0d92902eec54
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/zeebo/admission
Licenses: ASL 2.0
Build system: go
Synopsis: UDP packets processing in Golang
Description:

Package admission is a fast way to ingest/send metrics via UDP.

go-storj-io-drpc 0.0.34
Propagated dependencies: go-google-golang-org-protobuf@1.36.11 go-github-com-zeebo-errs@1.4.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://storj.io/drpc
Licenses: Expat
Build system: go
Synopsis: Lightweight, drop-in replacement for gRPC
Description:

This package is a light, drop-in replacement for gRPC, a Remote Procedure Call (RPC) framework.

go-github-com-go-openapi-swag-loading 0.27.0
Propagated dependencies: go-github-com-go-openapi-swag-conv@0.24.0 go-github-com-go-openapi-swag-jsonutils@0.27.0 go-github-com-go-openapi-swag-typeutils@0.27.0 go-github-com-go-openapi-swag-yamlutils@0.27.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/go-openapi/swag
Licenses: ASL 2.0
Build system: go
Synopsis: Tools to load a file from HTTP or from a local file system
Description:

Package loading provides tools to load a file from HTTP or from a local file system.

go-cloud-google-com-go-compute-metadata 0.9.0
Propagated dependencies: go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://pkg.go.dev/cloud.google.com/go/compute/metadata
Licenses: ASL 2.0
Build system: go
Synopsis: Go wrapper for Google Compute Engine metadata service
Description:

This package provides access to Google Compute Engine (GCE) metadata and API service accounts for Go.

go-github-com-grpc-ecosystem-go-grpc-middleware-providers-prometheus 1.1.0
Propagated dependencies: go-github-com-grpc-ecosystem-go-grpc-middleware-v2@2.3.4 go-github-com-prometheus-client-golang@1.23.2 go-github-com-prometheus-client-model@0.6.2 go-google-golang-org-grpc@1.69.2
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/grpc-ecosystem/go-grpc-middleware
Licenses: ASL 2.0
Build system: go
Synopsis: Prometheus monitoring for gRPC Go servers and clients
Description:

This package provides a standalone interceptor for Prometheus monitoring for gRPC Go servers and clients.

go-github-com-shurcool-httpgzip 0.0.0-20230704072819-d1585fc322fa
Propagated dependencies: go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/shurcooL/httpgzip
Licenses: Expat
Build system: go
Synopsis: Primitives of @code{net-http}-like with gzip compression
Description:

Package httpgzip provides net/http-like primitives that use gzip compression when serving HTTP requests.

go-github-com-hashicorp-go-retryablehttp 0.7.8
Propagated dependencies: go-github-com-hashicorp-go-hclog@1.6.3 go-github-com-hashicorp-go-cleanhttp@0.5.2
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/hashicorp/go-retryablehttp
Licenses: MPL 2.0
Build system: go
Synopsis: Retryable HTTP client in Golang
Description:

Package retryablehttp provides a familiar HTTP client interface with automatic retries and exponential backoff. It is a thin wrapper over the standard net/http client library and exposes nearly the same public API.

go-github-com-anaskhan96-soup 1.2.5
Propagated dependencies: go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/anaskhan96/soup
Licenses: Expat
Build system: go
Synopsis: Web Scraper in Go, similar to BeautifulSoup
Description:

Small web scraper package for Go, with its interface highly similar to that of BeautifulSoup.

go-github-com-santhosh-tekuri-jsonschema-v5 5.3.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/santhosh-tekuri/jsonschema
Licenses: ASL 2.0
Build system: go
Synopsis: JSONSchema validation using Golang
Description:

Package jsonschema provides json-schema compilation and validation.

go-github-com-davecgh-go-xdr 0.0.0-20161123171359-e6a2ba005892
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/davecgh/go-xdr
Licenses: ISC
Build system: go
Synopsis: Pure Go implementation of the XDR standard
Description:

go-xdr implements the data representation portion of the External Data Representation (XDR) standard protocol as specified in RFC 4506 (obsoletes RFC 1832 and RFC 1014) in pure Go.

go-go-opencensus-io 0.24.0
Propagated dependencies: go-github-com-golang-groupcache@0.0.0-20210331224755-41bb18bfe9da go-github-com-golang-protobuf@1.5.4 go-github-com-google-go-cmp@0.7.0 go-github-com-stretchr-testify@1.11.1 go-golang-org-x-net@0.53.0 go-google-golang-org-grpc@1.69.2
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://opencensus.io/
Licenses: ASL 2.0
Build system: go
Synopsis: Stats collection and distributed tracing framework
Description:

Package opencensus contains Go support for OpenCensus.

go-github-com-urfave-negroni 1.0.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/urfave/negroni
Licenses: Expat
Build system: go
Synopsis: Idiomatic HTTP Middleware for Golang
Description:

Package negroni is an idiomatic approach to web middleware in Go. It is tiny,non-intrusive, and encourages use of net/http Handlers.

go-go-opentelemetry-io-otel-exporters-otlp-otlptrace-otlptracehttp 1.36.0
Propagated dependencies: go-github-com-cenkalti-backoff-v5@5.0.2 go-go-opentelemetry-io-proto-otlp@1.7.0 go-google-golang-org-protobuf@1.36.11
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://go.opentelemetry.io/otel
Licenses: ASL 2.0
Build system: go
Synopsis: OTLP Trace HTTP Exporter
Description:

Package otlptracehttp provides an OTLP span exporter using HTTP with protobuf payloads. By default the telemetry is sent to @urlhttps://localhost:4318/v1/traces.

go-github-com-huin-goupnp 1.3.0
Propagated dependencies: go-golang-org-x-sync@0.21.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/huin/goupnp
Licenses: FreeBSD
Build system: go
Synopsis: UPnP client library for Go
Description:

goupnp is a Universal Plug and Play client library for Go.

Core components:

  • goupnp: core library - contains datastructures and utilities typically used by the implemented DCPs

  • httpu: HTTPU implementation, underlies SSDP

  • ssdp: SSDP client implementation (simple service discovery protocol) - used to discover UPnP services on a network

  • soap: SOAP client implementation (simple object access protocol) - used to communicate with discovered services

go-github-com-pion-srtp-v2 2.0.20
Propagated dependencies: go-github-com-pion-logging@0.2.4 go-github-com-pion-rtcp@1.2.16 go-github-com-pion-rtp@1.10.1 go-github-com-pion-transport-v2@2.2.10
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/pion/srtp
Licenses: Expat
Build system: go
Synopsis: Implementation of SRTP protocol in Golang
Description:

Package srtp implements Secure Real-time Transport Protocol.

go-github-com-1password-connect-sdk-go 1.5.3
Propagated dependencies: go-github-com-google-uuid@1.6.0 go-github-com-opentracing-opentracing-go@1.2.0 go-github-com-uber-jaeger-client-go@2.30.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/1Password/connect-sdk-go
Licenses: Expat
Build system: go
Synopsis: Go SDK for 1Password Connect
Description:

The 1Password Connect Go SDK provides access to the 1Password Connect API, to facilitate communication with the Connect server hosted on your infrastructure and 1Password. The library is intended to be used by your applications, pipelines, and other automations to simplify accessing items stored in your 1Password vaults.

go-storj-io-common 0.0.0-20251120170554-032ced125058
Propagated dependencies: go-github-com-blang-semver-v4@4.0.0 go-github-com-bmkessler-fastdiv@0.0.0-20190227075523-41d5178f2044 go-github-com-calebcase-tmpfile@1.0.3 go-github-com-flynn-noise@1.1.0 go-github-com-gogo-protobuf@1.3.2 go-github-com-google-gopacket@1.1.19 go-github-com-google-pprof@0.0.0-20250317173921-a4b03ec1a45e go-github-com-jtolds-tracetagger-v2@2.0.0-rc5 go-github-com-jtolio-crawlspace@0.0.0-20240521193440-69abbbe5a93f go-github-com-jtolio-crawlspace-tools@0.0.0-20240521193440-69abbbe5a93f go-github-com-jtolio-noiseconn@0.0.0-20231127013910-f6d9ecbf1de7 go-github-com-quic-go-quic-go@0.59.0 go-github-com-shopspring-decimal@1.4.0 go-github-com-spacemonkeygo-monkit-v3@3.0.24 go-github-com-spf13-cast@1.7.0 go-github-com-spf13-cobra@1.10.2 go-github-com-spf13-pflag@1.0.10 go-github-com-spf13-viper@1.8.1 go-github-com-zeebo-admission-v3@3.0.3 go-github-com-zeebo-blake3@0.2.4 go-github-com-zeebo-errs@1.4.0 go-github-com-zeebo-structs@1.0.2-0.f2db460 go-golang-org-x-crypto@0.53.0 go-golang-org-x-mod@0.35.0 go-golang-org-x-sync@0.21.0 go-golang-org-x-sys@0.46.0 go-gopkg-in-yaml-v2@2.4.0 go-storj-io-drpc@0.0.34 go-storj-io-eventkit@0.0.0-20250410172343-61f26d3de156 go-storj-io-picobuf@0.0.4
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://storj.io/common
Licenses: Expat
Build system: go
Synopsis: Common web and networking Golang utilities
Description:

This package provides a collection of Golang utilities maintained by Storj project:

  • accesslogs can handle collection and upload of arbitrarily formatted server access logs in the fashion of S3's server access logging

  • bloomfilter implements a bloom-filter for pieces that need to be preserved

  • cfgstruct

  • context2 contains utilities for contexts

  • currency

  • debug implements debug server for satellite, storage node, and edge services

  • encryption collects common cryptographic primitives needed for path and data encryption

  • errs2 collects common error handling functions

  • eventstat contains helper to create statistics about events with unbounded cardinality

  • experiment implements feature flag propagation.

  • fpath implements cross-platform file and object path handling

  • grant

  • http

  • identity implements CA and Peer identity management and generation.

  • leak provides a way to track resources when race detector is enabled

  • macaroon implements contextual caveats and authorization

  • memory contains byte size types and manipulation

  • metrics implements a server which displays only read-only monitoring data

  • netutil

  • nodetag

  • paths implements wrappers for handling encrypted and unencrypted paths safely

  • peertls manages TLS configuration for peers.

  • pkcrypto contains a set of helper functions and constants to perform common cryptographic operations

  • process

  • processgroup implements process-grouping commands.

  • ranger implements lazy io.Reader and io.Writer interfaces

  • readcloser implements utilities for io.ReadClosers

  • rpc implements dialing on Storj Network

  • signing implements consistent signing and verifying protobuf messages

  • socket implements RFC4594

  • storj contains the types which represent the main entities of the Storj domain

  • strictcsv

  • sync2 provides a set of functions and types for having context aware functionalities, offloading memory through the file system, and to control execution of tasks which can run repetitively, concurrently or asynchronously.

  • telemetry

  • testcontext implements convenience context for testing.

  • testrand implements generating random base types for testing.

  • testtrace provides profiling debugging utilities for writing the state of all goroutines

  • time2 provides time related functionality that can be manipulated to facilite deterministic testing

  • traces

  • tracing

  • useragent implements parts of RFC7231 and RFC2616

  • uuid implements UUID v4 based on RFC4122.

  • version

go-github-com-datadog-datadog-go 4.8.3
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/DataDog/datadog-go
Licenses: Expat
Build system: go
Synopsis: Golang client library to work with DataDog's API
Description:

datadog-go is a library that provides a DogStatsD client in Golang.

go-github-com-go-ldap-ldap-v3 3.4.9
Propagated dependencies: go-github-com-azure-go-ntlmssp@0.1.1 go-github-com-go-asn1-ber-asn1-ber@1.5.7 go-github-com-google-uuid@1.6.0 go-github-com-jcmturner-gokrb5-v8@8.4.4
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/go-ldap/ldap
Licenses: Expat
Build system: go
Synopsis: LDAP v3 functionality for Go
Description:

This package provides basic LDAP v3 functionality in the Go language.

go-github-com-open-policy-agent-opa 1.19.0
Propagated dependencies: go-github-com-agnivade-levenshtein@1.2.0 go-github-com-cespare-xxhash-v2@2.3.0 go-github-com-dgraph-io-badger-v4@4.9.1 go-github-com-fortytw2-leaktest@1.3.0 go-github-com-foxcpp-go-mockdns@1.2.0 go-github-com-fsnotify-fsnotify@1.9.0 go-github-com-go-logr-logr@1.4.3 go-github-com-gobwas-glob@0.2.3 go-github-com-google-uuid@1.6.0 go-github-com-hashicorp-golang-lru-v2@2.0.7 go-github-com-huandu-go-sqlbuilder@1.42.1 go-github-com-lestrrat-go-jwx-v3@3.2.0 go-github-com-olekukonko-tablewriter@1.1.4 go-github-com-opencontainers-go-digest@1.0.0 go-github-com-opencontainers-image-spec@1.1.0 go-github-com-prometheus-client-golang@1.23.2 go-github-com-prometheus-client-model@0.6.2 go-github-com-rcrowley-go-metrics@0.0.0-20250401214520-65e299d6c5c9 go-github-com-reeflective-readline@1.3.0 go-github-com-santhosh-tekuri-jsonschema-v6@6.0.2 go-github-com-sergi-go-diff@1.3.1 go-github-com-sirupsen-logrus@1.9.3 go-github-com-tchap-go-patricia-v2@2.3.3 go-github-com-tetratelabs-wazero@1.11.0 go-github-com-vektah-gqlparser-v2@2.5.31 go-github-com-xeipuuv-gojsonreference@0.0.0-0.bd5ef7b go-github-com-yashtewari-glob-intersection@0.2.0 go-go-opentelemetry-io-contrib-bridges-prometheus@0.69.0 go-go-opentelemetry-io-contrib-instrumentation-net-http-otelhttp@0.62.0 go-go-opentelemetry-io-otel@1.42.0 go-go-opentelemetry-io-otel-exporters-otlp-otlpmetric-otlpmetricgrpc@1.33.0 go-go-opentelemetry-io-otel-exporters-otlp-otlpmetric-otlpmetrichttp@1.33.0 go-go-opentelemetry-io-otel-exporters-otlp-otlptrace@1.36.0 go-go-opentelemetry-io-otel-exporters-otlp-otlptrace-otlptracegrpc@1.43.0 go-go-opentelemetry-io-otel-exporters-otlp-otlptrace-otlptracehttp@1.36.0 go-go-opentelemetry-io-otel-sdk@1.33.0 go-go-opentelemetry-io-otel-sdk-metric@1.33.0 go-go-opentelemetry-io-otel-trace@1.42.0 go-go-opentelemetry-io-proto-otlp@1.7.0 go-go-yaml-in-yaml-v3@3.0.4 go-golang-org-x-sync@0.21.0 go-golang-org-x-term@0.44.0 go-golang-org-x-text@0.38.0 go-golang-org-x-time@0.14.0 go-google-golang-org-grpc@1.69.2 go-google-golang-org-protobuf@1.36.11 go-gopkg-in-check-v1@1.0.0-20201130134442-10cb98267c6c go-gopkg-in-ini-v1@1.67.0 go-gopkg-in-natefinch-lumberjack-v2@2.1 go-oras-land-oras-go-v2@2.6.0 go-sigs-k8s-io-yaml@1.6.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/open-policy-agent/opa
Licenses: ASL 2.0
Build system: go
Synopsis: General purpose policy engine
Description:

Open Policy Agent (OPA) is an open source, general-purpose policy engine that enables unified, context-aware policy enforcement across the entire stack.

Total packages: 33008