_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


go-github-com-sigstore-rekor 1.4.3
Propagated dependencies: go-cloud-google-com-go-iam@1.7.0 go-github-com-asaskevich-govalidator@11.0.1 go-github-com-blang-semver@3.8.0 go-github-com-cyberphone-json-canonicalization@0.0.0-20241213102144-19d51d7fe467 go-github-com-go-chi-chi-v5@5.2.1 go-github-com-go-openapi-errors@0.22.1 go-github-com-go-openapi-loads@0.22.0 go-github-com-go-openapi-runtime@0.26.2 go-github-com-go-openapi-spec@0.21.0 go-github-com-go-openapi-strfmt@0.23.0 go-github-com-go-openapi-swag@0.23.0 go-github-com-go-openapi-swag-conv@0.24.0 go-github-com-go-openapi-validate@0.24.0 go-github-com-go-sql-driver-mysql@1.8.1 go-github-com-go-viper-mapstructure-v2@2.5.0 go-github-com-google-rpmpack@0.7.1 go-github-com-google-trillian@1.7.2 go-github-com-grpc-ecosystem-go-grpc-middleware@1.4.0 go-github-com-hashicorp-go-cleanhttp@0.5.2 go-github-com-hashicorp-go-retryablehttp@0.7.8 go-github-com-in-toto-in-toto-golang@0.9.0 go-github-com-jedisct1-go-minisign@0.2.5 go-github-com-jmoiron-sqlx@1.4.0 go-github-com-prometheus-client-golang@1.23.2 go-github-com-redis-go-redis-v9@9.17.3 go-github-com-rs-cors@1.11.1 go-github-com-secure-systems-lab-go-securesystemslib@0.10.0 go-github-com-sigstore-protobuf-specs@0.5.0 go-github-com-sigstore-sigstore@1.10.4 go-github-com-sigstore-sigstore-pkg-signature-kms-aws@1.10.5 go-github-com-sigstore-sigstore-pkg-signature-kms-azure@1.10.5 go-github-com-sigstore-sigstore-pkg-signature-kms-gcp@1.10.5 go-github-com-sigstore-sigstore-pkg-signature-kms-hashivault@1.10.5 go-github-com-theupdateframework-go-tuf@0.7.0 go-github-com-tink-crypto-tink-go-awskms-v2@2.1.0 go-github-com-tink-crypto-tink-go-gcpkms-v2@2.2.0 go-github-com-tink-crypto-tink-go-v2@2.6.0 go-github-com-transparency-dev-merkle@0.0.2 go-github-com-veraison-go-cose@1.3.0-0.a633822 go-go-uber-org-zap@1.27.0 go-golang-org-x-crypto@0.53.0 go-golang-org-x-mod@0.35.0 go-golang-org-x-net@0.53.0 go-golang-org-x-sync@0.21.0 go-google-golang-org-api@0.272.0 go-google-golang-org-genproto-googleapis-rpc@0.0.0-1.49b9836 go-google-golang-org-grpc@1.69.2 go-google-golang-org-protobuf@1.36.11 go-gopkg-in-ini-v1@1.67.0 go-gopkg-in-yaml-v2@2.4.0 go-sigs-k8s-io-yaml@1.6.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/sigstore/rekor
Licenses: ASL 2.0
Build system: go
Synopsis: Sigstore transparency log
Description:

Rekor provides an immutable tamper-resistant ledger of metadata generated within a software project's supply chain. It enables software maintainers and consumers to transparently record signed metadata to a ledger.

go-cloud-google-com-go-security 1.21.0
Propagated dependencies: go-cloud-google-com-go-iam@1.7.0 go-cloud-google-com-go-longrunning@0.8.0 go-github-com-googleapis-gax-go-v2@2.19.0 go-google-golang-org-api@0.272.0 go-google-golang-org-genproto@0.0.0-20260226221140-a57be14db171 go-google-golang-org-genproto-googleapis-api@0.0.0-20250519155744-55703ea1f237 go-google-golang-org-grpc@1.69.2 go-google-golang-org-protobuf@1.36.11
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://cloud.google.com/go
Licenses: ASL 2.0
Build system: go
Synopsis: Google Cloud Certificate Authority API
Description:

This package provides a Go Client Library for Certificate Authority API.

go-github-com-tailscale-netlink 1.1.1-0.20240822203006-4d49adab4de7
Propagated dependencies: go-golang-org-x-sys@0.46.0 go-github-com-vishvananda-netns@0.0.5
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/tailscale/netlink
Licenses: ASL 2.0
Build system: go
Synopsis: Netlink library for go
Description:

This package provides a simple library for netlink. Netlink is the interface a user-space program in linux uses to communicate with the kernel. It can be used to add and remove interfaces, set up ip addresses and routes, and confiugre ipsec. Netlink communication requires elevated privileges, so in most cases this code needs to be run as root. The low level primitives for netlink are contained in the nl subpackage. This package attempts to provide a high-level interface that is loosly modeled on the iproute2 cli.

It's an alternative fork of https://github.com/vishvananda/netlink.

go-github-com-uber-jaeger-lib 2.4.1
Propagated dependencies: go-github-com-hdrhistogram-hdrhistogram-go@1.1.2
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/jaegertracing/jaeger-lib
Licenses: ASL 2.0
Build system: go
Synopsis: Collection of libraries used by Jaeger
Description:

This package provides a collection of shared infrastructure libraries used by different components of Jaeger backend and jaeger-client-go.

go-github-com-beevik-ntp 1.4.3
Propagated dependencies: go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/beevik/ntp
Licenses: FreeBSD
Build system: go
Synopsis: NTP client package for Golang
Description:

Package ntp provides an implementation of a Simple NTP (SNTP) client capable of querying the current time from a remote NTP server as specified in RFC 5905.

go-github-com-varlink-go-varlink 0.4.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/varlink/go
Licenses: ASL 2.0
Build system: go
Synopsis: Go implementation of the Varlink IPC protocol
Description:

This package provides a Go implementation of the Varlink protocol, a protocol for inter-process communication. Varlink utilizes a plain-text, JSON-based format for messages and is designed to be accessible to both humans and machines.

go-github-com-go-openapi-swag-mangling 0.29.2
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/go-openapi/swag
Licenses: ASL 2.0
Build system: go
Synopsis: Name mangling capabilities
Description:

Package mangling provides name mangling capabilities.

go-github-com-jhillyerd-enmime-v2 2.4.1
Propagated dependencies: go-github-com-cention-sany-utf7@0.0.0-20170124080048-26cad61bd60a go-github-com-gogs-chardet@0.0.0-20211120154057-b7413eaefb8f go-github-com-inbucket-html2text@1.0.0 go-github-com-pkg-errors@0.9.1 go-golang-org-x-text@0.38.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/jhillyerd/enmime
Licenses: Expat
Build system: go
Synopsis: MIME encoder and decoder for Go
Description:

The enmime package implements a MIME encoding and decoding library geared towards parsing MIME encoded emails.

go-github-com-akrylysov-algnhsa 1.1.0
Propagated dependencies: go-github-com-aws-aws-lambda-go@1.47.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/akrylysov/algnhsa
Licenses: ASL 2.0
Build system: go
Synopsis: AWS Lambda Go @code{net/http} server adapter
Description:

This package implements a functionality to run Go web applications on AWS Lambda and API Gateway or ALB without changing the existing HTTP handlers.

go-github-com-koron-go-ssdp 0.1.0
Propagated dependencies: go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/koron/go-ssdp
Licenses: Expat
Build system: go
Synopsis: SSDP library for Golang
Description:

go-ssdp is a Simple Service Discovery Protocol library for Golang.

go-github-com-libp2p-go-yamux-v4 4.0.2
Propagated dependencies: go-github-com-libp2p-go-buffer-pool@0.1.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/libp2p/go-yamux
Licenses: MPL 2.0 Modified BSD
Build system: go
Synopsis: Reuse TCP/UDP ports in Golang
Description:

Yamux (Yet another Multiplexer) is a multiplexing library for Golang. It relies on an underlying connection to provide reliability and ordering, such as TCP or Unix domain sockets, and provides stream-oriented multiplexing. It is inspired by SPDY but is not interoperable with it.

go-github-com-swaggo-files-v2 2.0.2
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/swaggo/files
Licenses: Expat
Build system: go
Synopsis: Static files for Swaggo API builder
Description:

This package provides a collection of static files to build API specifications with Swaggo.

go-github-com-emersion-go-imap 1.2.1
Propagated dependencies: go-golang-org-x-text@0.38.0 go-github-com-emersion-go-sasl@0.0.0-20241020182733-b788ff22d5a6 go-github-com-emersion-go-message@0.18.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/emersion/go-imap
Licenses: Expat
Build system: go
Synopsis: IMAP4rev1 library written in Go
Description:

This package provides an IMAP4rev1 library written in Go. It can be used to build IMAP clients and servers.

go-storj-io-eventkit 0.0.0-20250410172343-61f26d3de156
Propagated dependencies: go-github-com-google-gopacket@1.1.19 go-github-com-pkg-errors@0.9.1 go-github-com-spacemonkeygo-monkit-v3@3.0.24 go-github-com-spf13-cobra@1.10.2 go-github-com-spf13-viper@1.8.1 go-github-com-stretchr-testify@1.11.1 go-go-uber-org-zap@1.27.0 go-golang-org-x-sync@0.21.0 go-google-golang-org-api@0.272.0 go-google-golang-org-protobuf@1.36.11 go-storj-io-picobuf@0.0.4
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://storj.io/eventkit
Licenses: Expat
Build system: go
Synopsis: Report multidimensional events over UDP
Description:

This package provides a Go library for reporting multidimensional events over UDP.

go-github-com-dylibso-observe-sdk-go 0.0.0-20240828172851-9145d8ad07e1
Propagated dependencies: go-github-com-ianlancetaylor-demangle@0.0.0-20230524184225-eabc099b10ab go-github-com-tetratelabs-wabin@0.0.0-20230304001439-f6f874872834 go-github-com-tetratelabs-wazero@1.11.0 go-go-opentelemetry-io-otel-exporters-otlp-otlptrace@1.36.0 go-go-opentelemetry-io-otel-exporters-otlp-otlptrace-otlptracegrpc@1.43.0 go-go-opentelemetry-io-otel-exporters-otlp-otlptrace-otlptracehttp@1.36.0 go-go-opentelemetry-io-proto-otlp@1.7.0 go-google-golang-org-protobuf@1.36.11
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/dylibso/observe-sdk
Licenses: ASL 2.0
Build system: go
Synopsis: Continuous runtime observablity SDKs to monitor WebAssembly code
Description:

This package provides a Golang implementation of observability SDKs for WebAssembly, enabling continuous monitoring of WebAssembly code as it executes within a runtime.

go-github-com-pion-dtls-v2 2.2.12
Propagated dependencies: go-github-com-pion-logging@0.2.4 go-github-com-pion-transport-v2@2.2.10 go-golang-org-x-crypto@0.53.0 go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/pion/dtls
Licenses: Expat
Build system: go
Synopsis: DTLS 1.2 Server/Client implementation for Go
Description:

This package provides a native DTLS 1.2 implementation in Golang.

go-github-com-jackpal-go-nat-pmp 1.0.2
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/jackpal/go-nat-pmp
Licenses: ASL 2.0
Build system: go
Synopsis: Port mapping and discovery of external IP address
Description:

This package provides a Go client for the NAT-PMP internet protocol for port mapping and discovering the external IP address of a firewall.

go-github-com-appscode-go-querystring 0.0.0-20170504095604-0126cfb3f1dc
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/appscode/go-querystring
Licenses: Modified BSD
Build system: go
Synopsis: Encode structs into URL query parameters
Description:

This package is designed to assist in scenarios where you want to construct a URL using a struct that represents the URL query parameters.

go-gomodules-xyz-jsonpatch-v2 2.5.0
Propagated dependencies: go-github-com-evanphx-json-patch@4.13.0 go-github-com-pkg-errors@0.9.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/gomodules/jsonpatch
Licenses: ASL 2.0
Build system: go
Synopsis: JSON Patch (RFC 6902) and target document generation
Description:

This package provides functionality for generating JSON Patch documents and for applying JSON Patch operations to JSON documents per RFC 6902. It's an alternative fork of https://github.com/mattbaird/jsonpatch.

go-github-com-getsentry-sentry-go 0.33.0
Propagated dependencies: go-github-com-go-errors-errors@1.5.1 go-github-com-pingcap-errors@0.11.4 go-github-com-pkg-errors@0.9.1 go-golang-org-x-sys@0.46.0 go-golang-org-x-text@0.38.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/getsentry/sentry-go
Licenses: Expat
Build system: go
Synopsis: Sentry SDK for Golang
Description:

sentry-go provides a Sentry client implementation for the Go programming language.

go-github-com-quic-go-qpack 0.6.0
Propagated dependencies: go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/quic-go/qpack
Licenses: Expat
Build system: go
Synopsis: Minimal QPACK (RFC 9204) implementation for Go
Description:

A minimal QPACK (RFC 9204) implementation in Go. It is minimal in the sense that it doesn't use the dynamic table at all, but just the static table and (Huffman encoded) string literals. Wherever possible, it reuses code from the HPACK implementation in the Go standard library.

go-github-com-mdlayher-wifi 0.3.0
Propagated dependencies: go-github-com-mdlayher-genetlink@1.3.2 go-github-com-mdlayher-netlink@1.7.2 go-golang-org-x-crypto@0.53.0 go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/mdlayher/wifi
Licenses: Expat
Build system: go
Synopsis: Access to IEEE 802.11 WiFi device actions
Description:

Package wifi provides access to IEEE 802.11 WiFi device operations on Linux using nl80211.

go-go-opentelemetry-io-contrib-detectors-aws-ec2-v2 2.5.0
Propagated dependencies: go-github-com-aws-aws-sdk-go-v2@1.41.7 go-github-com-aws-aws-sdk-go-v2-config@1.32.17 go-github-com-aws-aws-sdk-go-v2-feature-ec2-imds@1.18.17 go-github-com-aws-smithy-go@1.24.0 go-go-opentelemetry-io-otel@1.42.0 go-go-opentelemetry-io-otel-sdk@1.33.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/open-telemetry/opentelemetry-go-contrib
Licenses: ASL 2.0
Build system: go
Synopsis: Resource detector for EC2 instances
Description:

Package ec2 provides a resource detector for Amazon Elastic Compute Cloud instances using aws-sdk-go-v2.

Total packages: 33008