_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


go-github-com-puerkitobio-urlesc 0.0.0-20170810143723-de5bf2ad4578
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/PuerkitoBio/urlesc
Licenses: Modified BSD
Build system: go
Synopsis: Proper URL escaping as per RFC 3986
Description:

Package urlesc implements query escaping as per RFC 3986. It contains some parts of the net/url package, modified so as to allow some reserved characters incorrectly escaped by net/url.

go-github-com-gogo-status 1.1.1
Propagated dependencies: go-github-com-gogo-googleapis@1.4.1 go-github-com-gogo-protobuf@1.3.2 go-github-com-golang-protobuf@1.5.4 go-google-golang-org-grpc@1.69.2
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/gogo/status
Licenses: ASL 2.0
Build system: go
Synopsis: Error handling for client/server rRPC-like communication
Description:

Package status implements errors returned by gRPC. These errors are serialized and transmitted on the wire between server and client, and allow for additional data to be transmitted via the Details field in the status proto. gRPC service handlers should return an error created by this package, and gRPC clients should expect a corresponding error to be returned from the RPC call.

go-github-com-realclientip-realclientip-go 1.0.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/realclientip/realclientip-go
Licenses: Zero-Clause BSD
Build system: go
Synopsis: Go reference implementation of "real" client IP algorithms
Description:

Package realclientip provides strategies for obtaining the "real" client IP from HTTP requests.

snowflake-proxy 2.14.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/snowflake
Licenses: Modified BSD
Build system: go
Synopsis: Pluggable Transport using WebRTC, inspired by Flashproxy
Description:

This package provides a standalone (not browser-based) version of the Snowflake proxy. For browser-based versions of the Snowflake proxy, see snowflake-webext.

go-0xacab-org-leap-menshen 1.8.1
Propagated dependencies: go-0xacab-org-leap-lb@0.0.0-20210225193050-570f848edccf go-github-com-emirpasic-gods-v2@2.0.0-alpha go-github-com-go-openapi-errors@0.22.1 go-github-com-go-openapi-runtime@0.26.2 go-github-com-go-openapi-strfmt@0.23.0 go-github-com-go-openapi-swag@0.23.0 go-github-com-go-openapi-validate@0.24.0 go-github-com-jmoiron-sqlx@1.4.0 go-github-com-kellydunn-golang-geo@0.7.0 go-github-com-labstack-echo-v4@4.15.2 go-github-com-mattn-go-sqlite3@1.14.34 go-github-com-prometheus-client-golang@1.23.2 go-github-com-rs-zerolog@1.33.0 go-github-com-spf13-cobra@1.10.2 go-github-com-spf13-pflag@1.0.10 go-github-com-spf13-viper@1.8.1 go-github-com-swaggo-echo-swagger@1.4.1 go-github-com-swaggo-swag@1.16.4 go-github-com-tidwall-cities@0.1.0 go-golang-org-x-crypto@0.53.0 go-golang-org-x-exp@0.0.0-20250911091902-df9299821621 go-gonum-org-v1-gonum@0.16.0 go-google-golang-org-grpc@1.69.2 go-gopkg-in-yaml-v2@2.4.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://0xacab.org/leap/menshen
Licenses: GPL 3
Build system: go
Synopsis: Gateway & bridge distribution service for LEAP VPN
Description:

menshen is a resource distributor for LEAP VPN. Here, resource means information for accessing either gateways, bridges, or a combination of the two. This information includes not only endpoint discovery but also credentials (although the credential distribution is not fully integrated at this point). In chinese folk religions, menshen are guardians of doors and gates.

go-github-com-peterbourgon-unixtransport 0.0.4
Propagated dependencies: go-github-com-miekg-dns@1.1.72 go-github-com-oklog-run@1.1.0 go-github-com-peterbourgon-ff-v3@3.4.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/peterbourgon/unixtransport
Licenses: ASL 2.0
Build system: go
Synopsis: Support for Unix domain sockets in Go HTTP clients
Description:

This package adds support for Unix domain sockets in Go HTTP clients.

go-github-com-gregjones-httpcache 0.0.0-20190611155906-901d90724c79
Propagated dependencies: go-github-com-peterbourgon-diskv@3.0.0 go-github-com-syndtr-goleveldb@1.0.0 go-github-com-bradfitz-gomemcache@0.0.0-20230905024940-24af94b03874 go-github-com-gomodule-redigo@1.9.2
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/gregjones/httpcache
Licenses: Expat
Build system: go
Synopsis: Transport for @code{http.Client} that will cache responses
Description:

Package httpcache provides a http.RoundTripper implementation that works as a mostly RFC 7234 compliant cache for HTTP responses. It is only suitable for use as a "private" cache (i.e. for a web-browser or an API-client and not for a shared proxy).

go-github-com-ncw-swift-v2 2.0.3
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/ncw/swift
Licenses: Expat
Build system: go
Synopsis: Interface to various cloud storage APIs
Description:

Package swift provides an easy to use interface to Swift / Openstack Object Storage / Rackspace Cloud Files.

go-github-com-tv42-httpunix 0.0.0-0.2ba4b9c
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/tv42/httpunix
Licenses: Expat
Build system: go
Synopsis: Go library to talk HTTP over Unix domain sockets
Description:

This package is a Go library to talk HTTP over Unix domain sockets.

go-github-com-docker-go-connections 0.5.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/docker/go-connections
Licenses: ASL 2.0
Build system: go
Synopsis: Networking library for Go
Description:

This package provides a library to work with network connections in the Go language. In particular it provides tools to deal with network address translation (NAT), proxies, sockets, and transport layer security (TLS).

go-github-com-go-webauthn-webauthn 0.10.2
Propagated dependencies: go-github-com-fxamacker-cbor-v2@2.9.2 go-github-com-go-webauthn-x@0.1.12 go-github-com-golang-jwt-jwt-v5@5.3.1 go-github-com-google-go-tpm@0.9.8 go-github-com-google-uuid@1.6.0 go-github-com-mitchellh-mapstructure@1.5.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/go-webauthn/webauthn
Licenses: Modified BSD
Build system: go
Synopsis: Webauthn/FIDO2 library for Golang
Description:

This library is meant to handle Web Authentication for Go apps that wish to implement a passwordless solution for users. This library conforms as much as possible to the guidelines and implementation procedures outlined by the document. It's a successor of not maintained https://github.com/duo-labs/webauthn library.

go-github-com-labbsr0x-goh 1.0.1
Propagated dependencies: go-github-com-go-cmd-cmd@1.4.3 go-github-com-go-errors-errors@1.5.1 go-github-com-sirupsen-logrus@1.9.3
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/labbsr0x/goh
Licenses: Expat
Build system: go
Synopsis: Utility library for writing web hooks
Description:

This package provides an utility library for writing extremely simple webhooks in Golang.

go-github-com-pion-stun-v3 3.1.1
Propagated dependencies: go-github-com-pion-dtls-v3@3.1.2 go-github-com-pion-logging@0.2.4 go-github-com-pion-transport-v4@4.0.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/pion/stun
Licenses: Expat
Build system: go
Synopsis: Go implementation of STUN
Description:

Package stun implements Session Traversal Utilities for +NAT (STUN) (RFC 5389) protocol and +client with no external +dependencies and zero allocations in hot paths. Client +supports automatic +request retransmissions.

go-github-com-aws-aws-lambda-go 1.47.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/aws/aws-lambda-go
Licenses: ASL 2.0
Build system: go
Synopsis: AWS Lambda for Go
Description:

Libraries, samples, and tools to help Go developers develop AWS Lambda functions.

go-github-com-grpc-ecosystem-go-grpc-middleware-v2 2.3.4
Propagated dependencies: go-golang-org-x-net@0.53.0 go-golang-org-x-oauth2@0.36.0 go-google-golang-org-grpc@1.69.2 go-google-golang-org-protobuf@1.36.11
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/grpc-ecosystem/go-grpc-middleware
Licenses: ASL 2.0
Build system: go
Synopsis: Golang gRPC Middlewares
Description:

This package provides gRPC Go Middlewares: interceptors, helpers and utilities - middleware that is executed either on the gRPC Server before the request is passed onto the user's application logic, or on the gRPC client either around the user call. It is a perfect way to implement common patterns: auth, logging, tracing, metrics, validation, retries, rate limiting and more, which can be a great generic building blocks that make it easy to build multiple microservices easily.

go-github-com-xdg-go-scram 1.1.2
Propagated dependencies: go-github-com-xdg-go-stringprep@1.0.4 go-github-com-xdg-go-pbkdf2@1.0.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/xdg-go/scram
Licenses: ASL 2.0
Build system: go
Synopsis: Go implementation of RFC-5802
Description:

Package scram provides client and server implementations of the Salted Challenge Response Authentication Mechanism described in RFC-5802 and RFC-7677.

go-github-com-letsencrypt-pebble-v2 2.8.0
Propagated dependencies: go-github-com-go-jose-go-jose-v4@4.0.5 go-github-com-letsencrypt-challtestsrv@1.3.3 go-github-com-miekg-dns@1.1.72
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/letsencrypt/pebble
Licenses: MPL 2.0
Build system: go
Synopsis: RFC 8555 ACME test server
Description:

This package provides a miniature version of Boulder, Pebble is a small ACME test server not suited for use as a production CA.

protoc-gen-pico 0.0.4
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://storj.io/picobuf
Licenses: Expat
Build system: go
Synopsis: Replacement for subset of protobuf
Description:

Picobuf is a minimal replacement for google.golang.org/protobuf with focusing on small binary size. It does not support the whole Protocol Buffers feature set and features are added on as the need arises.

go-go-opentelemetry-io-otel-metric 1.42.0
Propagated dependencies: go-github-com-cespare-xxhash-v2@2.3.0 go-github-com-go-logr-logr@1.4.3 go-github-com-go-logr-stdr@1.2.2 go-go-opentelemetry-io-auto-sdk@1.1.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://opentelemetry.io/
Licenses: ASL 2.0
Build system: go
Synopsis: OpenTelemetry Metric API
Description:

Package metric provides an implementation of the metric part of the OpenTelemetry API.

go-github-com-transparency-dev-tessera 1.0.2
Propagated dependencies: go-cloud-google-com-go-spanner@1.91.0 go-cloud-google-com-go-storage@1.60.0 go-github-com-avast-retry-go-v4@4.6.0 go-github-com-aws-aws-sdk-go-v2@1.41.7 go-github-com-aws-aws-sdk-go-v2-config@1.32.17 go-github-com-aws-aws-sdk-go-v2-credentials@1.19.7 go-github-com-aws-aws-sdk-go-v2-service-s3@1.96.0 go-github-com-aws-smithy-go@1.24.0 go-github-com-bitfield-script@0.24.1 go-github-com-cenkalti-backoff-v5@5.0.2 go-github-com-charmbracelet-bubbletea@1.3.10 go-github-com-charmbracelet-lipgloss@1.1.0 go-github-com-dgraph-io-badger-v4@4.9.1 go-github-com-dustin-go-humanize@1.0.1 go-github-com-gdamore-tcell-v2@2.13.9 go-github-com-go-sql-driver-mysql@1.8.1 go-github-com-google-go-cmp@0.7.0 go-github-com-googlecloudplatform-opentelemetry-operations-go-exporter-metric@0.55.0 go-github-com-googlecloudplatform-opentelemetry-operations-go-exporter-trace@1.32.0 go-github-com-hashicorp-golang-lru-v2@2.0.7 go-github-com-muesli-termenv@0.16.0 go-github-com-rivo-tview@0.42.0 go-github-com-robinus2-golang-moving-average@1.0.0 go-github-com-transparency-dev-formats@0.0.0-20251222000000-0e991b4666d9 go-github-com-transparency-dev-merkle@0.0.2 go-go-opentelemetry-io-contrib-detectors-aws-ec2-v2@2.5.0 go-go-opentelemetry-io-contrib-detectors-aws-ecs@1.43.0 go-go-opentelemetry-io-contrib-detectors-gcp@1.42.0 go-go-opentelemetry-io-contrib-propagators-aws@1.36.0 go-go-opentelemetry-io-otel@1.42.0 go-go-opentelemetry-io-otel-exporters-otlp-otlpmetric-otlpmetricgrpc@1.33.0 go-go-opentelemetry-io-otel-exporters-otlp-otlptrace-otlptracegrpc@1.43.0 go-go-opentelemetry-io-otel-metric@1.42.0 go-go-opentelemetry-io-otel-sdk@1.33.0 go-go-opentelemetry-io-otel-sdk-metric@1.33.0 go-golang-org-x-crypto@0.53.0 go-golang-org-x-exp@0.0.0-20250911091902-df9299821621 go-golang-org-x-mod@0.35.0 go-golang-org-x-net@0.53.0 go-golang-org-x-sync@0.21.0 go-golang-org-x-time@0.14.0 go-google-golang-org-api@0.272.0 go-google-golang-org-grpc@1.69.2 go-k8s-io-klog-v2@2.130.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/transparency-dev/tessera
Licenses: ASL 2.0
Build system: go
Synopsis: Go library for building tile-based transparency logs (tlogs)
Description:

Tessera is a Go library for building tile-based transparency logs (tlogs). It is the logical successor to the approach Trillian v1 takes in building and operating logs. The implementation and its APIs bake-in current best-practices based on the lessons learned over the past decade of building and operating transparency logs in production environments and at scale.

go-xorm-io-builder 0.3.13
Propagated dependencies: go-gitea-com-xorm-sqlfiddle@0.0.0-20180821085327-62ce714f951a
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://xorm.io/builder
Licenses: Modified BSD
Build system: go
Synopsis: SQL builder for Go
Description:

Package builder is a simple and powerful SQL builder for Golang.

Total packages: 33008