Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
TTLCache is an in-memory cache with item expiration and generics which provides the following features:
simple API
type parameters
item expiration and automatic deletion
automatic expiration time extension on each Get call
loader interface that may be used to load/lazily initialize missing citem items
thread safety
event handlers (insertion, update, and eviction)
metrics
This package provides a OAuth 1.0 consumer implementation as specified in http://www.oauth.net and RFC 5849.
This package provides a Go module that analyzes and classifies different kinds of referrer URLs (search, social, ...).
libdns is a collection of free-range DNS provider client implementations. It defines the core interfaces that provider packages should implement. They are small and idiomatic interfaces with well-defined semantics.
The interfaces include:
RecordGetter to list records.
RecordAppender to append new records.
RecordSetter to set (create or change existing) records.
RecordDeleter to delete records.
This package provides the socks5 package that implements a SOCKS5 server. SOCKS (Secure Sockets) is used to route traffic between a client and server through an intermediate proxy layer. This can be used to bypass firewalls or NATs. It's an alternative fork of https://github.com/armon/go-socks5.
This package provides a collection of utilities for Pluggable Transports.
Package jaeger implements the Jaeger propagator specification as defined at https://www.jaegertracing.io/docs/1.18/client-libraries/#propagation-format.
This package provides an SDK for developing projects with Cloudinary in Go.
The html2text package converts HTML emails to plain text, allowing text-only mail clients to display them.
go-netroute provides an implementation of the gopacket/routing.Router interface for Golang.
This package implements semantic processing of JSON as specified in RFC 8259. JSON is a simple data interchange format that can represent primitive data types such as booleans, strings, and numbers, in addition to structured data types such as objects and arrays.
This package implements the SMB2/3 client in Go.
Package netem is a framework to write integration tests that use TCP/IP stacks implemented in userspace.
This Package provides facilities for running metamorphic, property-based testing. By running logically equivalent operations with different conditions, metamorphic tests can identify bugs without requiring an oracle.
This package implements a simple HTTP prober which may be used to check endpoint health status.
This package implements the Model Context Protocol, including clients and servers using standard transports.
Package jsonschema provides json-schema compilation and validation.
Package stringutils exposes helpers to search and process strings.
JSON Patch implementation for Go as specified in RFC 6902 from the IETF.
JSON Patch allows you to generate JSON that describes changes you want to make to a document, so you don't have to send the whole doc. JSON Patch format is supported by HTTP PATCH method, allowing for standards based partial updates via REST APIs.
This package provides the Golang definitions and protocol interfaces for interacting with the etcd v3 API.
Package httprouter is a trie based high performance HTTP request router.
This package provides a tun2socks implementation written in Go.
This is an extension to the Tink Go library that provides support for Google Cloud KMS.